2.13. Замечания по установке Perl


2.13. Замечания по установке Perl

2.13.1. Установка Perl на Unix
2.13.2. Установка Perl ActiveState на Windows
2.13.3. Проблемы Используя Perl DBI/DBDИнтерфейс

Perl DBI модуль обеспечивает универсальный интерфейс для доступа к базе данных. Можно записать a DBI сценарий, который работает со многими различными механизмами базы данных без изменения. Использовать DBI, следует установить DBI модуль, так же как Драйвер DataBase (DBD) модуль для каждого типа сервера базы данных Вы хотите получить доступ. Для MySQL этот драйвер DBD::mysql модуль.

Perl, и DBD::MySQL модуль для DBI должен быть установлен, если Вы хотите выполнить сценарии сравнительного теста MySQL; см. Раздел 8.12.2, "MySQL Benchmark Suite".

Отметить

Поддержка Perl не включается с дистрибутивами MySQL. Можно получить необходимые модули из http://search.cpan.org для Unix, или при использовании программы стр/мин ActiveState на Windows. Следующие разделы описывают, как сделать это.

DBI/DBD интерфейс требует Perl 5.6.0, и 5.6.1 или позже предпочитается. DBI не работает, если у Вас есть более старая версия Perl. Следует использовать DBD::mysql 4.009 или выше. Хотя более ранние версии доступны, они не поддерживают полную функциональность MySQL 5.6.




Spec-Zone.ru - all specs in one place