Определения строки меню

Строка меню содержит набор меню, разрешающих Вам управлять Инструментами и зарегистрированными данными. Каждое меню содержит список команд, сгруппированных функцией.

Инструментальное меню

Меню Instruments обеспечивает команды для отображения окна Instruments.

  Меню Table 2-1 Instruments

Команда

Описание

Об инструментах

Обеспечивает информацию о версии для Инструментов.

Предпочтения

Открывает Предпочтительное диалоговое окно.

Службы

Открывает диалоговый набор Клавиатуры для сочетаний клавиш Services.

Скройте инструменты

Скрывает все окна Instruments.

Скройте других

Скрывает все дисплеи за исключением Инструментов.

Покажите все

Дисплеи все скрытые процессы.

Инструменты выхода

Завершения все документы трассировки и закрывают Инструменты. Пользователя спрашивают, хотят ли они сохранить какие-либо несохраненные данные.

Меню файла

Меню File обеспечивает команды для создания, импорта, сохранения и выполнения документов трассировки.

  Меню Table 2-2 File

Команда

Описание

Новый

Создает новый документ трассировки.

Открытый

Открывает сохраненный документ трассировки.

Откройте Recent

Открывает недавно сохраненный документ трассировки.

Данные импорта

Открывает диалоговое окно Трассировки Импорта разрешение Вам загрузить ранее сохраненные данные.

Получите информацию

Открывает диалоговое окно конфигурации для выбранного инструмента.

Близко

Закрывает выбранный документ трассировки.

Сохранить

Сохраняет выбранный документ трассировки. Просит имя и место назначения, если это - первый раз, когда документ трассировки был сохранен.

Сохраните как

Сохраняет выбранный документ трассировки в определяемом расположении.

Сохраните как шаблон

Сохраняет текущий набор инструментов как шаблон трассировки. К шаблонам трассировки можно получить доступ от Инструментов стартовое диалоговое окно.

Рекордная трассировка

Записи прослеживают данные с помощью текущих инструментов.

Трассировка паузы

Приостанавливает в настоящее время рабочую трассировку.

Цикл

Определяет, циклично выполнится ли устройство записи пользовательского интерфейса во время, воспроизводят для повторения зарегистрированных шагов постоянно.

Рекордные опции

Открывает Рекордное диалоговое окно Опций. Если данные собраны в задержанном режиме, позволяет Вам устанавливать задержку запуска, ограничение по времени, предел окна.

Импорт данных DTrace

Позволяет Вам импортировать ранее собранные данные DTrace.

Импорт сценария DTrace

Позволяет Вам импортировать ранее создаваемые сценарии DTrace.

Энергетическая диагностика импорта от устройства

Импортирует энергетические журналы из устройства на iOS.

Документ Re-Symbolicate

Открывает symbolication диалоговое окно. Позволяет Вам устанавливать пути и файлы, используемые при поиске символов.

Меню редактирования

Меню Edit обеспечивает команды для текстового манипулирования, включая написание, грамматику и возможности поиска. Вы можете также re-symbolicate документ трассировки.

  Меню Table 2-3 Edit

Команда

Описание

Отмена

Удаляет ранее введенные инструкции.

Восстановление

Применяет инструкции, ранее удаленные Отменой.

Сокращение

Удаляет выделенный текст из документа.

Копия

Копирует выбранный пункт в Буфер обмена.

Глубокая копия

Копирует выбранный пункт и все элементы, содержавшиеся в нем на Буфере обмена.

Вставка

Вставляет текущую информацию, хранившую на Буфере обмена в выбранный документ.

Вставьте и соответствуйте стиль

Вставляет текущую информацию, хранившую на Буфере обмена в выбранный документ, и использует информацию о стилях документа для данных.

Удалить

Удаляет выбранный пункт.

Выберите All

Выбирает все доступные элементы.

Найти

Позволяет Вам искать элемент. Содержит пять подопций:

  • Найдите: Открывает поле поиска и ищет первую инстанцию входного текста.

  • Найдите Затем: Открывает поле поиска и ищет следующий экземпляр входного текста.

  • Сочтите Предыдущими: Открывает поле поиска и ищет предыдущий экземпляр входного текста.

  • Используйте Выбор для Нахождения: Открывает поле поиска и использует выделенный выбор в качестве ввода.

  • Переход к Выбору: Переходы к текущему выбору.

Написание

Обеспечивает написание и опции грамматики для документа. Содержит три подопции:

  • Покажите Написание и Грамматику: Открывает диалоговое окно Grammar и Spelling.

  • Проверка орфографии: Выполняет написание, проверяют документ.

  • Проверка орфографии При Вводе: Выполняет проверку написания при вводе в документе.

Добавьте флаг

Добавляет новый флаг к области дорожки.

Удалите флаг

Удаляет существующий флаг из области дорожки.

Специальные символы

Открывает окно Characters.

Меню представления

Меню View обеспечивает команды для управления окном Instruments.

  Меню Table 2-4 View

Команда

Описание

Инструменты

Открывает и закрывает область Instruments.

Подробность

Открывает и закрывает область Detail.

Расширенная подробность

Открывает и закрывает область Extended Detail.

Выполненный браузер

Режим браузера переключателей на и прочь.

Полный экран

Инструменты переключателей в и из полноэкранного режима.

Мини-инструменты

Инструменты переключателей в и из мини-режима.

Проверьте флаг

Открывает диалоговое окно флага.

Следующий флаг

Переходы к следующему флагу в области дорожки.

Предыдущий флаг

Переходы к предыдущему флагу в области дорожки.

Размер деки уменьшения

Уменьшает высоту инструмента.

Размер деки увеличения

Увеличивает высоту инструмента.

Поспешная дорожка для адаптации

Изменяет размеры собранных данных так, чтобы они соответствовали точно в области дорожки.

Оставленный кругооборот транспорта

Не используемый.

Право кругооборота транспорта

Не используемый.

Скройте панель инструментов

Скрывает панель инструментов Instruments.

Настройте панель инструментов

Открывает диалоговое окно панели инструментов Instruments.

Инструментальное меню

Меню Instrument обеспечивает команды для сбора и записи данных трассировки.

  Меню Table 2-5 Instrument

Команда

Описание

Создайте новый инструмент

Открывает Инструментальное диалоговое окно Сборки.

Инструмент редактирования

Открывает Инструментальное диалоговое окно Сборки, заполненное информацией выбранного инструмента.

Удалите <Инструментальное Имя> Инструмент

Удаляет выбранный инструмент из документа трассировки.

Удалите выполненный <#>

Удаляет выбранный сбор данных, выполненный из документа трассировки.

Символ трассировки

Переводит диалоговое окно символа трассировки в рабочее состояние. Позволяет Вам прослеживать определенный символ.

Позвольте записать

Позволяет Вам записывать данные.

Дорожка экспорта для <Инструментальное имя - процесс>

Сохраняет собранную информацию для инструмента / перечисленная комбинация процесса.

Сравните деревья вызова

Сравнивает дерево вызова текущего выполнения с деревьями вызова предыдущих выполнений.

Вызовите древовидный анализ данных

Позволяет Вам управлять деревом вызова в области Detail.

Меню окна

Меню окна обеспечивает команды, изменяющие размеры окна Instruments вместе с управлением события PM и флаги.

Табличное 2-6  Меню окна

Команда

Описание

Минимизировать

Минимизирует окно Instruments к прикреплению.

Изменение масштаба

Увеличивает окно Instruments к размеру Вашего видеомонитора при оставлении строки меню доступной.

Библиотека

Открывает и закрывает область Library.

Управляйте флагами

Открывает диалоговое окно Флага. Можно отредактировать информацию о флаге от этого диалогового окна.

Управляйте событиями PM

Открывает диалоговое окно Событий премьер-министра. Можно выбрать события PM для контроля от этого диалогового окна.

Перенесите все на передний план

Выявляет все окна Instruments экрана.

Инструменты <#>

Делает выбранный Инструментальный экземпляр активным.