B.3.2.11 Невозможно создать/записать в файл
Если для некоторых запросов вы получаете ошибку следующего типа, это означает, что MySQL не может создать временный файл для набора результатов в временном каталоге:
Can't create/write to file '\\sqla3fe_0.ism'.
Представленная выше ошибка является типичным сообщением для Windows; сообщение для Unix аналогично.
Одним из способов решения проблемы является запуск mysqld с параметром --tmpdir или добавление этого параметра в раздел [mysqld] файла конфигурации. Например, для указания каталога C:\temp используйте следующие строки:
[mysqld]
tmpdir=C:/temp
Каталог C:\temp должен существовать и иметь достаточное пространство для записи в него сервером MySQL. См. Раздел 4.2.2.2, “Использование файлов конфигурации”.
Другой причиной этой ошибки могут быть проблемы с правами доступа. Убедитесь, что сервер MySQL имеет права на запись в каталог tmpdir.
Также проверьте код ошибки, который вы получаете с помощью perror. Одна из причин, по которой сервер не может записать в таблицу, — это заполненная файловая система:
$> perror 28
OS error code 28: No space left on device
Если вы получаете ошибку следующего типа во время запуска, это указывает на то, что файловая система или каталог, используемые для хранения файлов данных, защищены от записи. При условии, что ошибка записи относится к тестовому файлу, эта ошибка несерьёзна и может быть безопасно проигнорирована.
Can't create test file /usr/local/mysql/data/master.lower-test
© 2025 Oracle
Licensed under the GPLv2 License.