B.3.2.15 Не удаётся инициализировать кодировку
Вы можете увидеть такую ошибку, если у вас проблемы с кодировкой:
MySQL Connection Failed: Can't initialize character set charset_name
Эта ошибка может быть вызвана следующими причинами:
-
Кодировка является многобайтовой, а клиент не поддерживает её. В этом случае необходимо перекомпилировать клиент, запустив CMake с параметром
-DDEFAULT_CHARSET=илиcharset_name-DWITH_EXTRA_CHARSETS=. См. Раздел 2.8.7, «Параметры конфигурации источника MySQL».charset_nameВсе стандартные двоичные файлы MySQL скомпилированы с параметром
-DWITH_EXTRA_CHARSETS=complex, который включает поддержку всех многобайтовых кодировок. См. Раздел 2.8.7, «Параметры конфигурации источника MySQL». -
Кодировка является простой, не скомпилированной в mysqld, а файлы определения кодировки не находятся в месте, где клиент их ожидает.
В этом случае необходимо использовать один из следующих методов для решения проблемы:
Перекомпилируйте клиент с поддержкой кодировки. См. Раздел 2.8.7, «Параметры конфигурации источника MySQL».
Укажите клиенту каталог, где находятся файлы определения кодировки. Для многих клиентов это можно сделать с помощью параметра
--character-sets-dir.Скопируйте файлы определения кодировки в каталог, где их ожидает клиент.
© 2025 Oracle
Licensed under the GPLv2 License.