check_point.mgmt.cp_mgmt_set_ha_state модуль — Состояние высокой доступности сервера домена коммутатора.
Примечание
Этот модуль входит в коллекцию check_point.mgmt (версия 5.2.3).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не включена в ansible-core. Чтобы проверить её установку, выполните ansible-galaxy collection list.
Чтобы установить её, используйте: ansible-galaxy collection install check_point.mgmt.
Чтобы использовать её в плейбуке, укажите: check_point.mgmt.cp_mgmt_set_ha_state.
Добавлен в check_point.mgmt 5.0.0
Описание
- Переключение состояния высокой доступности сервера домена коммутатора. После переключения сервера домена в состояние ожидания сессия истекает, и вам необходимо снова войти в систему.
Вы можете выполнить эту команду с пользователем или глобальным доменом на сервере с несколькими доменами и с домена пользователя на сервере управления безопасностью. - Все операции выполняются через веб-сервис API.
Параметры
Параметр |
Комментарии |
|---|---|
auto_publish_session boolean |
Опубликовать текущую сессию, если после завершения задачи были внесены изменения. Варианты:
|
ignore_errors boolean |
Применить изменения, игнорируя ошибки. Варианты:
|
new_state string |
Новое состояние сервера домена. Варианты:
|
| ... | ... |
Примеры
- name: set-ha-state
cp_mgmt_set_ha_state:
new_state: active
Возвращаемые значения
Общие возвращаемые значения описаны здесь, следующие поля уникальны для этого модуля:
Ключ |
Описание |
|---|---|
cp_mgmt_set_ha_state dictionary |
Вывод модуля checkpoint set-ha-state. Возвращается: всегда. |
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2024 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/latest/collections/check_point/mgmt/cp_mgmt_set_ha_state_module.html