Модуль f5networks.f5_modules.bigip_pool_member – управление участниками пулов F5 BIG-IP LTM
Примечание
Этот модуль входит в коллекцию f5networks.f5_modules (версия 1.39.0).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.
Чтобы установить её, используйте: ansible-galaxy collection install f5networks.f5_modules.
Чтобы использовать её в плейбуке, укажите: f5networks.f5_modules.bigip_pool_member.
Добавлено в f5networks.f5_modules 1.0.0
Краткое описание
- Управляет участниками пулов F5 BIG-IP LTM через REST API.
Параметры
Параметр | Комментарии |
|---|---|
address aliases: ip, host string | IP-адрес участника пула. Это может быть IPv4- или IPv6-адрес. При создании нового участника пула необходимо указать либо |
aggregate aliases: members list / elements=dictionary | Список определений участников пула для создания, изменения или удаления. При использовании Модуль НЕ отменит изменения, внесённые до обнаружения ошибки. Модуль также не укажет, какие изменения были внесены до сбоя. Поэтому настоятельно рекомендуем запускать модуль в режиме |
|
address aliases: ip, host string |
IP-адрес участника пула. Это может быть IPv4- или IPv6-адрес. При создании нового участника пула необходимо указать либо |
|
availability_requirements dictionary |
Если активировано несколько мониторов работоспособности, задаёт количество мониторов, которые должны получить успешные ответы, чтобы канал считался доступным. Указание пустой строки удалит мониторы и вернёт наследование настроек пула (по умолчанию). Указание |
|
at_least integer |
Задаёт минимальное количество активных мониторов работоспособности, которые должны успешно пройти проверку, чтобы канал считался доступным. Этот параметр актуален только при использовании Этот параметр игнорируется, если используется тип |
|
type string / обязательный |
Тип правила монитора, если указано При создании нового пула, если это значение не указано, будет использоваться значение по умолчанию Варианты:
|
|
connection_limit integer |
Ограничение количества подключений участника пула. Значение |
|
description string |
Описание участника пула. |
|
fqdn aliases: hostname string |
Полное доменное имя участника пула (FQDN). Это может быть любое имя, соответствующее требованиям к DNS-именам RFC 1123. Поэтому допустимы только символы от «A» до «Z», от «a» до «z», от «0» до «9», дефис («-») и точка («.»). Имена FQDN должны содержать хотя бы одну точку, отделяющую имя узла от домена. Например, Имена FQDN должны заканчиваться буквой или цифрой. При создании нового участника пула необходимо указать либо |
|
fqdn_auto_populate boolean |
Указывает, создаёт ли система автоматически временные узлы, используя IP-адреса, полученные при разрешении DNS-запроса для узла, заданного с помощью FQDN. Если задано значение Если задано значение При создании нового участника пула для этого параметра по умолчанию используется значение После установки этот параметр нельзя изменить. Этот параметр игнорируется, если Варианты:
|
|
ip_encapsulation string |
Задаёт инкапсуляцию IP с использованием IPIP (инкапсуляция IP в IP, RFC 2003) или GRE (инкапсуляция Generic Router, RFC 2784) для исходящих пакетов (от системы BIG-IP к участнику пула серверов). Если задано значение Если задано значение При любом другом значении доступны варианты None, Inherit from Pool и Member Specific. |
|
monitors list / elements=string |
Задаёт мониторы работоспособности, которые система в данный момент использует для мониторинга этого ресурса. |
|
name string |
Имя узла, который нужно создать или повторно использовать при создании нового участника пула. Этот параметр необязателен, однако для предотвращения непредвиденного поведения рекомендуем всегда указывать его. Если параметр не указан, имя узла создаётся автоматически из заданного значения Состояние |
|
partition string |
Раздел, в котором будут управляться ресурсы. По умолчанию: |
|
port integer |
Порт участника пула. После установки это значение нельзя изменить. При использовании агрегатов параметр необходимо указать. |
|
preserve_node boolean |
Если состояние равно Узел не будет удалён, если на него ссылаются другие участники пула. В этом случае модуль не выдаст ошибку. Значение Варианты:
|
|
priority_group integer |
Задаёт номер группы приоритета для участника пула. При добавлении нового участника по умолчанию используется значение Чтобы задать приоритет, необходимо включить использование групп приоритета при создании нового пула или при добавлении либо удалении участников пула. Если эта функция включена, система балансирует нагрузку, учитывая номер группы приоритета, присвоенный участнику пула. Чем выше число, тем выше приоритет. Таким образом, участник с приоритетом 3 имеет более высокий приоритет, чем участник с приоритетом 1. |
|
rate_limit integer |
Ограничение скорости передачи данных для участника пула (количество подключений в секунду). Значение |
|
ratio integer |
Весовой коэффициент участника пула. Допустимые значения — от 1 до 100. Для новых участников пула по умолчанию используется значение 1, если оно не переопределено этим параметром. |
|
reuse_nodes boolean |
Повторно использует определения узлов, если это запрошено. Варианты:
|
|
state string |
Состояние участника пула. Варианты:
|
availability_requirements dictionary | Если активировано несколько мониторов работоспособности, задаёт количество мониторов, которые должны получить успешные ответы, чтобы канал считался доступным. Указание пустой строки удалит мониторы и вернёт наследование настроек пула (по умолчанию). Указание |
|
at_least integer |
Задаёт минимальное количество активных мониторов работоспособности, которые должны успешно пройти проверку, чтобы канал считался доступным. Этот параметр актуален только при использовании Этот параметр игнорируется, если используется тип |
|
type string / обязательный |
Тип правила монитора, если указано При создании нового пула, если это значение не указано, будет использоваться значение по умолчанию Варианты:
|
connection_limit integer | Ограничение количества подключений участника пула. Значение |
description string | Описание участника пула. |
fqdn aliases: hostname string | Полное доменное имя участника пула (FQDN). Это может быть любое имя, соответствующее требованиям к DNS-именам RFC 1123. Поэтому допустимы только символы от «A» до «Z», от «a» до «z», от «0» до «9», дефис («-») и точка («.»). Имена FQDN должны содержать хотя бы одну точку, отделяющую имя узла от домена. Например, Имена FQDN должны заканчиваться буквой или цифрой. При создании нового участника пула необходимо указать либо |
fqdn_auto_populate boolean | Указывает, создаёт ли система автоматически временные узлы, используя IP-адреса, полученные при разрешении DNS-запроса для узла, заданного с помощью FQDN. Если задано значение Если задано значение При создании нового участника пула для этого параметра по умолчанию используется значение После установки этот параметр нельзя изменить. Этот параметр игнорируется, если Варианты:
|
ip_encapsulation string | Задаёт инкапсуляцию IP с использованием IPIP (инкапсуляция IP в IP, RFC 2003) или GRE (инкапсуляция Generic Router, RFC 2784) для исходящих пакетов (от системы BIG-IP к участнику пула серверов). Если задано значение Если задано значение При любом другом значении доступны варианты None, Inherit from Pool и Member Specific. |
monitors list / elements=string | Задаёт мониторы работоспособности, которые система в данный момент использует для мониторинга этого ресурса. |
name string | Имя узла, который нужно создать или повторно использовать при создании нового участника пула. Этот параметр необязателен, однако для предотвращения непредвиденного поведения рекомендуем всегда указывать его. Если параметр не указан, имя узла создаётся автоматически из заданного значения Состояние |
partition string | Раздел, в котором будут управляться ресурсы. По умолчанию: |
pool string / обязательный | Имя пула. Этот пул должен существовать. |
port integer | Порт участника пула. После установки это значение нельзя изменить. При использовании агрегатов параметр необходимо указать. |
preserve_node boolean | Если состояние равно Узел не будет удалён, если на него ссылаются другие участники пула. В этом случае модуль не выдаст ошибку. Значение Варианты:
|
priority_group integer | Задаёт номер группы приоритета для участника пула. При добавлении нового участника по умолчанию используется значение Чтобы задать приоритет, необходимо включить использование групп приоритета при создании нового пула или при добавлении либо удалении участников пула. Если эта функция включена, система балансирует нагрузку, учитывая номер группы приоритета, присвоенный участнику пула. Чем выше число, тем выше приоритет. Таким образом, участник с приоритетом 3 имеет более высокий приоритет, чем участник с приоритетом 1. |
provider dictionary добавлено в f5networks.f5_modules 1.0.0 | Объект dict, содержащий сведения для подключения. |
|
auth_provider string |
Настраивает поставщика аутентификации для получения токенов аутентификации с удалённого устройства. Этот параметр используется главным образом при работе с устройствами BIG-IQ. |
|
no_f5_teem boolean |
Если задано значение Этот параметр можно не указывать, задав переменную среды Ранее использовавшаяся переменная Варианты:
|
|
password aliases: pass, pwd string / обязательный |
Пароль учётной записи пользователя, используемой для подключения к BIG-IP или BIG-IQ. Этот параметр можно не указывать, задав переменную среды |
|
server string / required |
Имя хоста BIG-IP или BIG-IQ. Этот параметр можно не указывать, задав переменную окружения |
|
server_port integer |
Порт сервера BIG-IP. Этот параметр можно не указывать, задав переменную окружения По умолчанию: |
|
timeout integer |
Задает время ожидания в секундах при подключении к сетевому устройству или отправке ему команд. Если время ожидания истечет до завершения операции, модуль завершится с ошибкой. |
|
transport string |
Настраивает транспортное соединение для подключения к удаленному устройству. Варианты:
|
|
user string / обязательный |
Имя пользователя для подключения к BIG-IP или BIG-IQ. У этого пользователя должны быть права администратора на устройстве. Этот параметр можно не указывать, задав переменную окружения |
|
validate_certs boolean |
Если Этот параметр можно не указывать, задав переменную окружения Варианты:
|
rate_limit integer | Ограничение скорости для участника пула (количество подключений в секунду). Значение |
ratio integer | Весовой коэффициент участника пула. Допустимые значения — от 1 до 100. Для новых участников пула по умолчанию используется значение 1, если оно не переопределено этим параметром. |
replace_all_with псевдонимы: purge boolean | Удаляет участников, не указанных в параметре Операция выполняется целиком или не выполняется вовсе: она будет остановлена, если невозможно удалить некоторых участников пула. Варианты:
|
reuse_nodes boolean | Повторно использует определения узлов, если это указано. Варианты:
|
state string | Состояние участника пула. Варианты:
|
Примечания
Примечание
- Дополнительные сведения об использовании Ansible для управления устройствами F5 Networks см. на странице https://www.ansible.com/integrations/networks/f5.
- Требуется BIG-IP версии >= 12.
- Модули F5 изменяют только текущую конфигурацию продукта F5. Чтобы обеспечить сохранение конфигурации BIG-IP на диске, добавьте хотя бы одну задачу, использующую модуль f5networks.f5_modules.bigip_config для сохранения текущей конфигурации. Инструкции по использованию модуля для сохранения текущей конфигурации см. в документации модуля.
Примеры
- name: Add pool member
bigip_pool_member:
pool: my-pool
partition: Common
name: my-member
host: "{{ ansible_default_ipv4['address'] }}"
port: 80
description: web server
connection_limit: 100
rate_limit: 50
ratio: 2
provider:
server: lb.mydomain.com
user: admin
password: secret
delegate_to: localhost
- name: Modify pool member ratio and description
bigip_pool_member:
pool: my-pool
partition: Common
name: my-member
host: "{{ ansible_default_ipv4['address'] }}"
port: 80
ratio: 1
description: nginx server
provider:
server: lb.mydomain.com
user: admin
password: secret
delegate_to: localhost
- name: Remove pool member from pool
bigip_pool_member:
state: absent
pool: my-pool
partition: Common
name: my-member
host: "{{ ansible_default_ipv4['address'] }}"
port: 80
provider:
server: lb.mydomain.com
user: admin
password: secret
delegate_to: localhost
- name: Force pool member offline
bigip_pool_member:
state: forced_offline
pool: my-pool
partition: Common
name: my-member
host: "{{ ansible_default_ipv4['address'] }}"
port: 80
provider:
server: lb.mydomain.com
user: admin
password: secret
delegate_to: localhost
- name: Create members with priority groups
bigip_pool_member:
pool: my-pool
partition: Common
host: "{{ item.address }}"
name: "{{ item.name }}"
priority_group: "{{ item.priority_group }}"
port: 80
provider:
server: lb.mydomain.com
user: admin
password: secret
delegate_to: localhost
loop:
- address: 1.1.1.1
name: web1
priority_group: 4
- address: 2.2.2.2
name: web2
priority_group: 3
- address: 3.3.3.3
name: web3
priority_group: 2
- address: 4.4.4.4
name: web4
priority_group: 1
- name: Add pool members aggregate
bigip_pool_member:
pool: my-pool
aggregate:
- host: 192.168.1.1
partition: Common
port: 80
description: web server
connection_limit: 100
rate_limit: 50
ratio: 2
- host: 192.168.1.2
partition: Common
port: 80
description: web server
connection_limit: 100
rate_limit: 50
ratio: 2
- host: 192.168.1.3
partition: Common
port: 80
description: web server
connection_limit: 100
rate_limit: 50
ratio: 2
provider:
server: lb.mydomain.com
user: admin
password: secret
delegate_to: localhost
- name: Add pool members aggregate, remove non aggregates
bigip_pool_member:
pool: my-pool
aggregate:
- host: 192.168.1.1
partition: Common
port: 80
description: web server
connection_limit: 100
rate_limit: 50
ratio: 2
- host: 192.168.1.2
partition: Common
port: 80
description: web server
connection_limit: 100
rate_limit: 50
ratio: 2
- host: 192.168.1.3
partition: Common
port: 80
description: web server
connection_limit: 100
rate_limit: 50
ratio: 2
replace_all_with: true
provider:
server: lb.mydomain.com
user: admin
password: secret
delegate_to: localhost
Возвращаемые значения
Общие возвращаемые значения описаны здесь; ниже перечислены поля, уникальные для этого модуля:
Ключ | Описание |
|---|---|
address string | Адрес участника пула. Возвращается: changed Пример: |
connection_limit integer | Новое ограничение количества подключений для участника пула. Возвращается: changed Пример: |
description string | Новое описание участника пула. Возвращается: changed Пример: |
fqdn string | Полное доменное имя участника пула. Возвращается: changed Пример: |
fqdn_auto_populate boolean | Указывает, включено ли автоматическое заполнение FQDN для участника. Возвращается: changed Пример: |
monitors list / elements=string | Новый список мониторов ресурса. Возвращается: changed Пример: |
priority_group integer | Новая группа приоритетов. Возвращается: changed Пример: |
rate_limit integer | Новое ограничение скорости для участника пула (количество подключений в секунду). Возвращается: changed Пример: |
ratio integer | Новый весовой коэффициент участника пула. Возвращается: changed Пример: |
replace_all_with boolean | Удаляет с устройства всех участников пула, не входящих в агрегат. Возвращается: changed Пример: |
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/f5networks/f5_modules/bigip_pool_member_module.html