fortinet.fortimanager.fmgr_firewall_sslsshprofile_dot модуль — Настройка параметров DNS over TLS.
Примечание
Этот модуль является частью коллекции fortinet.fortimanager (версия 2.7.0).
У вас, возможно, уже установлена эта коллекция, если вы используете пакет ansible. Она не входит в ansible-core. Чтобы проверить установку, выполните ansible-galaxy collection list.
Для её установки используйте: ansible-galaxy collection install fortinet.fortimanager.
Чтобы использовать её в плейбуке, укажите: fortinet.fortimanager.fmgr_firewall_sslsshprofile_dot.
Впервые в fortinet.fortimanager 2.1.0
Обзор
- Этот модуль позволяет настроить устройство FortiManager.
- Примеры включают все параметры и значения, которые необходимо настроить из источников данных перед использованием.
Параметры
Параметр | Комментарии |
|---|---|
access_token строка | Токен для доступа к FortiManager без использования имени пользователя и пароля. |
adom строка / обязательный | Параметр (adom) в запрошенном URL. |
bypass_validation булево | Устанавливается в значение True только тогда, когда схема модуля отличается от структуры API FortiManager, модуль продолжает выполнение без проверки параметров. Варианты:
|
enable_log булево | Включить/выключить ведение журнала для задачи. Варианты:
|
firewall_sslsshprofile_dot словарь | Установленные параметры верхнего уровня. |
|
cert-validation-failure строка |
Устарело, пожалуйста, переименуйте на cert_validation_failure. Действие при ошибке проверки сертификата. Варианты:
|
|
cert-validation-timeout строка |
Устарело, пожалуйста, переименуйте на cert_validation_timeout. Действие при истечении срока проверки сертификата. Варианты:
|
|
client-certificate строка |
Устарело, пожалуйста, переименуйте на client_certificate. Действие при получении клиентского сертификата. Варианты:
|
|
expired-server-cert строка |
Устарело, пожалуйста, переименуйте на expired_server_cert. Действие при истечении срока действия серверного сертификата. Варианты:
|
|
min-allowed-ssl-version строка |
Устарело, пожалуйста, переименуйте на min_allowed_ssl_version. Минимально разрешенная версия SSL. Варианты:
|
|
proxy-after-tcp-handshake строка |
Устарело, пожалуйста, переименуйте на proxy_after_tcp_handshake. Прокси-трафик после установления трехстороннего рукопожатия TCP Варианты:
|
|
quic строка |
Включить/выключить проверку QUIC Варианты:
|
|
revoked-server-cert строка |
Устарело, пожалуйста, переименуйте на revoked_server_cert. Действие при аннулировании серверного сертификата. Варианты:
|
|
sni-server-cert-check строка |
Устарело, пожалуйста, переименуйте на sni_server_cert_check. Проверка SNI в сообщении приветствия клиента с полями CN или SAN… Варианты:
|
|
status строка |
Настройка статуса проверки протокола. Варианты:
|
|
unsupported-ssl-cipher строка |
Устарело, пожалуйста, переименуйте на unsupported_ssl_cipher. Действие при использовании неподдерживаемого шифра SSL. Варианты:
|
|
unsupported-ssl-negotiation string |
Устарело, пожалуйста, переименуйте в unsupported_ssl_negotiation. Действие, основанное на том, что используемое соглашение SSL не поддерживается. Варианты:
|
|
unsupported-ssl-version string |
Устарело, пожалуйста, переименуйте в unsupported_ssl_version. Действие, основанное на том, что используемая версия SSL не поддерживается. Варианты:
|
|
untrusted-server-cert string |
Устарело, пожалуйста, переименуйте в untrusted_server_cert. Действие, основанное на том, что сертификат сервера выдан не надёжным центром сертификации. Варианты:
|
forticloud_access_token string | Авторизуйте клиента Ansible с помощью маркера доступа к API forticloud. |
proposed_method string | Переопределённый метод для основного запроса Json RPC. Варианты:
|
rc_failed list / elements=integer | Список кодов rc, с которыми будут переопределены условия для отказа. |
rc_succeeded list / elements=integer | Список кодов rc, с которыми будут переопределены условия для успеха. |
ssl-ssh-profile string | Устарело, пожалуйста, используйте “ssl_ssh_profile” |
ssl_ssh_profile string | Параметр (ssl-ssh-profile) в запрошенном URL. |
workspace_locking_adom string | ADOM для блокировки в режиме работы с рабочей областью FortiManager, значение может быть глобальным и другими, включая root. |
workspace_locking_timeout integer | Максимальное время ожидания в секундах, пока другой пользователь не освободит блокировку рабочей области. По умолчанию: |
Примечания
Примечание
- Начиная с версии 2.4.0, все входные аргументы имеют имя с использованием нижнего подчеркивания (snake_case). Пожалуйста, измените аргументы, такие как “var-name” на “var_name”. Старые имена аргументов все еще доступны, но вы получите предупреждения об устаревании. Вы можете проигнорировать это предупреждение, установив deprecation_warnings=False в ansible.cfg.
- Работа в режиме блокировки рабочей области поддерживается в этом модуле FortiManager, параметры workspace_locking_adom и workspace_locking_timeout помогают в этой задаче.
- Обычно выполнение одного модуля может завершиться ошибкой, если возвращается ненулевой код rc. Вы также можете переопределить условия для отказа или успеха с помощью параметров rc_failed и rc_succeeded
Примеры
- name: Example playbook (generated based on argument schema)
hosts: fortimanagers
connection: httpapi
vars:
ansible_httpapi_use_ssl: true
ansible_httpapi_validate_certs: false
ansible_httpapi_port: 443
tasks:
- name: Configure DNS over TLS options.
fortinet.fortimanager.fmgr_firewall_sslsshprofile_dot:
# bypass_validation: false
workspace_locking_adom: <value in [global, custom adom including root]>
workspace_locking_timeout: 300
# rc_succeeded: [0, -2, -3, ...]
# rc_failed: [-2, -3, ...]
adom: <your own value>
ssl_ssh_profile: <your own value>
firewall_sslsshprofile_dot:
cert_validation_failure: <value in [allow, block, ignore]>
cert_validation_timeout: <value in [allow, block, ignore]>
client_certificate: <value in [bypass, inspect, block]>
expired_server_cert: <value in [allow, block, ignore]>
proxy_after_tcp_handshake: <value in [disable, enable]>
revoked_server_cert: <value in [allow, block, ignore]>
sni_server_cert_check: <value in [enable, strict, disable]>
status: <value in [disable, deep-inspection]>
unsupported_ssl_cipher: <value in [block, allow]>
unsupported_ssl_negotiation: <value in [block, allow]>
untrusted_server_cert: <value in [allow, block, ignore]>
unsupported_ssl_version: <value in [block, allow, inspect]>
min_allowed_ssl_version: <value in [ssl-3.0, tls-1.0, tls-1.1, ...]>
quic: <value in [disable, enable, bypass, ...]>
Значения возврата
Общие значения возврата документированы здесь, следующие поля уникальны для данного модуля:
Ключ | Описание |
|---|---|
meta словарь | Результат запроса. Возвращается: всегда |
|
request_url строка |
Полный URL запроса. Возвращается: всегда Пример: |
|
response_code целое число |
Статус запроса API. Возвращается: всегда Пример: |
|
response_data список / элементы=строка |
Ответ API. Возвращается: всегда |
|
response_message строка |
Дескриптивное сообщение ответа API. Возвращается: всегда Пример: |
|
system_information словарь |
Информация о целевой системе. Возвращается: всегда |
rc целое число | Статус запроса. Возвращается: всегда Пример: |
version_check_warning список / элементы=строка | Предупреждение, если параметры, используемые в книге задач, не поддерживаются текущей версией FortiManager. Возвращается: сложный |
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2024 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/latest/collections/fortinet/fortimanager/fmgr_firewall_sslsshprofile_dot_module.html