Модуль fortinet.fortimanager.fmgr_sys_reboot — Перезагрузка FortiManager.
Примечание
Этот модуль является частью коллекции fortinet.fortimanager (версия 2.7.0).
У вас, возможно, уже установлена эта коллекция, если вы используете пакет ansible. Она не включена в ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.
Для установки используйте: ansible-galaxy collection install fortinet.fortimanager.
Чтобы использовать его в книге задач, укажите: fortinet.fortimanager.fmgr_sys_reboot.
Новое в fortinet.fortimanager 2.1.0
Обзор
- Этот модуль позволяет настраивать устройство FortiManager.
- Примеры включают все параметры и значения, которые необходимо скорректировать из источников данных перед использованием.
Параметры
Параметр | Комментарии |
|---|---|
access_token строка | Токен для доступа к FortiManager без использования имени пользователя и пароля. |
bypass_validation булево | Устанавливается в значение True только тогда, когда схема модуля отличается от структуры API FortiManager, модуль продолжает выполнение без проверки параметров. Варианты:
|
enable_log булево | Включить/выключить ведение журнала для задачи. Варианты:
|
forticloud_access_token строка | Авторизовать клиента Ansible с помощью токена доступа к API forticloud. |
rc_failed список / элементы=целое число | Список кодов rc, по которым условия завершения задачи с ошибкой будут переопределены. |
rc_succeeded список / элементы=целое число | Список кодов rc, по которым условия завершения задачи успешно будут переопределены. |
sys_reboot словарь | Набор параметров верхнего уровня. |
|
fmgr_message строка |
Необязательное сообщение, которое будет сохранено в журнале событий. |
workspace_locking_adom строка | Домен для блокировки в режиме работы FortiManager в рабочей области, значение может быть глобальным и другими, включая root. |
workspace_locking_timeout целое число | Максимальное время в секундах ожидания, пока другой пользователь не разблокирует рабочую область. По умолчанию: |
Примечания
Примечание
- Начиная с версии 2.4.0, все входные аргументы имеют именование с использованием нижнего подчеркивания (snake_case). Пожалуйста, измените аргументы, такие как «var-name», на «var_name». Старые имена аргументов все еще доступны, но вы получите предупреждения об устаревании. Вы можете проигнорировать это предупреждение, установив deprecation_warnings=False в ansible.cfg.
- Поддержка работы в режиме блокировки рабочей области включена в этот модуль FortiManager, параметры workspace_locking_adom и workspace_locking_timeout помогают выполнить эту работу.
- Обычно выполнение одного модуля может завершиться ошибкой при возврате ненулевого значения rc. Вы также можете переопределить условия завершения с ошибкой или успехом с помощью параметров rc_failed и rc_succeeded.
Примеры
- name: Example playbook (generated based on argument schema)
hosts: fortimanagers
connection: httpapi
vars:
ansible_httpapi_use_ssl: true
ansible_httpapi_validate_certs: false
ansible_httpapi_port: 443
tasks:
- name: Restart FortiManager.
fortinet.fortimanager.fmgr_sys_reboot:
# bypass_validation: false
workspace_locking_adom: <value in [global, custom adom including root]>
workspace_locking_timeout: 300
# rc_succeeded: [0, -2, -3, ...]
# rc_failed: [-2, -3, ...]
sys_reboot:
fmgr_message: <string>
Значения возврата
Общие значения возврата документированы здесь, следующие поля уникальны для этого модуля:
Ключ | Описание |
|---|---|
meta словарь | Результат запроса. Возвращается: всегда |
|
request_url строка |
Полный URL запроса. Возвращается: всегда Пример: |
|
response_code целое число |
Статус API запроса. Возвращается: всегда Пример: |
|
response_data список / элементы=строка |
Ответ API. Возвращается: всегда |
|
response_message строка |
Описание ответа API. Возвращается: всегда Пример: |
|
system_information словарь |
Информация о целевой системе. Возвращается: всегда |
rc целое число | Статус запроса. Возвращается: всегда Пример: |
version_check_warning список / элементы=строка | Предупреждение, если параметры, используемые в книге задач, не поддерживаются текущей версией FortiManager. Возвращается: сложная |
Ссылки на сборку
© 2012–2018 Michael DeHaan
© 2018–2024 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/latest/collections/fortinet/fortimanager/fmgr_sys_reboot_module.html