Модуль fortinet.fortimanager.fmgr_system_locallog_setting — Настройки локального логгирования.
Примечание
Этот модуль входит в коллекцию fortinet.fortimanager (версия 2.7.0).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не включена в ansible-core. Чтобы проверить установку, выполните ansible-galaxy collection list.
Для установки используйте: ansible-galaxy collection install fortinet.fortimanager.
Для использования в плейбуке укажите: fortinet.fortimanager.fmgr_system_locallog_setting.
Новое в fortinet.fortimanager 2.0.0
Обзор
- Этот модуль позволяет настраивать устройство FortiManager.
- Примеры включают все параметры и значения, которые необходимо скорректировать для использования данных из источников.
Параметры
Параметр | Комментарии |
|---|---|
access_token строка | Токен для доступа к FortiManager без использования имени пользователя и пароля. |
bypass_validation логическое | Устанавливается в True только в случае расхождения схемы модуля со структурой API FortiManager. Модуль продолжает выполнение без проверки параметров. Варианты:
|
enable_log логическое | Включение/отключение логгирования для задачи. Варианты:
|
forticloud_access_token строка | Авторизация клиента Ansible с помощью токена доступа к API forticloud. |
proposed_method строка | Переопределённый метод для базового запроса Json RPC. Варианты:
|
rc_failed список / элементы=целое число | Список кодов rc, при которых выполнение завершится ошибкой. |
rc_succeeded список / элементы=целое число | Список кодов rc, при которых выполнение завершится успешно. |
system_locallog_setting словарь | Настройка параметров верхнего уровня. |
|
log-daemon-crash строка |
Устарело, используйте log_daemon_crash. Отправлять сообщение logmsg при сбое демона. disable — Отключить настройку. enable — Включить настройку. Варианты:
|
|
log-interval-adom-perf-stats целое число |
Устарело, используйте log_interval_adom_perf_stats. Интервал в минутах для логгирования событий статистики производительности adom. |
|
log-interval-dev-no-logging целое число |
Устарело, используйте log_interval_dev_no_logging. Интервал в минутах для логгирования событий отсутствия логов... |
|
log-interval-disk-full целое число |
Устарело, используйте log_interval_disk_full. Интервал в минутах для логгирования событий заполнения диска. |
|
log-interval-gbday-exceeded целое число |
Устарело, используйте log_interval_gbday_exceeded. Интервал в минутах для логгирования событий превышения лимита ГБ/день... |
|
no-log-detection-threshold целое число |
Устарело, используйте no_log_detection_threshold. Интервал в минутах для запуска локального сообщения, если не обнаруж… |
workspace_locking_adom строка | Область, которую нужно заблокировать для FortiManager, работающего в режиме рабочего пространства. Значение может быть глобальным и другими, включая корневой. |
workspace_locking_timeout целое число | Максимальное время ожидания в секундах, пока другой пользователь не разблокирует рабочее пространство. По умолчанию: |
Примечания
Примечание
- Начиная с версии 2.4.0, все входные аргументы используют нижнее подчеркивание (snake_case). Пожалуйста, замените аргументы, такие как «var-name», на «var_name». Старые имена аргументов по-прежнему доступны, но вы получите предупреждения об устаревании. Вы можете проигнорировать это предупреждение, установив deprecation_warnings=False в ansible.cfg.
- Поддержка работы в режиме блокировки рабочего пространства в этом модуле FortiManager. Параметры workspace_locking_adom и workspace_locking_timeout помогают в этом.
- Обычно, выполнение модуля может завершиться ошибкой, если возвращается код rc, отличный от нуля. Вы также можете переопределить условия для завершения ошибки или успеха с помощью параметров rc_failed и rc_succeeded.
Примеры
- name: Example playbook (generated based on argument schema)
hosts: fortimanagers
connection: httpapi
vars:
ansible_httpapi_use_ssl: true
ansible_httpapi_validate_certs: false
ansible_httpapi_port: 443
tasks:
- name: Settings for locallog logging.
fortinet.fortimanager.fmgr_system_locallog_setting:
# bypass_validation: false
workspace_locking_adom: <value in [global, custom adom including root]>
workspace_locking_timeout: 300
# rc_succeeded: [0, -2, -3, ...]
# rc_failed: [-2, -3, ...]
system_locallog_setting:
log_interval_dev_no_logging: <integer>
log_interval_disk_full: <integer>
log_interval_gbday_exceeded: <integer>
log_daemon_crash: <value in [disable, enable]>
no_log_detection_threshold: <integer>
log_interval_adom_perf_stats: <integer>
Значения возврата
Общие значения возврата документированы здесь, следующие являются полями, уникальными для этого модуля:
Ключ | Описание |
|---|---|
meta словарь | Результат запроса. Возвращается: всегда |
|
request_url строка |
Полный URL запроса. Возвращается: всегда Пример: |
|
response_code целое число |
Статус запроса API. Возвращается: всегда Пример: |
|
response_data список / элементы=строка |
Ответ API. Возвращается: всегда |
|
response_message строка |
Дескриптивное сообщение ответа API. Возвращается: всегда Пример: |
|
system_information словарь |
Информация о целевой системе. Возвращается: всегда |
rc целое число | Статус запроса. Возвращается: всегда Пример: |
version_check_warning список / элементы=строка | Предупреждение, если параметры, используемые в книге задач, не поддерживаются текущей версией FortiManager. Возвращается: сложный |
Ссылки на сборку
© 2012–2018 Michael DeHaan
© 2018–2024 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/latest/collections/fortinet/fortimanager/fmgr_system_locallog_setting_module.html