fortinet.fortimanager.fmgr_system_npu_dosoptions модуль — Настройки NPU DoS.
Примечание
Этот модуль входит в коллекцию fortinet.fortimanager (версия 2.7.0).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не включена в ansible-core. Чтобы проверить установку, выполните ansible-galaxy collection list.
Чтобы установить её, используйте: ansible-galaxy collection install fortinet.fortimanager.
Чтобы использовать её в книге задач, укажите: fortinet.fortimanager.fmgr_system_npu_dosoptions.
Новая функция в fortinet.fortimanager 2.2.0
Обзор
- Этот модуль позволяет настраивать устройство FortiManager.
- Примеры включают все параметры и значения, которые необходимо настроить по источникам данных перед использованием.
Параметры
Параметр | Комментарии |
|---|---|
access_token строка | Токен для доступа к FortiManager без использования имени пользователя и пароля. |
adom строка / обязательно | Параметр (adom) в запрошенном URL. |
bypass_validation логическое значение | Устанавливается в значение True только тогда, когда схема модуля отличается от структуры API FortiManager, модуль продолжает выполнение без проверки параметров. Варианты:
|
enable_log логическое значение | Включить/выключить ведение журнала для задачи. Варианты:
|
forticloud_access_token строка | Авторизовать клиент Ansible с помощью токена доступа к API forticloud. |
proposed_method строка | Переопределённый метод для базового запроса Json RPC. Варианты:
|
rc_failed список / элементы=целое число | Список кодов rc, по которым будет переопределяться условие ошибки. |
rc_succeeded список / элементы=целое число | Список кодов rc, по которым будет переопределяться условие успешного выполнения. |
system_npu_dosoptions словарь | Настраиваемые параметры верхнего уровня. |
|
npu_dos_meter_mode строка |
Режим отгрузки измерения DoS NPU. Устарело, используйте npu_dos_meter_mode. Варианты:
|
|
npu_dos_synproxy_mode строка |
Режим SYNPROXY NPU DoS. Устарело, используйте npu_dos_synproxy_mode. Варианты:
|
|
npu_dos_tpe_mode строка |
Включить/выключить вставку идентификатора DoS-метра в таблицу сеансов. Устарело, используйте npu_dos_tpe_mode. Варианты:
|
workspace_locking_adom строка | ADOM для блокировки при работе FortiManager в режиме рабочего пространства. Значение может быть глобальным и другими, включая корень. |
workspace_locking_timeout целое число | Максимальное время в секундах ожидания освобождения блокировки рабочего пространства другим пользователем. По умолчанию: |
Примечания
Примечание
- Начиная с версии 2.4.0, все входные аргументы имеют имя, использующее подчёркивание (snake_case). Пожалуйста, измените аргументы, такие как “var-name”, на “var_name”. Старые имена аргументов по-прежнему доступны, но вы получите предупреждения об устаревании. Вы можете проигнорировать это предупреждение, установив deprecation_warnings=False в ansible.cfg.
- Поддержка работы в режиме блокировки рабочего пространства в этом модуле FortiManager, параметры верхнего уровня workspace_locking_adom и workspace_locking_timeout помогают в этой задаче.
- Обычно выполнение одного модуля может завершиться ошибкой при возвращении ненулевого rc. Вы также можете переопределить условия ошибки или успеха с помощью параметров rc_failed и rc_succeeded
Примеры
- name: Example playbook (generated based on argument schema)
hosts: fortimanagers
connection: httpapi
vars:
ansible_httpapi_use_ssl: true
ansible_httpapi_validate_certs: false
ansible_httpapi_port: 443
tasks:
- name: NPU DoS configurations.
fortinet.fortimanager.fmgr_system_npu_dosoptions:
# bypass_validation: false
workspace_locking_adom: <value in [global, custom adom including root]>
workspace_locking_timeout: 300
# rc_succeeded: [0, -2, -3, ...]
# rc_failed: [-2, -3, ...]
adom: <your own value>
system_npu_dosoptions:
npu_dos_meter_mode: <value in [local, global]>
npu_dos_synproxy_mode: <value in [synack2ack, pass-synack]>
npu_dos_tpe_mode: <value in [disable, enable]>
Значения возврата
Общие значения возврата описаны здесь, следующие поля уникальны для этого модуля:
Ключ | Описание |
|---|---|
meta словарь | Результат запроса. Возвращается: всегда |
|
request_url строка |
Полный URL запроса. Возвращается: всегда Пример: |
|
response_code целое число |
Статус API-запроса. Возвращается: всегда Пример: |
|
response_data список / элементы=строка |
Ответ API. Возвращается: всегда |
|
response_message строка |
Дескриптивное сообщение ответа API. Возвращается: всегда Пример: |
|
system_information словарь |
Информация о целевой системе. Возвращается: всегда |
rc целое число | Статус запроса. Возвращается: всегда Пример: |
version_check_warning список / элементы=строка | Предупреждение, если параметры, используемые в книге задач, не поддерживаются текущей версией FortiManager. Возвращается: сложное |
Ссылки на сборки
© 2012–2018 Michael DeHaan
© 2018–2024 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/latest/collections/fortinet/fortimanager/fmgr_system_npu_dosoptions_module.html