Spec-Zone.ru › Ansible

Модуль google.cloud.gcp_compute_disk_info — сбор информации о диске GCP

Примечание

Этот модуль входит в коллекцию google.cloud (версия 1.13.0).

Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в ansible-core. Чтобы проверить, установлена ли она, выполните команду ansible-galaxy collection list.

Чтобы установить её, используйте: ansible-galaxy collection install google.cloud. Для использования этого модуля нужны дополнительные требования. Подробности см. в разделе Требования.

Чтобы использовать модуль в плейбуке, укажите: google.cloud.gcp_compute_disk_info.

  • Краткое описание
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Краткое описание

  • Сбор информации о диске GCP

Требования

На хосте, выполняющем этот модуль, должны быть установлены следующие компоненты.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр

Комментарии

access_token

string

Токен доступа OAuth2, если выбран тип учетных данных accesstoken.

auth_kind

string / обязательный

Тип используемых учетных данных.

Варианты:

  • "application"
  • "machineaccount"
  • "serviceaccount"
  • "accesstoken"

env_type

string

Указывает, в какой среде Ansible выполняется этот модуль.

Не задавайте это значение, если не знаете, что делаете.

Этот параметр изменяет только строку User Agent для запросов к API.

filters

list / elements=string

Список пар значений фильтров. Доступные фильтры перечислены здесь: https://cloud.google.com/sdk/gcloud/reference/topic/filters.

Каждый следующий фильтр в списке добавляется как условие AND (filter1 and filter2).

project

string

Проект Google Cloud Platform, который следует использовать.

scopes

list / elements=string

Массив используемых областей доступа

service_account_contents

jsonarg

Содержимое JSON-файла учетной записи службы в виде словаря или JSON-строки, представляющей его.

service_account_email

string

Необязательный адрес электронной почты учетной записи службы. Указывается, если выбрано machineaccount и пользователь не хочет использовать адрес электронной почты по умолчанию.

service_account_file

path

Путь к JSON-файлу учетной записи службы, если выбран тип serviceaccount.

zone

string / обязательный

Ссылка на зону, в которой находится диск.

Примечания

Примечание

  • Для аутентификации можно задать service_account_file с помощью переменной среды GCP_SERVICE_ACCOUNT_FILE.
  • Для аутентификации можно задать service_account_contents с помощью переменной среды GCP_SERVICE_ACCOUNT_CONTENTS.
  • Для аутентификации можно задать service_account_email с помощью переменной среды GCP_SERVICE_ACCOUNT_EMAIL.
  • Для аутентификации можно задать access_token с помощью переменной среды GCP_ACCESS_TOKEN.
  • Для аутентификации можно задать auth_kind с помощью переменной среды GCP_AUTH_KIND.
  • Для аутентификации можно задать scopes с помощью переменной среды GCP_SCOPES.
  • Значения переменных среды используются только в том случае, если значения в плейбуке не заданы.
  • Параметры service_account_email и service_account_file являются взаимоисключающими.

Примеры

- name: get info on a disk
  gcp_compute_disk_info:
    zone: us-central1-a
    filters:
    - name = test_object
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"

Возвращаемые значения

Общие возвращаемые значения описаны здесь, ниже перечислены поля, уникальные для этого модуля:

Ключ

Описание

resources

complex

Список ресурсов

Возвращается: всегда

creationTimestamp

string

Временная метка создания в текстовом формате RFC3339.

Возвращается: при успехе

description

string

Необязательное описание этого ресурса. Укажите это свойство при создании ресурса.

Возвращается: при успехе

diskEncryptionKey

complex

Шифрует диск с помощью предоставленного клиентом ключа шифрования.

После шифрования диска с помощью предоставленного клиентом ключа необходимо указывать тот же ключ при последующем использовании диска (например, для создания снимка диска или образа либо для подключения диска к виртуальной машине).

Ключи шифрования, предоставленные клиентом, не защищают доступ к метаданным диска.

Если при создании диска не указать ключ шифрования, диск будет зашифрован автоматически сгенерированным ключом, и для дальнейшего использования диска указывать ключ не потребуется.

Возвращается: при успехе

kmsKeyName

string

Имя ключа шифрования, хранящегося в Google Cloud KMS.

Чтобы использовать эту функцию, у учетной записи службы Compute Engine System вашего проекта (`service-{{PROJECT_NUMBER}}@compute-system.iam.gserviceaccount.com`) должна быть роль `roles/cloudkms.cryptoKeyEncrypterDecrypter`.

Возвращается: при успехе

kmsKeyServiceAccount

string

Учетная запись службы, используемая для запроса шифрования с указанным ключом KMS.

Если значение не указано, используется учетная запись службы Compute Engine Service Agent.

Возвращается: при успехе

rawKey

string

Задает предоставленный клиентом 256-битный ключ шифрования, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса.

Возвращается: при успехе

sha256

string

Хеш SHA-256 предоставленного клиентом ключа шифрования, защищающего этот ресурс, закодированный в base64 согласно RFC 4648.

Возвращается: при успехе

id

integer

Уникальный идентификатор ресурса.

Возвращается: при успехе

labelFingerprint

string

Отпечаток, используемый для оптимистичной блокировки этого ресурса. Используется внутри системы при обновлении.

Возвращается: при успехе

labels

dictionary

Метки, применяемые к этому диску. Список пар ключ->значение.

Возвращается: при успехе

lastAttachTimestamp

string

Временная метка последнего подключения в текстовом формате RFC3339.

Возвращается: при успехе

lastDetachTimestamp

string

Временная метка последнего отключения в текстовом формате RFC3339.

Возвращается: при успехе

licenses

list / elements=string

Все применимые общедоступные лицензии.

Возвращается: при успехе

name

string

Имя ресурса. Указывается клиентом при создании ресурса. Имя должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие символы, кроме последнего, могут быть дефисом, строчной буквой или цифрой; последний символ не может быть дефисом.

Возвращается: при успехе

physicalBlockSizeBytes

integer

Размер физического блока постоянного диска в байтах. Если в запросе не указано это значение, используется значение по умолчанию. В настоящее время поддерживаются размеры 4096 и 16384; в будущем могут быть добавлены другие размеры.

Если запрошено неподдерживаемое значение, в сообщении об ошибке будут перечислены значения, поддерживаемые для проекта вызывающей стороны.

Возвращается: при успехе

provisionedIops

integer

Указывает количество IOPS, которое необходимо выделить для диска.

Возвращается: при успехе

sizeGb

integer

Размер постоянного диска, заданный в ГБ. Это поле можно указать при создании постоянного диска с помощью параметра sourceImage или sourceSnapshot либо указать отдельно, чтобы создать пустой постоянный диск.

Если указать это поле вместе с sourceImage или sourceSnapshot, значение sizeGb не должно быть меньше размера sourceImage или снимка.

Возвращается: при успехе

sourceImage

string

Исходный образ, использованный для создания этого диска. Если исходный образ удален, это поле не будет задано.

Чтобы создать диск с одним из общедоступных образов операционной системы, укажите образ по имени семейства. Например, укажите family/debian-9, чтобы использовать последнюю версию образа Debian 9: projects/debian-cloud/global/images/family/debian-9. Также можно указать конкретную версию общедоступного образа операционной системы: projects/debian-cloud/global/images/debian-9-stretch-vYYYYMMDD. Чтобы создать диск с созданным вами приватным образом, укажите имя образа в следующем формате: global/images/my-private-image. Можно также указать приватный образ по его семейству; в этом случае будет использована последняя версия образа в этом семействе. Замените имя образа на family/family-name: global/images/family/my-private-family .

Возвращается: при успехе

sourceImageEncryptionKey

complex

Предоставленный клиентом ключ шифрования исходного образа. Обязателен, если исходный образ защищен предоставленным клиентом ключом шифрования.

Возвращается: при успехе

kmsKeyName

string

Имя ключа шифрования, хранящегося в Google Cloud KMS.

Возвращается: при успехе

kmsKeyServiceAccount

string

Учетная запись службы, используемая для запроса шифрования с указанным ключом KMS.

Если значение не указано, используется учетная запись службы Compute Engine Service Agent.

Возвращается: при успехе

rawKey

string

Задает предоставленный клиентом 256-битный ключ шифрования, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса.

Возвращается: при успехе

sha256

string

Хеш SHA-256 предоставленного клиентом ключа шифрования, защищающего этот ресурс, закодированный в base64 согласно RFC 4648.

Возвращается: при успехе

sourceImageId

string

Значение ID образа, использованного для создания этого диска. Оно идентифицирует точный образ, из которого был создан этот постоянный диск. Например, если постоянный диск был создан из образа, который позднее удалили и заново создали под тем же именем, ID исходного образа укажет на точную версию использованного образа.

Возвращается: при успехе

sourceSnapshot

dictionary

Исходный снимок, использованный для создания этого диска. В качестве значения можно указать частичный или полный URL ресурса.

Возвращается: при успехе

sourceSnapshotEncryptionKey

complex

Предоставленный клиентом ключ шифрования исходного снимка. Обязателен, если исходный снимок защищен предоставленным клиентом ключом шифрования.

Возвращается: при успехе

kmsKeyName

string

Имя ключа шифрования, хранящегося в Google Cloud KMS.

Возвращается: при успехе

kmsKeyServiceAccount

string

Учетная запись службы, используемая для запроса шифрования с указанным ключом KMS.

Если значение не указано, используется учетная запись службы Compute Engine Service Agent.

Возвращается: при успехе

rawKey

string

Задает предоставленный клиентом 256-битный ключ шифрования, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса.

Возвращается: при успехе

sha256

string

Хеш SHA-256 предоставленного клиентом ключа шифрования, защищающего этот ресурс, закодированный в base64 согласно RFC 4648.

Возвращается: при успехе

sourceSnapshotId

string

Уникальный ID снимка, использованного для создания этого диска. Это значение идентифицирует точный снимок, из которого был создан этот постоянный диск. Например, если постоянный диск был создан из снимка, который позднее удалили и заново создали под тем же именем, ID исходного снимка укажет на точную версию использованного снимка.

Возвращается: при успехе

type

string

URL ресурса типа диска, указывающий, какой тип диска использовать при создании диска. Укажите это значение при создании диска.

Возвращается: при успехе

users

list / elements=string

Ссылки на пользователей диска (подключенные экземпляры) в формате: project/zones/zone/instances/instance .

Возвращается: при успехе

zone

string

Ссылка на зону, в которой находится диск.

Возвращается: при успехе

Авторы

  • Google Inc. (@googlecloudplatform)

Ссылки на коллекцию

  • Отслеживание проблем
  • Главная страница
  • Репозиторий (исходный код)

© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/google/cloud/gcp_compute_disk_info_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API