Spec-Zone.ru › Ansible

Модуль google.cloud.gcp_compute_forwarding_rule_info — сбор сведений о GCP ForwardingRule

Примечание

Этот модуль входит в коллекцию google.cloud (версия 1.13.0).

Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в состав ansible-core. Чтобы проверить, установлена ли она, выполните команду ansible-galaxy collection list.

Для установки используйте: ansible-galaxy collection install google.cloud. Для использования этого модуля могут потребоваться дополнительные компоненты; подробности см. в разделе Требования.

Чтобы использовать модуль в плейбуке, укажите: google.cloud.gcp_compute_forwarding_rule_info.

  • Краткое описание
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Краткое описание

  • Сбор сведений о GCP ForwardingRule

Требования

На хосте, где выполняется этот модуль, должны быть установлены следующие компоненты.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр

Комментарии

access_token

string

Токен доступа OAuth2, если тип учетных данных — accesstoken.

auth_kind

string / обязательный

Тип используемых учетных данных.

Варианты:

  • "application"
  • "machineaccount"
  • "serviceaccount"
  • "accesstoken"

env_type

string

Указывает, в какой среде Ansible выполняется этот модуль.

Не задавайте этот параметр, если не знаете, что делаете.

Он изменяет только строку User Agent для запросов к API.

filters

list / элементы=string

Список пар значений фильтров. Доступные фильтры перечислены здесь: https://cloud.google.com/sdk/gcloud/reference/topic/filters.

Каждый дополнительный фильтр в списке добавляется как условие AND (filter1 and filter2).

project

string

Проект Google Cloud Platform, который следует использовать.

region

string / обязательный

Ссылка на регион, в котором находится региональное правило переадресации.

Это поле не применяется к глобальным правилам переадресации.

scopes

list / элементы=string

Массив используемых областей действия

service_account_contents

jsonarg

Содержимое JSON-файла учетной записи службы — в виде словаря или строки JSON, представляющей этот файл.

service_account_email

string

Необязательный адрес электронной почты учетной записи службы. Используется, если выбран machineaccount и пользователь не хочет использовать адрес электронной почты по умолчанию.

service_account_file

path

Путь к JSON-файлу учетной записи службы, если в качестве типа выбрано serviceaccount.

Примечания

Примечание

  • Для аутентификации можно задать service_account_file с помощью переменной окружения GCP_SERVICE_ACCOUNT_FILE.
  • Для аутентификации можно задать service_account_contents с помощью переменной окружения GCP_SERVICE_ACCOUNT_CONTENTS.
  • Для аутентификации можно задать service_account_email с помощью переменной окружения GCP_SERVICE_ACCOUNT_EMAIL.
  • Для аутентификации можно задать access_token с помощью переменной окружения GCP_ACCESS_TOKEN.
  • Для аутентификации можно задать auth_kind с помощью переменной окружения GCP_AUTH_KIND.
  • Для аутентификации можно задать scopes с помощью переменной окружения GCP_SCOPES.
  • Значения переменных окружения используются только в том случае, если значения не заданы в плейбуке.
  • Параметры service_account_email и service_account_file являются взаимоисключающими.

Примеры

- name: get info on a forwarding rule
  gcp_compute_forwarding_rule_info:
    region: us-west1
    filters:
    - name = test_object
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"

Возвращаемые значения

Общие возвращаемые значения описаны здесь; ниже перечислены поля, уникальные для этого модуля:

Ключ

Описание

resources

complex

Список ресурсов

Возвращается: всегда

allowGlobalAccess

boolean

Если значение равно true, клиенты могут обращаться к ILB из всех регионов.

В противном случае доступ разрешен только из локального региона, где расположен ILB.

Возвращается: при успехе

allPorts

boolean

Для внутренней балансировки нагрузки TCP/UDP (то есть схема балансировки нагрузки — INTERNAL, а протокол — TCP/UDP) задайте значение true, чтобы разрешить перенаправление на настроенные для этого правила переадресации серверные части пакетов, адресованных на любые порты. Используется вместе с backend service. Не может быть задано, если указаны port или portRange.

Возвращается: при успехе

backendService

dictionary

BackendService, которому передается соответствующий трафик. Используется только для внутренней балансировки нагрузки.

Возвращается: при успехе

creationTimestamp

string

Временная метка создания в текстовом формате RFC3339.

Возвращается: при успехе

description

string

Необязательное описание этого ресурса. Укажите это свойство при создании ресурса.

Возвращается: при успехе

id

integer

Уникальный идентификатор ресурса.

Возвращается: при успехе

IPAddress

string

IP-адрес, от имени которого работает это правило переадресации.

Допустимые адреса ограничены схемой балансировки нагрузки правила переадресации (EXTERNAL или INTERNAL) и областью действия (глобальной или региональной).

Если схема балансировки нагрузки — EXTERNAL, для глобальных правил переадресации адрес должен быть глобальным IP-адресом, а для региональных — находиться в том же регионе, что и правило переадресации. Если это поле не задано, будет назначен временный IPv4-адрес из той же области действия (глобальной или региональной). Региональное правило переадресации поддерживает только IPv4. Глобальное правило переадресации поддерживает IPv4 и IPv6.

Если схема балансировки нагрузки — INTERNAL, здесь может быть указан только IP-адрес RFC 1918, принадлежащий сети или подсети, настроенной для правила переадресации. По умолчанию, если это поле не задано, из диапазона IP-адресов подсети или сети, настроенной для этого правила переадресации, автоматически выделяется временный внутренний IP-адрес.

Адрес можно указать как буквальный IP-адрес или как URL-ссылку на существующий ресурс Address. Допустимы все следующие примеры: * 100.1.2.3 * https://www.googleapis.com/compute/v1/projects/project/regions/region/addresses/address * projects/project/regions/region/addresses/address * regions/region/addresses/address * global/addresses/address * address .

Возвращается: при успехе

IPProtocol

string

IP-протокол, к которому применяется это правило.

Для схемы балансировки нагрузки INTERNAL допустимы только TCP и UDP.

Возвращается: при успехе

isMirroringCollector

boolean

Указывает, можно ли использовать этот балансировщик нагрузки в качестве сборщика для зеркалирования пакетов. Чтобы предотвратить циклы зеркалирования, трафик экземпляров за этим балансировщиком нагрузки не будет зеркалироваться, даже если к ним применяется правило PacketMirroring. Значение true можно задать только для балансировщиков нагрузки, у которых loadBalancingScheme имеет значение INTERNAL.

Возвращается: при успехе

loadBalancingScheme

string

Указывает назначение ForwardingRule. Допустимые значения: EXTERNAL, INTERNAL или INTERNAL_MANAGED. EXTERNAL используется для классических шлюзов Cloud VPN, переадресации протоколов на виртуальные машины с внешнего IP-адреса, а также для балансировщиков нагрузки HTTP(S), SSL Proxy, TCP Proxy и Network TCP/UDP.

INTERNAL используется для переадресации протоколов на виртуальные машины с внутреннего IP-адреса и для внутренних балансировщиков нагрузки TCP/UDP.

INTERNAL_MANAGED используется для внутренних балансировщиков нагрузки HTTP(S).

Возвращается: при успехе

name

string

Имя ресурса, задаваемое клиентом при создании ресурса. Длина имени должна составлять от 1 до 63 символов, имя должно соответствовать RFC1035. В частности, длина имени должна составлять от 1 до 63 символов, а само имя должно соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом.

Возвращается: при успехе

network

dictionary

При внутренней балансировке нагрузки это поле указывает сеть, которой должен принадлежать IP-адрес балансировщика нагрузки для данного Forwarding Rule. Если поле не задано, будет использоваться сеть по умолчанию.

Это поле используется только при внутренней балансировке нагрузки (INTERNAL).

Возвращается: при успехе

networkTier

string

Уровень сетевого обслуживания, используемый для настройки этого адреса. Если поле не задано, предполагается значение PREMIUM.

Возвращается: при успехе

portRange

string

Это поле используется вместе с полем target для TargetHttpProxy, TargetHttpsProxy, TargetSslProxy, TargetTcpProxy, TargetVpnGateway, TargetPool и TargetInstance.

Применяется только для IPProtocol со значением TCP, UDP или SCTP. На целевой объект будут переадресовываться только пакеты, адресованные на порты из указанного диапазона.

Диапазоны портов правил переадресации с одинаковой парой [IPAddress, IPProtocol] не должны пересекаться.

Для некоторых типов целевых объектов переадресации допустимые порты ограничены: * TargetHttpProxy: 80, 8080 * TargetHttpsProxy: 443 * TargetTcpProxy: 25, 43, 110, 143, 195, 443, 465, 587, 700, 993, 995, 1883, 5222 * TargetSslProxy: 25, 43, 110, 143, 195, 443, 465, 587, 700, 993, 995, 1883, 5222 * TargetVpnGateway: 500, 4500 .

Возвращается: при успехе

ports

list / элементы=string

Это поле используется вместе с полем backend_service при внутренней балансировке нагрузки.

При схеме балансировки нагрузки INTERNAL можно задать один порт или список портов, разделенных запятыми. На серверные части, настроенные для этого правила переадресации, будут переадресовываться только пакеты, адресованные на эти порты.

Можно указать не более 5 портов.

Возвращается: при успехе

region

string

Ссылка на регион, в котором находится региональное правило переадресации.

Это поле не применяется к глобальным правилам переадресации.

Возвращается: при успехе

serviceLabel

string

Необязательный префикс имени службы для этого Forwarding Rule.

Если он задан, то станет первой меткой полного имени службы.

Длина метки должна составлять от 1 до 63 символов, она должна соответствовать RFC1035.

В частности, длина метки должна составлять от 1 до 63 символов, а сама метка должна соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом.

Это поле используется только при внутренней балансировке нагрузки (INTERNAL).

Возвращается: при успехе

serviceName

string

Полное внутреннее имя службы для этого Forwarding Rule.

Это поле используется только при внутренней балансировке нагрузки (INTERNAL).

Возвращается: при успехе

subnetwork

dictionary

Подсеть, которой должен принадлежать IP-адрес балансировщика нагрузки для этого Forwarding Rule. Это поле используется только при внутренней балансировке нагрузки (INTERNAL).

Если указанная сеть работает в режиме автоматического создания подсетей, это поле можно не задавать. Однако если сеть работает в режиме пользовательских подсетей, подсеть необходимо указать.

Возвращается: при успехе

target

string

URL целевого ресурса, которому передается соответствующий трафик.

Целевой ресурс должен находиться в том же регионе, что и правило переадресации.

Тип переадресуемого трафика должен соответствовать типу целевого объекта.

Возвращается: при успехе

Авторы

  • Google Inc. (@googlecloudplatform)

Ссылки на коллекцию

  • Отслеживание проблем
  • Домашняя страница
  • Репозиторий (исходный код)

© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/google/cloud/gcp_compute_forwarding_rule_info_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API