модуль google.cloud.gcp_compute_image_info — сбор информации об образе GCP
Примечание
Этот модуль входит в коллекцию google.cloud (версия 1.13.0).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.
Чтобы установить её, используйте: ansible-galaxy collection install google.cloud. Для использования этого модуля необходимы дополнительные требования; подробности см. в разделе Требования.
Чтобы использовать его в плейбуке, укажите: google.cloud.gcp_compute_image_info.
Краткое описание
- Сбор информации об образе GCP
Требования
Следующие требования должны быть выполнены на хосте, на котором выполняется этот модуль.
- python >= 2.6
- requests >= 2.18.4
- google-auth >= 1.3.0
Параметры
Параметр | Комментарии |
|---|---|
access_token string | Токен доступа OAuth2, если выбран тип учётных данных accesstoken. |
auth_kind string / обязательный | Тип используемых учётных данных. Варианты:
|
env_type string | Указывает, в какой среде Ansible выполняется этот модуль. Не задавайте этот параметр, если не знаете, что делаете. Он изменяет только строку User Agent для любых запросов к API. |
filters list / элементы=string | Список пар значений фильтров. Доступные фильтры перечислены здесь: https://cloud.google.com/sdk/gcloud/reference/topic/filters. Каждый дополнительный фильтр в списке добавляется как условие AND (filter1 и filter2). |
project string | Проект Google Cloud Platform, который следует использовать. |
scopes list / элементы=string | Массив используемых областей доступа |
service_account_contents jsonarg | Содержимое JSON-файла сервисной учётной записи в виде словаря или JSON-строки, представляющей его. |
service_account_email string | Необязательный адрес электронной почты сервисной учётной записи. Используется, если выбран machineaccount и пользователь не хочет применять адрес по умолчанию. |
service_account_file path | Путь к JSON-файлу сервисной учётной записи, если в качестве типа выбрано serviceaccount. |
Примечания
Примечание
- Для аутентификации можно задать service_account_file с помощью переменной среды
GCP_SERVICE_ACCOUNT_FILE. - Для аутентификации можно задать service_account_contents с помощью переменной среды
GCP_SERVICE_ACCOUNT_CONTENTS. - Для аутентификации можно задать service_account_email с помощью переменной среды
GCP_SERVICE_ACCOUNT_EMAIL. - Для аутентификации можно задать access_token с помощью переменной среды
GCP_ACCESS_TOKEN. - Для аутентификации можно задать auth_kind с помощью переменной среды
GCP_AUTH_KIND. - Для аутентификации можно задать scopes с помощью переменной среды
GCP_SCOPES. - Значения переменных среды будут использоваться только в том случае, если значения в плейбуке не заданы.
- Параметры service_account_email и service_account_file являются взаимоисключающими.
Примеры
- name: get info on an image
gcp_compute_image_info:
filters:
- name = test_object
project: test_project
auth_kind: serviceaccount
service_account_file: "/tmp/auth.pem"
Возвращаемые значения
Общие возвращаемые значения описаны здесь; ниже перечислены поля, уникальные для этого модуля:
Ключ | Описание |
|---|---|
resources complex | Список ресурсов Возвращается: всегда |
|
archiveSizeBytes integer |
Размер архива tar.gz образа, хранящегося в Google Cloud Storage (в байтах). Возвращается: при успехе |
|
creationTimestamp string |
Время создания в текстовом формате RFC3339. Возвращается: при успехе |
|
deprecated complex |
Статус устаревания, связанный с этим образом. Возвращается: при успехе |
|
deleted string |
Необязательная временная метка RFC3339, указывающая момент, когда состояние этого ресурса должно измениться на DELETED или позже. Это значение носит исключительно информационный характер; статус не изменится, пока клиент явно его не изменит. Возвращается: при успехе |
|
deprecated string |
Необязательная временная метка RFC3339, указывающая момент, когда состояние этого ресурса должно измениться на DEPRECATED или позже. Это значение носит исключительно информационный характер; статус не изменится, пока клиент явно его не изменит. Возвращается: при успехе |
|
obsolete string |
Необязательная временная метка RFC3339, указывающая момент, когда состояние этого ресурса должно измениться на OBSOLETE или позже. Это значение носит исключительно информационный характер; статус не изменится, пока клиент явно его не изменит. Возвращается: при успехе |
|
replacement string |
URL рекомендуемой замены устаревшего ресурса. Рекомендуемый ресурс-замена должен быть того же типа, что и устаревший ресурс. Возвращается: при успехе |
|
state string |
Состояние устаревания этого ресурса. Возможные значения: DEPRECATED, OBSOLETE или DELETED. Операции, создающие новый ресурс на основе ресурса в состоянии DEPRECATED, завершатся успешно, но выдадут предупреждение с указанием устаревшего ресурса и рекомендацией по его замене. Операции с ресурсами в состояниях OBSOLETE или DELETED будут отклонены и завершатся ошибкой. Возвращается: при успехе |
|
description string |
Необязательное описание этого ресурса. Укажите это свойство при создании ресурса. Возвращается: при успехе |
|
diskSizeGb integer |
Размер образа после восстановления на постоянном диске (в ГБ). Возвращается: при успехе |
|
family string |
Имя семейства образов, к которому относится этот образ. Диски можно создавать, указывая семейство образов вместо имени конкретного образа. Семейство образов всегда возвращает последнюю версию образа, которая не является устаревшей. Имя семейства образов должно соответствовать RFC1035. Возвращается: при успехе |
|
guestOsFeatures complex |
Список функций, которые следует включить в гостевой операционной системе. Применимо только к загрузочным образам. Возвращается: при успехе |
|
type string |
Тип поддерживаемой функции. Возвращается: при успехе |
|
id integer |
Уникальный идентификатор ресурса. Этот идентификатор задаётся сервером. Возвращается: при успехе |
|
imageEncryptionKey complex |
Шифрует образ с помощью предоставленного пользователем ключа шифрования. После шифрования образа предоставленным пользователем ключом необходимо будет указать тот же ключ при последующем использовании образа (например, для создания диска на его основе). Возвращается: при успехе |
|
rawKey string |
Указывает предоставленный пользователем ключ шифрования длиной 256 бит, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса. Возвращается: при успехе |
|
sha256 string |
Хеш SHA-256 предоставленного пользователем ключа шифрования, защищающего этот ресурс, закодированный в base64 согласно RFC 4648. Возвращается: при успехе |
|
labelFingerprint string |
Отпечаток, используемый для оптимистичной блокировки этого ресурса. Используется внутри системы при обновлениях. Возвращается: при успехе |
|
labels dictionary |
Метки, применяемые к этому образу. Возвращается: при успехе |
|
licenses list / элементы=string |
URI всех применимых лицензий. Возвращается: при успехе |
|
name string |
Имя ресурса, задаваемое клиентом при его создании. Имя должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом. Возвращается: при успехе |
|
rawDisk complex |
Параметры образа необработанного диска. Возвращается: при успехе |
|
containerType string |
Формат для кодирования и передачи блочного устройства; должен быть TAR. Это только формат контейнера и передачи, а не формат среды выполнения. Задаётся клиентом при создании образа диска. Возвращается: при успехе |
|
sha1Checksum string |
Необязательная контрольная сумма SHA1 образа диска до распаковки. Указывается клиентом при создании образа диска. Возвращается: при успехе |
|
source string |
Полный URL Google Cloud Storage, где хранится дисковое хранилище. Необходимо указать это свойство или свойство sourceDisk, но не оба одновременно. Возвращается: при успехе |
|
sourceDisk dictionary |
Исходный диск, на основе которого создаётся этот образ. Для создания образа необходимо указать это свойство или свойство rawDisk.source, но не оба одновременно. Возвращается: при успехе |
|
sourceDiskEncryptionKey complex |
Предоставленный пользователем ключ шифрования исходного диска. Требуется, если исходный диск защищён ключом шифрования, предоставленным пользователем. Возвращается: при успехе |
|
rawKey string |
Указывает предоставленный пользователем ключ шифрования длиной 256 бит, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса. Возвращается: при успехе |
|
sha256 string |
Хеш SHA-256 предоставленного пользователем ключа шифрования, защищающего этот ресурс, закодированный в base64 согласно RFC 4648. Возвращается: при успехе |
|
sourceDiskId string |
Значение ID диска, использованного для создания этого образа. Это значение можно использовать, чтобы определить, был ли образ создан из текущего или предыдущего экземпляра диска с данным именем. Возвращается: при успехе |
|
sourceImage dictionary |
URL исходного образа, использованного для создания этого образа. Для создания образа необходимо указать полный или частичный URL одного из следующих ресурсов: * URL selfLink * это свойство * URL rawDisk.source * URL sourceDisk. Возвращается: при успехе |
|
sourceSnapshot dictionary |
URL исходного снимка, использованного для создания этого образа. Для создания образа необходимо указать полный или частичный URL одного из следующих ресурсов: * URL selfLink * это свойство * URL sourceImage * URL rawDisk.source * URL sourceDisk. Возвращается: при успехе |
|
sourceType string |
Тип образа, использованного для создания этого диска. Значение по умолчанию и единственное допустимое значение — RAW. Возвращается: при успехе |
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/google/cloud/gcp_compute_image_info_module.html