Модуль google.cloud.gcp_compute_instance_info — сбор сведений об экземпляре GCP
Примечание
Этот модуль входит в коллекцию google.cloud (версия 1.13.0).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в состав ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.
Для установки используйте: ansible-galaxy collection install google.cloud. Для использования этого модуля необходимы дополнительные компоненты; подробности см. в разделе Требования.
Чтобы использовать модуль в плейбуке, укажите: google.cloud.gcp_compute_instance_info.
Краткое описание
- Сбор сведений об экземпляре GCP
Требования
Следующие компоненты необходимы на хосте, где выполняется этот модуль.
- python >= 2.6
- requests >= 2.18.4
- google-auth >= 1.3.0
Параметры
Параметр | Описание |
|---|---|
access_token string | Токен доступа OAuth2, если выбран тип учетных данных accesstoken. |
auth_kind string / обязательный | Тип используемых учетных данных. Допустимые значения:
|
env_type string | Указывает, в какой среде Ansible выполняется этот модуль. Не задавайте это значение, если не знаете, что делаете. Этот параметр изменяет только строку User Agent для всех запросов API. |
filters list / элементы=string | Список пар «фильтр — значение». Доступные фильтры перечислены здесь: https://cloud.google.com/compute/docs/reference/rest/v1/instances/list Каждый следующий фильтр в списке добавляется как условие AND (filter1 and filter2). |
project string | Проект Google Cloud Platform, который будет использоваться. |
scopes list / элементы=string | Массив используемых областей доступа |
service_account_contents jsonarg | Содержимое JSON-файла учетной записи службы в виде словаря или JSON-строки, представляющей его. |
service_account_email string | Необязательный адрес электронной почты учетной записи службы, если выбран machineaccount и пользователь не хочет использовать адрес по умолчанию. |
service_account_file path | Путь к JSON-файлу учетной записи службы, если в качестве типа выбрано serviceaccount. |
zone string / обязательный | Ссылка на зону, в которой находится машина. |
Примечания
Примечание
- Для аутентификации можно задать service_account_file с помощью переменной окружения
GCP_SERVICE_ACCOUNT_FILE. - Для аутентификации можно задать service_account_contents с помощью переменной окружения
GCP_SERVICE_ACCOUNT_CONTENTS. - Для аутентификации можно задать service_account_email с помощью переменной окружения
GCP_SERVICE_ACCOUNT_EMAIL. - Для аутентификации можно задать access_token с помощью переменной окружения
GCP_ACCESS_TOKEN. - Для аутентификации можно задать auth_kind с помощью переменной окружения
GCP_AUTH_KIND. - Для аутентификации можно задать scopes с помощью переменной окружения
GCP_SCOPES. - Значения переменных окружения используются только в том случае, если значения не заданы в плейбуке.
- Параметры service_account_email и service_account_file взаимоисключающие.
Примеры
- name: get info on an instance
gcp_compute_instance_info:
zone: us-central1-a
filters:
- name = test_object
project: test_project
auth_kind: serviceaccount
service_account_file: "/tmp/auth.pem"
Возвращаемые значения
Общие возвращаемые значения описаны здесь, далее перечислены поля, уникальные для этого модуля:
Ключ | Описание |
|---|---|
resources complex | Список ресурсов Возвращается: всегда |
|
canIpForward boolean |
Разрешает этому экземпляру отправлять и получать пакеты с несовпадающими IP-адресами назначения или источника. Это необходимо, если вы планируете использовать этот экземпляр для пересылки маршрутов. Возвращается: при успешном выполнении |
|
confidentialInstanceConfig complex |
Конфигурация для конфиденциальных вычислений (требуется указать тип машины из семейства n2d-* и загрузочный диск типа pd-ssd). Возвращается: при успешном выполнении |
|
enableConfidentialCompute boolean |
Включает конфиденциальные вычисления. Возвращается: при успешном выполнении |
|
cpuPlatform string |
Платформа ЦП, используемая этим экземпляром. Возвращается: при успешном выполнении |
|
creationTimestamp string |
Временная метка создания в текстовом формате RFC3339. Возвращается: при успешном выполнении |
|
deletionProtection boolean |
Указывает, должна ли быть включена защита ресурса от удаления. Возвращается: при успешном выполнении |
|
disks complex |
Массив дисков, связанных с экземплярами, созданными на основе этого шаблона. Возвращается: при успешном выполнении |
|
autoDelete boolean |
Указывает, будет ли диск удаляться автоматически при удалении экземпляра (но не при отсоединении диска от экземпляра). Совет: для дисков следует задавать autoDelete=true, чтобы после удаления машины не оставались неиспользуемые диски. Возвращается: при успешном выполнении |
|
boot boolean |
Указывает, что это загрузочный диск. Виртуальная машина будет использовать первый раздел диска для корневой файловой системы. Возвращается: при успешном выполнении |
|
deviceName string |
Задает уникальное имя устройства по вашему выбору, которое отображается в дереве /dev/disk/by-id/google-* операционной системы Linux, работающей внутри экземпляра. Это имя можно использовать для обращения к устройству из экземпляра, например для его монтирования или изменения размера. Возвращается: при успешном выполнении |
|
diskEncryptionKey complex |
Шифрует или расшифровывает диск с помощью предоставленного клиентом ключа шифрования. Возвращается: при успешном выполнении |
|
rawKey string |
Задает 256-битный ключ шифрования, предоставленный клиентом и закодированный в base64 по RFC 4648, для шифрования или расшифровки этого ресурса. Возвращается: при успешном выполнении |
|
rsaEncryptedKey string |
Задает предоставленный клиентом 2048-битный ключ шифрования, обернутый с помощью RSA и закодированный в base64 по RFC 4648, для шифрования или расшифровки этого ресурса. Возвращается: при успешном выполнении |
|
sha256 string |
Хеш SHA-256 предоставленного клиентом ключа шифрования, закодированный в base64 по RFC 4648 и защищающий этот ресурс. Возвращается: при успешном выполнении |
|
index integer |
Назначает этому диску индекс, начинающийся с нуля; индекс 0 зарезервирован для загрузочного диска. Например, если к экземпляру подключено несколько дисков, у каждого диска будет уникальный индекс. Если значение не указано, сервер выберет подходящее. Возвращается: при успешном выполнении |
|
initializeParams complex |
Задает параметры нового диска, который будет создан вместе с новым экземпляром. Используйте параметры инициализации для создания загрузочных дисков или локальных SSD, подключаемых к новому экземпляру. Возвращается: при успешном выполнении |
|
diskName string |
Задает имя диска. Если оно не указано, по умолчанию используется имя экземпляра. Возвращается: при успешном выполнении |
|
diskSizeGb integer |
Задает размер диска в ГБ в системе счисления с основанием 2. Возвращается: при успешном выполнении |
|
diskType string |
Ссылка на тип диска. Задает тип диска, используемый для создания экземпляра. Если значение не указано, по умолчанию используется pd-standard. Возвращается: при успешном выполнении |
|
sourceImage string |
Исходный образ для создания этого диска. При создании нового экземпляра необходимо указать initializeParams.sourceImage или disks.source. Чтобы создать диск с одним из общедоступных образов операционных систем, укажите образ по имени семейства. Возвращается: при успешном выполнении |
|
sourceImageEncryptionKey complex |
Предоставленный клиентом ключ шифрования исходного образа. Требуется, если исходный образ защищен ключом шифрования, предоставленным клиентом. Шаблоны экземпляров не хранят ключи шифрования, предоставленные клиентом, поэтому невозможно создавать диски для экземпляров в управляемой группе экземпляров, если исходные образы зашифрованы собственными ключами. Возвращается: при успешном выполнении |
|
rawKey string |
Задает 256-битный ключ шифрования, предоставленный клиентом и закодированный в base64 по RFC 4648, для шифрования или расшифровки этого ресурса. Возвращается: при успешном выполнении |
|
sha256 string |
Хеш SHA-256 предоставленного клиентом ключа шифрования, закодированный в base64 по RFC 4648 и защищающий этот ресурс. Возвращается: при успешном выполнении |
|
interface string |
Задает интерфейс диска для его подключения: SCSI или NVME. По умолчанию используется SCSI. Для постоянных дисков всегда необходимо использовать SCSI. Запрос завершится ошибкой, если попытаться подключить постоянный диск в формате, отличном от SCSI. Возвращается: при успешном выполнении |
|
mode string |
Режим подключения диска: READ_WRITE или READ_ONLY. Если значение не указано, по умолчанию диск подключается в режиме READ_WRITE. Возвращается: при успешном выполнении |
|
source dictionary |
Ссылка на диск. При создании нового экземпляра необходимо указать initializeParams.sourceImage или disks.source. При необходимости с помощью этого свойства можно также подключить существующие постоянные диски, не являющиеся корневыми. Это поле применимо только к постоянным дискам. Возвращается: при успешном выполнении |
|
type string |
Тип диска: SCRATCH или PERSISTENT. Если значение не указано, по умолчанию используется PERSISTENT. Возвращается: при успешном выполнении |
|
guestAccelerators complex |
Список типов и количества ускорительных карт, подключенных к экземпляру. Возвращается: при успешном выполнении |
|
acceleratorCount integer |
Количество ускорительных карт, доступных этому экземпляру. Возвращается: при успешном выполнении |
|
acceleratorType string |
Полный или частичный URL ресурса типа ускорителя, который будет доступен этому экземпляру. Возвращается: при успешном выполнении |
|
hostname string |
Имя хоста создаваемого экземпляра. Указанное имя хоста должно соответствовать RFC1035. Если имя хоста не указано, по умолчанию используется [INSTANCE_NAME].c.[PROJECT_ID].internal при использовании глобальной DNS и [INSTANCE_NAME].[ZONE].c.[PROJECT_ID].internal при использовании зональной DNS. Возвращается: при успешном выполнении |
|
id integer |
Уникальный идентификатор ресурса. Этот идентификатор задается сервером. Возвращается: при успешном выполнении |
|
labelFingerprint string |
Отпечаток, используемый для оптимистической блокировки этого ресурса. Используется внутри системы при обновлении. Возвращается: при успешном выполнении |
|
labels dictionary |
Метки, применяемые к этому экземпляру. Список пар «ключ->значение». Возвращается: при успешном выполнении |
|
machineType string |
Ссылка на тип машины, определяющий вид виртуальной машины. Возвращается: при успешном выполнении |
|
metadata dictionary |
Пары ключ/значение метаданных, назначаемые экземплярам, созданным на основе этого шаблона. Эти пары могут содержать пользовательские метаданные или предопределенные ключи. Возвращается: при успешном выполнении |
|
minCpuPlatform string |
Задает минимальную платформу ЦП для экземпляра виртуальной машины. Допустимые значения — общепринятые названия платформ ЦП. Возвращается: при успешном выполнении |
|
name string |
Имя ресурса, указанное клиентом при его создании. Имя ресурса должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, оно должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие — дефисом, строчной буквой или цифрой, за исключением последнего символа, которым не может быть дефис. Возвращается: при успешном выполнении |
|
networkInterfaces complex |
Массив конфигураций этого интерфейса. В нем указывается, как интерфейс взаимодействует с другими сетевыми службами, например подключается к Интернету. Для одного экземпляра поддерживается только один сетевой интерфейс. Возвращается: при успешном выполнении |
|
accessConfigs complex |
Массив конфигураций этого интерфейса. В настоящее время поддерживается только одна конфигурация доступа — ONE_TO_ONE_NAT. Если accessConfigs не указаны, у этого экземпляра не будет доступа к внешнему Интернету. Возвращается: при успешном выполнении |
|
name string |
Имя этой конфигурации доступа. По умолчанию рекомендуется использовать имя External NAT, но можно задать любую строку. Например, My external IP или Network Access. Возвращается: при успешном выполнении |
|
natIP dictionary |
Ссылка на адрес. Внешний IP-адрес, связанный с этим экземпляром. Укажите неиспользуемый статический внешний IP-адрес, доступный проекту, или оставьте это поле незаполненным, чтобы использовать IP-адрес из общего пула эфемерных IP-адресов. Если указан статический внешний IP-адрес, он должен находиться в том же регионе, что и зона экземпляра. Возвращается: при успешном выполнении |
|
networkTier string |
Указывает уровень сети, используемый при настройке этой конфигурации доступа. Если указана AccessConfig без действительного внешнего IP-адреса, будет создан эфемерный IP-адрес с этим значением networkTier. Если указана AccessConfig с действительным внешним IP-адресом, ее значение должно совпадать с networkTier ресурса Address, которому принадлежит этот IP-адрес. Возвращается: при успешном выполнении |
|
publicPtrDomainName string |
Доменное имя DNS для общедоступной записи PTR. Это поле можно задать, только если включено поле setPublicPtr. Возвращается: при успешном выполнении |
|
setPublicPtr boolean |
Указывает, следует ли создать общедоступную запись DNS PTR для сопоставления внешнего IP-адреса экземпляра с доменным именем DNS. Возвращается: при успешном выполнении |
|
type string |
Тип конфигурации. По умолчанию используется единственный вариант — ONE_TO_ONE_NAT. Возвращается: при успешном выполнении |
|
aliasIpRanges complex |
Массив диапазонов псевдонимов IP-адресов для этого сетевого интерфейса. Их можно указывать только для сетевых интерфейсов в сетях с режимом подсетей. Возвращается: при успешном выполнении |
|
ipCidrRange string |
Диапазон IP CIDR, представленный этим диапазоном псевдонимных IP-адресов. Этот диапазон IP CIDR должен принадлежать указанной подсети и не может содержать IP-адреса, зарезервированные системой или используемые другими сетевыми интерфейсами. Диапазон может быть одним IP-адресом (например, 10.2.3.4), маской подсети (например, /24) или строкой в формате CIDR (например, 10.1.2.0/24). Возвращается: успешно |
|
subnetworkRangeName string |
Необязательное имя дополнительного диапазона подсети, указывающее диапазон, из которого выделяется диапазон IP CIDR для этого диапазона псевдонимных IP-адресов. Если не указано, используется основной диапазон подсети. Возвращается: успешно |
|
name string |
Имя сетевого интерфейса, созданное сервером. Для сетевых устройств это eth0, eth1 и т. д. Возвращается: успешно |
|
network dictionary |
Указывает имя существующей сети. Если имя сети не задано, выбирается сетевой интерфейс по умолчанию, для которого, возможно, уже настроен SSH. Возвращается: успешно |
|
networkIP string |
Внутренний сетевой адрес IPv4, назначаемый экземпляру для этого сетевого интерфейса. Если пользователь не указал адрес, система назначает неиспользуемый внутренний IP-адрес. Возвращается: успешно |
|
subnetwork dictionary |
Ссылка на сеть VPC. Если сетевой ресурс работает в устаревшем режиме, не указывайте это свойство. Если сеть работает в режиме автоматического создания подсетей, указывать подсеть необязательно. Если сеть работает в режиме пользовательских подсетей, это поле необходимо указать. Возвращается: успешно |
|
scheduling complex |
Задает параметры планирования для этого экземпляра. Возвращается: успешно |
|
automaticRestart boolean |
Указывает, следует ли автоматически перезапускать экземпляр, если он был остановлен Compute Engine (а не пользователем). Параметр автоматического перезапуска можно задать только для стандартных экземпляров. Прерываемые экземпляры нельзя перезапускать автоматически. Возвращается: успешно |
|
onHostMaintenance string |
Определяет поведение этого экземпляра во время обслуживания. Для стандартных экземпляров поведение по умолчанию — MIGRATE. Для прерываемых экземпляров поведение по умолчанию и единственно возможное поведение — TERMINATE. Дополнительные сведения см. в разделе «Настройка параметров планирования экземпляра». Возвращается: успешно |
|
preemptible boolean |
Определяет, является ли экземпляр прерываемым. Это можно задать только при создании экземпляра; после его создания изменить или задать это значение нельзя. Возвращается: успешно |
|
serviceAccounts complex |
Список учетных записей службы с указанными для них областями доступа, авторизованных для этого экземпляра. Для одного экземпляра ВМ поддерживается только одна учетная запись службы. Возвращается: успешно |
|
string |
Адрес электронной почты учетной записи службы. Возвращается: успешно |
|
scopes list / elements=string |
Список областей доступа, предоставляемых этой учетной записи службы. Возвращается: успешно |
|
shieldedInstanceConfig complex |
Конфигурация различных параметров, связанных с защищенными экземплярами. Возвращается: успешно |
|
enableIntegrityMonitoring boolean |
Определяет, включен ли для экземпляра мониторинг целостности. Возвращается: успешно |
|
enableSecureBoot boolean |
Определяет, включена ли для экземпляра безопасная загрузка (Secure Boot). Возвращается: успешно |
|
enableVtpm boolean |
Определяет, включен ли для экземпляра vTPM. Возвращается: успешно |
|
status string |
Состояние экземпляра. Возможные значения: PROVISIONING, STAGING, RUNNING, STOPPING, SUSPENDING, SUSPENDED и TERMINATED. Чтобы машина оставалась включенной, используйте RUNNING; чтобы выключить ее, используйте TERMINATED. Возвращается: успешно |
|
statusMessage string |
Необязательное пояснение состояния для пользователя. Возвращается: успешно |
|
tags complex |
Список тегов, применяемых к этому экземпляру. Теги используются для идентификации допустимых источников или целевых объектов сетевых брандмауэров и указываются клиентом при создании экземпляра. Позже теги можно изменить с помощью метода setTags. Каждый тег в списке должен соответствовать RFC1035. Возвращается: успешно |
|
fingerprint string |
Указывает отпечаток для этого запроса — по сути, хеш содержимого метаданных, используемый для оптимистичной блокировки. Первоначально отпечаток создается Compute Engine и изменяется после каждого запроса на изменение или обновление метаданных. Для обновления или изменения метаданных всегда необходимо указывать актуальный хеш отпечатка. Возвращается: успешно |
|
tag_values list / elements=string |
Массив тегов. Длина каждого тега должна составлять от 1 до 63 символов, а сам тег должен соответствовать RFC1035. Возвращается: успешно |
|
zone string |
Ссылка на зону, в которой находится машина. Возвращается: успешно |
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/google/cloud/gcp_compute_instance_info_module.html