модуль google.cloud.gcp_compute_instance — Создает экземпляр GCP
Примечание
Этот модуль входит в коллекцию google.cloud (версия 1.13.0).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.
Чтобы установить ее, используйте: ansible-galaxy collection install google.cloud. Для использования этого модуля необходимы дополнительные требования; подробную информацию см. в разделе Требования.
Чтобы использовать его в плейбуке, укажите: google.cloud.gcp_compute_instance.
Обзор
- Экземпляр — это виртуальная машина (VM), размещенная в инфраструктуре Google.
Требования
На хосте, выполняющем этот модуль, должны быть установлены перечисленные ниже компоненты.
- python >= 2.6
- requests >= 2.18.4
- google-auth >= 1.3.0
Параметры
Параметр | Комментарии |
|---|---|
access_token string | Токен доступа OAuth2, если тип учетных данных — accesstoken. |
auth_kind string / обязательный | Тип используемых учетных данных. Варианты:
|
can_ip_forward псевдонимы: ip_forward boolean | Разрешает этому экземпляру отправлять и получать пакеты, IP-адреса назначения или источника которых не совпадают с IP-адресами экземпляра. Это необходимо, если вы планируете использовать экземпляр для перенаправления маршрутов. Варианты:
|
confidential_instance_config dictionary | Конфигурация конфиденциальных вычислений (требуется указать тип машины из семейства n2d-* и загрузочный диск типа pd-ssd). |
|
enable_confidential_compute boolean |
Включает конфиденциальные вычисления. Варианты:
|
deletion_protection boolean | Следует ли защитить ресурс от удаления. Варианты:
|
discard_local_ssd boolean | Удаляет содержимое всех подключенных дисков Local SSD при изменении состояния на TERMINATED. Варианты:
|
disks list / элементы=dictionary | Массив дисков, связанных с экземплярами, создаваемыми на основе этого шаблона. |
|
auto_delete boolean |
Указывает, будет ли диск автоматически удален при удалении экземпляра (но не при отсоединении диска от экземпляра). Совет: для дисков следует установить autoDelete=true, чтобы при удалении машины не оставались неиспользуемые диски. Варианты:
|
|
boot boolean |
Указывает, что это загрузочный диск. Виртуальная машина будет использовать первый раздел диска в качестве корневой файловой системы. Варианты:
|
|
device_name string |
Задает уникальное имя устройства на ваш выбор, которое будет отображаться в дереве /dev/disk/by-id/google-* операционной системы Linux, работающей в экземпляре. Это имя можно использовать в экземпляре для обращения к устройству при его подключении, изменении размера и т. п. |
|
disk_encryption_key dictionary |
Шифрует или расшифровывает диск с помощью предоставленного клиентом ключа шифрования. |
|
raw_key string |
Задает предоставленный клиентом 256-битный ключ шифрования в кодировке base64 согласно RFC 4648, используемый для шифрования или расшифровки этого ресурса. |
|
rsa_encrypted_key string |
Задает предоставленный клиентом 2048-битный ключ шифрования, обернутый RSA и закодированный в base64 согласно RFC 4648, используемый для шифрования или расшифровки этого ресурса. |
|
index integer |
Назначает этому диску индекс, начинающийся с нуля; индекс 0 зарезервирован для загрузочного диска. Например, если к экземпляру подключено несколько дисков, каждому диску будет присвоен уникальный индекс. Если значение не указано, сервер выберет подходящее. |
|
initialize_params dictionary |
Задает параметры нового диска, который будет создан вместе с новым экземпляром. Используйте параметры инициализации для создания загрузочных дисков или локальных дисков SSD, подключенных к новому экземпляру. |
|
disk_name string |
Задает имя диска. Если оно не указано, по умолчанию используется имя экземпляра. |
|
disk_size_gb integer |
Задает размер диска в ГБ по основанию 2. |
|
disk_type string |
Ссылка на тип диска. Задает тип диска, который будет использоваться для создания экземпляра. Если значение не указано, по умолчанию используется pd-standard. |
|
source_image псевдонимы: image, image_family string |
Исходный образ для создания этого диска. При создании нового экземпляра требуется указать initializeParams.sourceImage или disks.source. Чтобы создать диск на основе одного из общедоступных образов операционных систем, укажите образ по имени семейства. |
|
source_image_encryption_key dictionary |
Предоставленный клиентом ключ шифрования исходного образа. Обязателен, если исходный образ защищен ключом шифрования, предоставленным клиентом. Шаблоны экземпляров не хранят ключи шифрования, предоставленные клиентом, поэтому нельзя создавать диски для экземпляров в управляемой группе экземпляров, если исходные образы зашифрованы вашими собственными ключами. |
|
raw_key string |
Задает предоставленный клиентом 256-битный ключ шифрования в кодировке base64 согласно RFC 4648, используемый для шифрования или расшифровки этого ресурса. |
|
interface string |
Задает интерфейс диска для его подключения: SCSI или NVME. По умолчанию используется SCSI. Для постоянных дисков всегда необходимо использовать SCSI. Запрос завершится ошибкой, если попытаться подключить постоянный диск в формате, отличном от SCSI. Допустимые варианты: «SCSI», «NVME» |
|
mode string |
Режим подключения диска: READ_WRITE или READ_ONLY. Если значение не указано, по умолчанию диск подключается в режиме READ_WRITE. Допустимые варианты: «READ_WRITE», «READ_ONLY» |
|
source dictionary |
Ссылка на диск. При создании нового экземпляра требуется указать initializeParams.sourceImage или disks.source. При необходимости с помощью этого свойства можно также подключить существующие постоянные диски, не являющиеся корневыми. Это поле применимо только к постоянным дискам. Это поле представляет собой ссылку на ресурс Disk в GCP. Ее можно указать двумя способами. Во-первых, можно передать словарь с ключом ‘selfLink’ и значением selfLink вашего ресурса. Во-вторых, можно добавить `register: name-of-resource` в задачу gcp_compute_disk, а затем установить в этом поле source значение “{{ name-of-resource }}” |
|
type string |
Задает тип диска: SCRATCH или PERSISTENT. Если значение не указано, по умолчанию используется PERSISTENT. Допустимые варианты: «SCRATCH», «PERSISTENT» |
env_type string | Указывает среду Ansible, в которой выполняется этот модуль. Не задавайте это значение, если не знаете, что делаете. Оно влияет только на строку User Agent во всех запросах к API. |
guest_accelerators list / элементы=dictionary | Список типов и количества ускорительных карт, подключенных к экземпляру. |
|
accelerator_count integer |
Количество ускорительных карт, доступных этому экземпляру. |
|
accelerator_type string |
Полный или частичный URL ресурса типа ускорителя, доступного этому экземпляру. |
hostname string | Имя хоста создаваемого экземпляра. Указанное имя хоста должно соответствовать RFC1035. Если имя хоста не указано, по умолчанию используется [INSTANCE_NAME].c.[PROJECT_ID].internal при использовании глобальной DNS и [INSTANCE_NAME].[ZONE].c.[PROJECT_ID].internal при использовании зональной DNS. |
labels dictionary | Метки, применяемые к этому экземпляру. Список пар ключ->значение. |
machine_type string | Ссылка на тип машины, определяющий вид виртуальной машины. |
metadata dictionary | Пары ключ/значение метаданных, назначаемые экземплярам, создаваемым на основе этого шаблона. Эти пары могут содержать пользовательские метаданные или предопределенные ключи. |
min_cpu_platform string | Задает минимальную платформу ЦП для экземпляра виртуальной машины. Допустимые значения — общепринятые названия платформ ЦП. |
name string | Имя ресурса, задаваемое клиентом при первоначальном создании ресурса. Имя ресурса должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, которым не может быть дефис. |
network_interfaces list / элементы=dictionary | Массив конфигураций этого интерфейса. Указывает, как интерфейс взаимодействует с другими сетевыми службами, например подключается к Интернету. Для каждого экземпляра поддерживается только один сетевой интерфейс. |
|
access_configs list / элементы=dictionary |
Массив конфигураций этого интерфейса. В настоящее время поддерживается только одна конфигурация доступа — ONE_TO_ONE_NAT. Если accessConfigs не указаны, у этого экземпляра не будет внешнего доступа к Интернету. |
|
name string / обязательный |
Имя этой конфигурации доступа. По умолчанию рекомендуется имя External NAT, но можно использовать любую произвольную строку, например My external IP или Network Access. |
|
nat_ip dictionary |
Ссылка на адрес. Внешний IP-адрес, связанный с этим экземпляром. Укажите неиспользуемый статический внешний IP-адрес, доступный проекту, или оставьте это поле незаполненным, чтобы использовать IP-адрес из общего пула эфемерных IP-адресов. Если указан статический внешний IP-адрес, он должен находиться в том же регионе, что и зона экземпляра. Это поле представляет собой ссылку на ресурс Address в GCP. Ее можно указать двумя способами. Во-первых, можно передать словарь с ключом ‘address’ и значением адреса вашего ресурса. Во-вторых, можно добавить `register: name-of-resource` в задачу gcp_compute_address, а затем установить в этом поле nat_ip значение “{{ name-of-resource }}” |
|
network_tier string |
Уровень сети, используемый при настройке этой конфигурации доступа. Если задан AccessConfig без допустимого внешнего IP-адреса, для этого networkTier будет создан эфемерный IP-адрес. Если задан AccessConfig с допустимым внешним IP-адресом, его уровень должен соответствовать networkTier, связанному с ресурсом Address, которому принадлежит этот IP-адрес. Допустимые варианты: «PREMIUM», «STANDARD» |
|
public_ptr_domain_name string |
Доменное имя DNS для общедоступной записи PTR. Это поле можно задать, только если включено поле setPublicPtr. |
|
set_public_ptr boolean |
Указывает, следует ли создать общедоступную запись DNS PTR для сопоставления внешнего IP-адреса экземпляра с доменным именем DNS. Варианты:
|
|
type string / обязательный |
Тип конфигурации. По умолчанию и в качестве единственного варианта используется ONE_TO_ONE_NAT. Допустимый вариант: «ONE_TO_ONE_NAT» |
|
alias_ip_ranges list / элементы=dictionary |
Массив диапазонов псевдонимных IP-адресов для этого сетевого интерфейса. Можно указать только для сетевых интерфейсов в сетях с режимом подсетей. |
|
ip_cidr_range string |
Диапазон IP CIDR, представленный этим диапазоном псевдонимных IP-адресов. Этот диапазон IP CIDR должен относиться к указанной подсети и не может содержать IP-адреса, зарезервированные системой или используемые другими сетевыми интерфейсами. Диапазон может быть одним IP-адресом (например, 10.2.3.4), маской подсети (например, /24) или строкой в формате CIDR (например, 10.1.2.0/24). |
|
subnetwork_range_name string |
Необязательное имя дополнительного диапазона подсети, из которого выделяется диапазон IP CIDR для этого диапазона псевдонимных IP-адресов. Если значение не указано, будет использоваться основной диапазон подсети. |
|
network dictionary |
Задает название существующей сети. Если название сети не указано, будет выбран сетевой интерфейс по умолчанию, для которого может быть уже настроен SSH. Это поле представляет собой ссылку на ресурс Network в GCP. Ее можно указать двумя способами. Во-первых, можно передать словарь с ключом ‘selfLink’ и значением selfLink вашего ресурса. Во-вторых, можно добавить `register: name-of-resource` в задачу gcp_compute_network, а затем установить в этом поле network значение “{{ name-of-resource }}” |
|
network_ip string |
Внутренний сетевой адрес IPv4, назначаемый экземпляру для этого сетевого интерфейса. Если пользователь не указал адрес, система назначит неиспользуемый внутренний IP-адрес. |
|
nic_type string |
Тип сетевой карты, подключенной к экземпляру. Если значение не указано, будет использоваться тип по умолчанию, предоставляемый GCP. gVNIC — это сетевой интерфейс нового поколения, пришедший на смену VirtIO. В Compute Engine он заменяет VirtIO-Net и становится единственным поддерживаемым сетевым интерфейсом для всех новых типов машин (поколение 3 и новее). Для новых серий машин и сетевых функций требуется gVNIC вместо VirtIO. Варианты:
|
|
subnetwork dictionary |
Ссылка на сеть VPC. Если ресурс сети находится в устаревшем режиме, не указывайте это свойство. Если сеть работает в режиме автоматического создания подсетей, указывать подсеть необязательно. Если сеть работает в режиме пользовательских подсетей, это поле необходимо указать. Это поле представляет собой ссылку на ресурс Subnetwork в GCP. Его можно задать двумя способами. Во-первых, можно указать словарь с ключом ‘selfLink’ и значением selfLink ресурса. Также можно добавить `register: name-of-resource` в задачу gcp_compute_subnetwork, а затем присвоить этому полю subnetwork значение “{{ name-of-resource }}” |
project string | Проект Google Cloud Platform, который будет использоваться. |
scheduling dictionary | Задает параметры планирования для этого экземпляра. |
|
automatic_restart boolean |
Указывает, следует ли автоматически перезапускать экземпляр, если он был остановлен Compute Engine (а не пользователем). Параметр автоматического перезапуска можно задать только для стандартных экземпляров. Прерываемые экземпляры нельзя перезапускать автоматически. Варианты:
|
|
on_host_maintenance string |
Определяет поведение этого экземпляра во время обслуживания. Для стандартных экземпляров по умолчанию используется поведение MIGRATE. Для прерываемых экземпляров поведение по умолчанию и единственно возможное поведение — TERMINATE. Дополнительные сведения см. в разделе «Настройка параметров планирования экземпляра». |
|
preemptible boolean |
Определяет, является ли экземпляр прерываемым. Этот параметр можно задать только при создании экземпляра; изменить его после создания экземпляра нельзя. Варианты:
|
scopes list / elements=string | Массив используемых областей доступа |
service_account_contents jsonarg | Содержимое JSON-файла сервисного аккаунта в виде словаря или JSON-строки, представляющей это содержимое. |
service_account_email string | Необязательный адрес электронной почты сервисного аккаунта, если выбрано machineaccount и пользователь не хочет использовать адрес по умолчанию. |
service_account_file path | Путь к JSON-файлу сервисного аккаунта, если в качестве типа выбрано serviceaccount. |
service_accounts list / elements=dictionary | Список сервисных аккаунтов с указанными для них областями доступа, авторизованных для этого экземпляра. Для одного экземпляра ВМ поддерживается только один сервисный аккаунт. |
|
string |
Адрес электронной почты сервисного аккаунта. |
|
scopes list / elements=string |
Список областей доступа, предоставляемых этому сервисному аккаунту. |
shielded_instance_config dictionary | Настройки различных параметров, относящихся к защищенным экземплярам. |
|
enable_integrity_monitoring boolean |
Определяет, включен ли для экземпляра мониторинг целостности. Варианты:
|
|
enable_secure_boot boolean |
Определяет, включена ли для экземпляра безопасная загрузка Secure Boot. Варианты:
|
|
enable_vtpm boolean |
Определяет, включен ли для экземпляра vTPM. Варианты:
|
state string | Должен ли указанный объект существовать в GCP Варианты:
|
status string | Статус экземпляра. Возможные значения: PROVISIONING, STAGING, RUNNING, STOPPING, SUSPENDING, SUSPENDED и TERMINATED. Чтобы оставить машину включенной, используйте RUNNING; чтобы выключить ее — TERMINATED. Некоторые допустимые варианты: “PROVISIONING”, “STAGING”, “RUNNING”, “STOPPING”, “SUSPENDING”, “SUSPENDED”, “TERMINATED” |
tags dictionary | Список тегов, применяемых к этому экземпляру. Теги используются для определения допустимых источников или целей сетевых брандмауэров и задаются клиентом при создании экземпляра. Позднее теги можно изменить с помощью метода setTags. Каждый тег в списке должен соответствовать RFC1035. |
|
fingerprint string |
Задает отпечаток для этого запроса — по сути, хеш содержимого метаданных, используемый для оптимистической блокировки. Изначально отпечаток создается Compute Engine и меняется после каждого запроса на изменение или обновление метаданных. Для обновления или изменения метаданных необходимо всегда указывать актуальный хеш отпечатка. |
|
items list / elements=string |
Устарело. Используйте tag_values. |
|
tag_values list / elements=string |
Массив тегов. Длина каждого тега должна составлять от 1 до 63 символов; он должен соответствовать RFC1035. |
zone string / обязательный | Ссылка на зону, в которой находится машина. |
Примеры
- name: create a disk
google.cloud.gcp_compute_disk:
name: disk-instance
size_gb: 50
source_image: projects/ubuntu-os-cloud/global/images/family/ubuntu-1604-lts
zone: us-central1-a
project: "{{ gcp_project }}"
auth_kind: "{{ gcp_cred_kind }}"
service_account_file: "{{ gcp_cred_file }}"
state: present
register: disk
- name: create a network
google.cloud.gcp_compute_network:
name: network-instance
project: "{{ gcp_project }}"
auth_kind: "{{ gcp_cred_kind }}"
service_account_file: "{{ gcp_cred_file }}"
state: present
register: network
- name: create a address
google.cloud.gcp_compute_address:
name: address-instance
region: us-central1
project: "{{ gcp_project }}"
auth_kind: "{{ gcp_cred_kind }}"
service_account_file: "{{ gcp_cred_file }}"
state: present
register: address
- name: create a instance
google.cloud.gcp_compute_instance:
name: test_object
machine_type: n1-standard-1
disks:
- auto_delete: 'true'
boot: 'true'
source: "{{ disk }}"
- auto_delete: 'true'
interface: NVME
type: SCRATCH
initialize_params:
disk_type: local-ssd
metadata:
startup-script-url: gs:://graphite-playground/bootstrap.sh
cost-center: '12345'
labels:
environment: production
network_interfaces:
- network: "{{ network }}"
access_configs:
- name: External NAT
nat_ip: "{{ address }}"
type: ONE_TO_ONE_NAT
zone: us-central1-a
project: test_project
auth_kind: serviceaccount
service_account_file: "/tmp/auth.pem"
state: present
Возвращаемые значения
Общие возвращаемые значения описаны здесь; ниже перечислены поля, уникальные для этого модуля:
Ключ | Описание |
|---|---|
canIpForward boolean | Разрешает этому экземпляру отправлять и получать пакеты с IP-адресами назначения или источника, не совпадающими с его собственными. Это необходимо, если вы планируете использовать этот экземпляр для пересылки маршрутов. Возвращается: успешно |
confidentialInstanceConfig complex | Конфигурация для конфиденциальных вычислений (требуется установить тип машины на любой из типов n2d-* и использовать загрузочный диск типа pd-ssd). Возвращается: успешно |
|
enableConfidentialCompute boolean |
Включает конфиденциальные вычисления. Возвращается: успешно |
cpuPlatform string | Платформа ЦП, используемая этим экземпляром. Возвращается: успешно |
creationTimestamp string | Временная метка создания в текстовом формате RFC3339. Возвращается: успешно |
deletionProtection boolean | Указывает, следует ли защитить ресурс от удаления. Возвращается: успешно |
disks complex | Массив дисков, связанных с экземплярами, создаваемыми на основе этого шаблона. Возвращается: успешно |
|
autoDelete boolean |
Указывает, будет ли диск удален автоматически при удалении экземпляра (но не при отсоединении диска от экземпляра). Совет: для дисков следует установить значение autoDelete=true, чтобы после удаления машины не оставались неиспользуемые диски. Возвращается: успешно |
|
boot boolean |
Указывает, что это загрузочный диск. Виртуальная машина будет использовать первый раздел диска в качестве корневой файловой системы. Возвращается: успешно |
|
deviceName string |
Задает выбранное вами уникальное имя устройства, которое отображается в дереве /dev/disk/by-id/google-* операционной системы Linux, работающей в экземпляре. Это имя можно использовать для обращения к устройству из экземпляра, например, при подключении или изменении размера. Возвращается: успешно |
|
diskEncryptionKey complex |
Шифрует или расшифровывает диск с помощью ключа шифрования, предоставленного пользователем. Возвращается: успешно |
|
rawKey string |
Задает предоставленный пользователем 256-битный ключ шифрования в кодировке base64 RFC 4648 для шифрования или расшифровки этого ресурса. Возвращается: успешно |
|
rsaEncryptedKey string |
Задает предоставленный пользователем 2048-битный ключ шифрования, обернутый с помощью RSA и закодированный в base64 RFC 4648, для шифрования или расшифровки этого ресурса. Возвращается: успешно |
|
sha256 string |
Хеш SHA-256 предоставленного пользователем ключа шифрования, защищающего этот ресурс, закодированный в base64 RFC 4648. Возвращается: успешно |
|
index integer |
Назначает этому диску индекс, начинающийся с нуля, где 0 зарезервирован для загрузочного диска. Например, если к экземпляру подключено несколько дисков, у каждого диска будет уникальный номер индекса. Если значение не задано, сервер выберет подходящее значение. Возвращается: успешно |
|
initializeParams complex |
Задает параметры нового диска, который будет создан вместе с новым экземпляром. Используйте параметры инициализации для создания загрузочных дисков или локальных SSD, подключаемых к новому экземпляру. Возвращается: успешно |
|
diskName string |
Задает имя диска. Если оно не указано, по умолчанию используется имя экземпляра. Возвращается: успешно |
|
diskSizeGb integer |
Задает размер диска в ГБ в системе счисления с основанием 2. Возвращается: успешно |
|
diskType string |
Ссылка на тип диска. Задает тип диска, используемого для создания экземпляра. Если значение не указано, по умолчанию используется pd-standard. Возвращается: успешно |
|
sourceImage string |
Исходный образ для создания этого диска. При создании нового экземпляра необходимо указать initializeParams.sourceImage или disks.source. Чтобы создать диск на основе одного из общедоступных образов операционных систем, укажите образ по имени семейства. Возвращается: успешно |
|
sourceImageEncryptionKey complex |
Ключ шифрования исходного образа, предоставленный пользователем. Обязателен, если исходный образ защищен ключом шифрования, предоставленным пользователем. Шаблоны экземпляров не хранят ключи шифрования, предоставленные пользователем, поэтому нельзя создавать диски для экземпляров в управляемой группе экземпляров, если исходные образы зашифрованы вашими собственными ключами. Возвращается: успешно |
|
rawKey string |
Задает предоставленный пользователем 256-битный ключ шифрования в кодировке base64 RFC 4648 для шифрования или расшифровки этого ресурса. Возвращается: успешно |
|
sha256 string |
Хеш SHA-256 предоставленного пользователем ключа шифрования, защищающего этот ресурс, закодированный в base64 RFC 4648. Возвращается: успешно |
|
interface string |
Задает интерфейс диска для его подключения: SCSI или NVME. По умолчанию используется SCSI. Для постоянных дисков всегда необходимо использовать SCSI; запрос завершится ошибкой, если попытаться подключить постоянный диск в формате, отличном от SCSI. Возвращается: успешно |
|
mode string |
Режим подключения диска: READ_WRITE или READ_ONLY. Если значение не указано, по умолчанию диск подключается в режиме READ_WRITE. Возвращается: успешно |
|
source dictionary |
Ссылка на диск. При создании нового экземпляра необходимо указать initializeParams.sourceImage или disks.source. При необходимости с помощью этого свойства можно также подключить существующие постоянные диски, не являющиеся корневыми. Это поле применимо только к постоянным дискам. Возвращается: успешно |
|
type string |
Задает тип диска: SCRATCH или PERSISTENT. Если значение не указано, по умолчанию используется PERSISTENT. Возвращается: успешно |
guestAccelerators complex | Список типов и количества ускорительных карт, подключенных к экземпляру. Возвращается: успешно |
|
acceleratorCount integer |
Количество ускорительных карт, доступных этому экземпляру. Возвращается: успешно |
|
acceleratorType string |
Полный или частичный URL ресурса типа ускорителя, предоставляемого этому экземпляру. Возвращается: успешно |
hostname string | Имя хоста создаваемого экземпляра. Указанное имя хоста должно соответствовать RFC1035. Если имя хоста не задано, при использовании глобальной DNS по умолчанию используется имя [INSTANCE_NAME].c.[PROJECT_ID].internal, а при использовании зональной DNS — [INSTANCE_NAME].[ZONE].c.[PROJECT_ID].internal. Возвращается: успешно |
id integer | Уникальный идентификатор ресурса. Этот идентификатор задается сервером. Возвращается: успешно |
labelFingerprint string | Отпечаток, используемый для оптимистической блокировки этого ресурса. Используется внутри системы во время обновлений. Возвращается: успешно |
labels dictionary | Метки, применяемые к этому экземпляру. Список пар «ключ->значение». Возвращается: успешно |
machineType string | Ссылка на тип машины, определяющий тип виртуальной машины. Список актуальных допустимых типов машин см. на странице https://cloud.google.com/compute/docs/machine-types. Возвращается: успешно |
metadata dictionary | Пары ключ/значение метаданных, назначаемые экземплярам, созданным на основе этого шаблона. Эти пары могут содержать пользовательские метаданные или предопределенные ключи. Возвращается: успешно |
minCpuPlatform string | Задает минимальную платформу ЦП для экземпляра виртуальной машины. Допустимые значения — понятные пользователю названия платформ ЦП. Возвращается: успешно |
name string | Имя ресурса, задаваемое клиентом при первоначальном создании ресурса. Имя ресурса должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, последующие символы — дефисом, строчной буквой или цифрой, а последний символ не может быть дефисом. Возвращается: успешно |
networkInterfaces complex | Массив конфигураций этого интерфейса. В нем задается настройка взаимодействия интерфейса с другими сетевыми службами, например подключение к интернету. Для каждого экземпляра поддерживается только один сетевой интерфейс. Возвращается: успешно |
|
accessConfigs complex |
Массив конфигураций этого интерфейса. В настоящее время поддерживается только одна конфигурация доступа — ONE_TO_ONE_NAT. Если accessConfigs не указаны, у этого экземпляра не будет внешнего доступа к интернету. Возвращается: успешно |
|
name string |
Имя этой конфигурации доступа. По умолчанию рекомендуется использовать имя External NAT, но можно указать любую произвольную строку. Например: My external IP или Network Access. Возвращается: успешно |
|
natIP dictionary |
Ссылка на адрес. Внешний IP-адрес, связанный с этим экземпляром. Укажите неиспользуемый статический внешний IP-адрес, доступный проекту, или оставьте это поле незаполненным, чтобы использовать IP-адрес из общего пула временных IP-адресов. Если указан статический внешний IP-адрес, он должен находиться в том же регионе, что и зона экземпляра. Возвращается: успешно |
|
networkTier string |
Указывает уровень сети, используемый для настройки этой конфигурации доступа. Если AccessConfig задана без действительного внешнего IP-адреса, для этого networkTier будет создан временный IP-адрес. Если AccessConfig задана с действительным внешним IP-адресом, этот адрес должен соответствовать networkTier, связанному с ресурсом Address, которому принадлежит данный IP-адрес. Возвращается: успешно |
|
publicPtrDomainName string |
Доменное имя DNS для общедоступной записи PTR. Это поле можно задать, только если включено поле setPublicPtr. Возвращается: успешно |
|
setPublicPtr boolean |
Указывает, следует ли создать общедоступную запись DNS PTR, сопоставляющую внешний IP-адрес экземпляра с доменным именем DNS. Возвращается: успешно |
|
type string |
Тип конфигурации. По умолчанию используется единственный вариант — ONE_TO_ONE_NAT. Возвращается: успешно |
|
aliasIpRanges complex |
Массив диапазонов псевдонимов IP-адресов для этого сетевого интерфейса. Можно указать только для сетевых интерфейсов в сетях с режимом подсетей. Возвращается: успешно |
|
ipCidrRange string |
Диапазон IP CIDR, представленный этим диапазоном псевдонимов IP-адресов. Этот диапазон IP CIDR должен принадлежать указанной подсети и не может содержать IP-адреса, зарезервированные системой или используемые другими сетевыми интерфейсами. Диапазон может представлять собой один IP-адрес (например, 10.2.3.4), маску подсети (например, /24) или строку в формате CIDR (например, 10.1.2.0/24). Возвращается: успешно |
|
subnetworkRangeName string |
Необязательное имя дополнительного диапазона подсети, из которого выделяется диапазон IP CIDR для этого диапазона псевдонимов IP-адресов. Если значение не указано, будет использоваться основной диапазон подсети. Возвращается: успешно |
|
name string |
Имя сетевого интерфейса, созданное сервером. Для сетевых устройств это eth0, eth1 и т. д. Возвращается: при успехе |
|
network dictionary |
Указывает имя существующей сети. Если имя сети не задано, будет выбран сетевой интерфейс по умолчанию, для которого, возможно, уже настроен SSH. Возвращается: при успехе |
|
networkIP string |
Внутренний сетевой адрес IPv4, назначаемый экземпляру для этого сетевого интерфейса. Если пользователь не указал адрес, система назначит неиспользуемый внутренний IP-адрес. Возвращается: при успехе |
|
subnetwork dictionary |
Ссылка на сеть VPC. Если ресурс сети работает в устаревшем режиме, не указывайте это свойство. Если сеть работает в режиме автоматических подсетей, указывать подсеть необязательно. Если сеть работает в режиме пользовательских подсетей, это поле необходимо заполнить. Возвращается: при успехе |
scheduling complex | Задает параметры планирования для этого экземпляра. Возвращается: при успехе |
|
automaticRestart boolean |
Указывает, следует ли автоматически перезапускать экземпляр, если его остановил Compute Engine (а не пользователь). Автоматический перезапуск можно настроить только для стандартных экземпляров. Прерываемые экземпляры нельзя перезапускать автоматически. Возвращается: при успехе |
|
onHostMaintenance string |
Определяет поведение этого экземпляра во время обслуживания. Для стандартных экземпляров поведение по умолчанию — MIGRATE. Для прерываемых экземпляров поведение по умолчанию и единственно возможное поведение — TERMINATE. Подробнее см. в разделе «Настройка параметров планирования экземпляра». Возвращается: при успехе |
|
preemptible boolean |
Определяет, является ли экземпляр прерываемым. Это значение можно задать только при создании экземпляра; после его создания задать или изменить его нельзя. Возвращается: при успехе |
serviceAccounts complex | Список учетных записей службы с указанными для них областями доступа, авторизованных для этого экземпляра. Для каждого экземпляра виртуальной машины поддерживается только одна учетная запись службы. Возвращается: при успехе |
|
string |
Адрес электронной почты учетной записи службы. Возвращается: при успехе |
|
scopes list / elements=string |
Список областей доступа, доступных для этой учетной записи службы. Возвращается: при успехе |
shieldedInstanceConfig complex | Настройки различных параметров, связанных с защищенными экземплярами. Возвращается: при успехе |
|
enableIntegrityMonitoring boolean |
Определяет, включен ли для экземпляра мониторинг целостности. Возвращается: при успехе |
|
enableSecureBoot boolean |
Определяет, включена ли для экземпляра безопасная загрузка. Возвращается: при успехе |
|
enableVtpm boolean |
Определяет, включен ли для экземпляра vTPM. Возвращается: при успехе |
status string | Статус экземпляра. Возможные значения: PROVISIONING, STAGING, RUNNING, STOPPING, SUSPENDING, SUSPENDED и TERMINATED. Чтобы машина оставалась включенной, используйте RUNNING; чтобы выключить ее, используйте TERMINATED. Возвращается: при успехе |
statusMessage string | Необязательное пояснение статуса в удобочитаемом виде. Возвращается: при успехе |
tags complex | Список тегов, применяемых к этому экземпляру. Теги используются для идентификации допустимых источников или целей сетевых брандмауэров и задаются клиентом при создании экземпляра. Позже теги можно изменить с помощью метода setTags. Каждый тег в списке должен соответствовать RFC1035. Возвращается: при успехе |
|
fingerprint string |
Указывает отпечаток для этого запроса — по сути, хеш содержимого метаданных, используемый для оптимистической блокировки. Изначально отпечаток создается Compute Engine и меняется после каждого запроса на изменение или обновление метаданных. Для обновления или изменения метаданных всегда необходимо указывать актуальный хеш отпечатка. Возвращается: при успехе |
|
tag_values list / elements=string |
Массив тегов. Длина каждого тега должна составлять от 1 до 63 символов, а сам тег должен соответствовать RFC1035. Возвращается: при успехе |
zone string | Ссылка на зону, в которой находится машина. Возвращается: при успехе |
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/google/cloud/gcp_compute_instance_module.html