Модуль google.cloud.gcp_compute_interconnect_attachment_info — сбор сведений о GCP InterconnectAttachment
Примечание
Этот модуль входит в коллекцию google.cloud (версия 1.13.0).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.
Чтобы установить ее, используйте: ansible-galaxy collection install google.cloud. Для использования этого модуля требуются дополнительные компоненты. Подробности см. в разделе Требования.
Чтобы использовать модуль в плейбуке, укажите: google.cloud.gcp_compute_interconnect_attachment_info.
Краткое описание
- Сбор сведений о GCP InterconnectAttachment
Требования
На узле, на котором выполняется этот модуль, должны быть установлены перечисленные ниже компоненты.
- python >= 2.6
- requests >= 2.18.4
- google-auth >= 1.3.0
Параметры
Параметр | Комментарии |
|---|---|
access_token string | Токен доступа OAuth2, если тип учетных данных — accesstoken. |
auth_kind string / обязательный | Тип используемых учетных данных. Варианты:
|
env_type string | Указывает среду Ansible, в которой выполняется этот модуль. Не задавайте это значение, если не знаете, что делаете. Это влияет только на строку User Agent для запросов к API. |
filters list / элементы=string | Список пар значений фильтров. Доступные фильтры перечислены здесь: https://cloud.google.com/sdk/gcloud/reference/topic/filters. Каждый дополнительный фильтр в списке добавляется как условие И (filter1 и filter2). |
project string | Проект Google Cloud Platform, который будет использоваться. |
region string / обязательный | Регион, в котором находится региональное подключение interconnect. |
scopes list / элементы=string | Массив используемых областей действия |
service_account_contents jsonarg | Содержимое JSON-файла учетной записи службы в виде словаря или строки JSON, представляющей это содержимое. |
service_account_email string | Необязательный адрес электронной почты учетной записи службы, если выбран machineaccount и пользователь не хочет использовать адрес электронной почты по умолчанию. |
service_account_file path | Путь к JSON-файлу учетной записи службы, если в качестве типа выбрано serviceaccount. |
Примечания
Примечание
- Для аутентификации можно задать service_account_file с помощью переменной окружения
GCP_SERVICE_ACCOUNT_FILE. - Для аутентификации можно задать service_account_contents с помощью переменной окружения
GCP_SERVICE_ACCOUNT_CONTENTS. - Для аутентификации можно задать service_account_email с помощью переменной окружения
GCP_SERVICE_ACCOUNT_EMAIL. - Для аутентификации можно задать access_token с помощью переменной окружения
GCP_ACCESS_TOKEN. - Для аутентификации можно задать auth_kind с помощью переменной окружения
GCP_AUTH_KIND. - Для аутентификации можно задать scopes с помощью переменной окружения
GCP_SCOPES. - Значения переменных окружения используются только в том случае, если значения не заданы в плейбуке.
- Параметры service_account_email и service_account_file являются взаимоисключающими.
Примеры
- name: get info on an interconnect attachment
gcp_compute_interconnect_attachment_info:
region: us-central1
filters:
- name = test_object
project: test_project
auth_kind: serviceaccount
service_account_file: "/tmp/auth.pem"
Возвращаемые значения
Общие возвращаемые значения описаны здесь. Ниже перечислены поля, уникальные для этого модуля:
Ключ | Описание |
|---|---|
resources complex | Список ресурсов Возвращается: всегда |
|
adminEnabled boolean |
Указывает, включено или отключено подключение VLAN. Для типа PARTNER это значение предварительно активирует подключение interconnect. Возвращается: при успехе |
|
bandwidth string |
Предоставленная пропускная способность подключения interconnect. Для подключений типа DEDICATED пользователь может задавать пропускную способность. Для подключений типа PARTNER пропускную способность должен задавать партнер Google, обслуживающий подключение interconnect. Для типа PARTNER доступно только для вывода; для PARTNER_PROVIDER и DEDICATED значение изменяемое. По умолчанию — BPS_10G. Возвращается: при успехе |
|
candidateSubnets list / элементы=string |
До 16 возможных префиксов, которые можно использовать для ограничения выделения cloudRouterIpAddress и customerRouterIpAddress для этого подключения. Все префиксы должны входить в пространство локальных адресов канала (169.254.0.0/16) и иметь длину /29 или меньшее значение (/28, /27 и т. д.). Google попытается выбрать неиспользуемую подсеть /29 из предоставленных возможных префиксов. Запрос завершится ошибкой, если все возможные подсети /29 используются на периферии Google. Если значение не указано, Google случайным образом выберет неиспользуемую подсеть /29 из всего пространства локальных адресов канала. Возвращается: при успехе |
|
cloudRouterIpAddress string |
IPv4-адрес и длина префикса, которые следует настроить в интерфейсе Cloud Router для этого подключения interconnect. Возвращается: при успехе |
|
creationTimestamp string |
Временная метка создания в текстовом формате RFC3339. Возвращается: при успехе |
|
customerRouterIpAddress string |
IPv4-адрес и длина префикса, которые следует настроить в подинтерфейсе маршрутизатора клиента для этого подключения interconnect. Возвращается: при успехе |
|
description string |
Необязательное описание этого ресурса. Возвращается: при успехе |
|
edgeAvailabilityDomain string |
Желаемый домен доступности для подключения. Доступно только для типа PARTNER при создании. Для повышения надежности клиентам рекомендуется настроить пару подключений — по одному на каждый домен доступности. Выбранный домен доступности будет передан партнеру с помощью ключа сопряжения, чтобы предоставленный канал находился в указанном домене. Если значение не указано, по умолчанию используется AVAILABILITY_DOMAIN_ANY. Возвращается: при успехе |
|
encryption string |
Указывает заданный пользователем параметр шифрования этого подключения interconnect: NONE — значение по умолчанию, означающее, что подключение передает незашифрованный трафик. Виртуальные машины могут отправлять трафик через подключение этого типа и получать его оттуда. IPSEC означает, что подключение передает только трафик, зашифрованный устройством IPsec, например шлюзом HA VPN. Виртуальные машины не могут напрямую отправлять трафик через такое подключение или получать его оттуда. Чтобы использовать Cloud Interconnect с шифрованием IPsec, создайте подключение с этим параметром. В настоящее время публично недоступно. Возвращается: при успехе |
|
googleReferenceId string |
Идентификатор ссылки Google, используемый при создании запросов в службу поддержки Google или для отладки проблем с подключением к серверной части. Возвращается: при успехе |
|
id string |
Уникальный идентификатор ресурса. Этот идентификатор назначается сервером. Возвращается: при успехе |
|
interconnect string |
URL базового объекта Interconnect, через который будет проходить трафик этого подключения. Обязателен для типа DEDICATED и не должен задаваться для типа PARTNER. Возвращается: при успехе |
|
ipsecInternalAddresses list / элементы=string |
URL адресов, зарезервированных для подключения interconnect. Используется только для подключений interconnect с параметром шифрования IPSEC. Адреса должны находиться в диапазонах IP-адресов RFC 1918. При создании шлюза HA VPN поверх подключения interconnect, если подключение настроено для использования IP-адреса RFC 1918, IP-адрес шлюза VPN будет выделен из указанного здесь диапазона IP-адресов. Например, если интерфейс 0 шлюза HA VPN сопряжен с этим подключением interconnect, IP-адрес RFC 1918 для интерфейса 0 шлюза VPN будет выделен из IP-адреса, указанного для этого подключения interconnect. Если это поле не указано для подключения interconnect с параметром шифрования IPSEC, то при последующем создании шлюза HA VPN на этом подключении IP-адрес шлюза HA VPN будет выделен из регионального пула внешних IP-адресов. Возвращается: при успехе |
|
mtu string |
Максимальный размер передаваемого блока (MTU) в байтах для пакетов, проходящих через это подключение interconnect. В настоящее время разрешены только значения 1440 и 1500. Если значение не указано, по умолчанию используется 1440. Возвращается: при успехе |
|
name string |
Имя ресурса. Указывается клиентом при создании ресурса. Имя должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной латинской буквой, а все последующие символы, кроме последнего, — дефисом, строчной латинской буквой или цифрой. Последний символ не может быть дефисом. Возвращается: при успехе |
|
pairingKey string |
[Только для вывода для типа PARTNER. Для DEDICATED отсутствует.] Непрозрачный идентификатор подключения PARTNER, используемый для запуска подготовки у выбранного партнера. Имеет вид «XXXXX/region/domain». Возвращается: при успехе |
|
partnerAsn string |
[Только для вывода для типа PARTNER. Для DEDICATED отсутствует.] Необязательный номер ASN BGP маршрутизатора, который должен предоставить партнер уровня 3, если он настроил BGP от имени клиента. Возвращается: при успехе |
|
privateInterconnectInfo complex |
Информация, относящаяся к InterconnectAttachment. Это свойство заполняется, если подключение interconnect имеет тип DEDICATED. Возвращается: при успехе |
|
tag8021q integer |
Тег инкапсуляции 802.1q для трафика между Google и клиентом, поступающего в эту сеть и регион и выходящего из них. Возвращается: при успехе |
|
region string |
Регион, в котором находится региональное подключение interconnect. Возвращается: при успехе |
|
router dictionary |
URL облачного маршрутизатора, используемого для динамической маршрутизации. Этот маршрутизатор должен находиться в том же регионе, что и данный InterconnectAttachment. InterconnectAttachment автоматически подключит Interconnect к сети и региону, в которых настроен Cloud Router. Возвращается: при успехе |
|
state string |
[Только для вывода] Текущее состояние работы этого подключения. Возвращается: при успехе |
|
type string |
Тип InterconnectAttachment, который требуется создать. По умолчанию — DEDICATED. Возвращается: при успехе |
|
vlanTag8021q integer |
Тег VLAN IEEE 802.1Q для этого подключения в диапазоне 2–4094. Для типа PARTNER управляется на вышестоящем уровне. Возвращается: при успехе |
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/google/cloud/gcp_compute_interconnect_attachment_info_module.html