Модуль google.cloud.gcp_compute_interconnect_attachment — создает GCP InterconnectAttachment
Примечание
Этот модуль входит в коллекцию google.cloud (версия 1.13.0).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.
Для установки используйте: ansible-galaxy collection install google.cloud. Для использования этого модуля требуются дополнительные компоненты. Подробности см. в разделе Требования.
Чтобы использовать его в плейбуке, укажите: google.cloud.gcp_compute_interconnect_attachment.
Краткое описание
- Представляет ресурс InterconnectAttachment (подключение VLAN). Дополнительные сведения см. в разделе «Создание подключений VLAN».
Требования
На хосте, где выполняется этот модуль, необходимы следующие компоненты.
- python >= 2.6
- requests >= 2.18.4
- google-auth >= 1.3.0
Параметры
Параметр | Комментарии |
|---|---|
access_token string | Токен доступа OAuth2, если тип учетных данных — accesstoken. |
admin_enabled boolean | Включено или отключено подключение VLAN. При использовании типа PARTNER это приведет к предварительной активации подключения interconnect. Варианты:
|
auth_kind string / обязательно | Тип используемых учетных данных. Варианты:
|
bandwidth string | Выделенная пропускная способность подключения interconnect. Для подключений типа DEDICATED пользователь может задать пропускную способность. Для подключений типа PARTNER пропускную способность должен задать партнер Google, обслуживающий interconnect. Только для чтения для типа PARTNER; может изменяться для PARTNER_PROVIDER и DEDICATED. По умолчанию — BPS_10G. Допустимые значения: «BPS_50M», «BPS_100M», «BPS_200M», «BPS_300M», «BPS_400M», «BPS_500M», «BPS_1G», «BPS_2G», «BPS_5G», «BPS_10G», «BPS_20G», «BPS_50G» |
candidate_subnets list / элементы=string | До 16 префиксов-кандидатов, которые можно использовать для ограничения выделения cloudRouterIpAddress и customerRouterIpAddress для этого подключения. Все префиксы должны входить в пространство локальных адресов канала связи (169.254.0.0/16) и иметь длину /29 или меньше (/28, /27 и т. д.). Google попытается выбрать неиспользуемую подсеть /29 из предоставленных префиксов-кандидатов. Запрос завершится ошибкой, если все возможные подсети /29 уже используются на периферии Google. Если префиксы не указаны, Google случайным образом выберет неиспользуемую подсеть /29 из всего пространства локальных адресов канала связи. |
description string | Необязательное описание этого ресурса. |
edge_availability_domain string | Предпочтительный домен доступности для подключения. Доступен только для типа PARTNER и задается при создании. Для повышения надежности клиентам следует настроить пару подключений, по одному на каждый домен доступности. Выбранный домен доступности будет передан партнеру с помощью ключа сопряжения, чтобы подготовленный канал находился в указанном домене. Если значение не указано, по умолчанию используется AVAILABILITY_DOMAIN_ANY. |
encryption string | Указывает заданный пользователем вариант шифрования для этого подключения interconnect: NONE — значение по умолчанию, означающее, что подключение передает незашифрованный трафик. Виртуальные машины могут отправлять трафик через подключение этого типа и получать его. IPSEC означает, что подключение передает только трафик, зашифрованный устройством IPsec, например шлюзом HA VPN. Виртуальные машины не могут напрямую отправлять трафик через такое подключение и получать его. Чтобы использовать Cloud Interconnect с шифрованием IPsec, создайте подключение, выбрав этот параметр. В настоящее время публично недоступно. Допустимые значения: «NONE», «IPSEC» По умолчанию: |
env_type string | Указывает, в какой среде Ansible выполняется этот модуль. Не задавайте это значение, если не знаете, что делаете. Этот параметр изменяет только строку User Agent для запросов к API. |
interconnect string | URL базового объекта Interconnect, через который будет проходить трафик этого подключения. Обязателен, если тип — DEDICATED; не должен быть задан, если тип — PARTNER. |
ipsec_internal_addresses list / элементы=dictionary | URL адресов, зарезервированных для подключения interconnect. Используется только для подключений interconnect с параметром шифрования IPSEC. Адреса должны принадлежать диапазонам IP-адресов RFC 1918. При создании шлюза HA VPN поверх подключения interconnect, настроенного для использования IP-адреса RFC 1918, IP-адрес шлюза VPN будет выделен из указанного здесь диапазона IP-адресов. Например, если интерфейс 0 шлюза HA VPN сопряжен с этим подключением interconnect, IP-адрес RFC 1918 для интерфейса 0 шлюза VPN будет выделен из диапазона IP-адресов, указанного для этого подключения interconnect. Если это поле не задано для подключения interconnect с параметром шифрования IPSEC, то при последующем создании шлюза HA VPN на этом подключении IP-адрес шлюза HA VPN будет выделен из регионального пула внешних IP-адресов. |
mtu string | Максимальный размер передаваемого блока (MTU) в байтах для пакетов, проходящих через это подключение interconnect. Сейчас разрешены только значения 1440 и 1500. Если значение не указано, по умолчанию используется 1440. |
name string / обязательно | Имя ресурса. Указывается клиентом при создании ресурса. Длина имени должна составлять от 1 до 63 символов, а само имя должно соответствовать RFC1035. В частности, длина имени должна составлять от 1 до 63 символов, а имя должно соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, которым не может быть дефис. |
project string | Проект Google Cloud Platform, который следует использовать. |
region string / обязательно | Регион, в котором находится региональное подключение interconnect. |
router dictionary / обязательно | URL облачного маршрутизатора, который будет использоваться для динамической маршрутизации. Этот маршрутизатор должен находиться в том же регионе, что и InterconnectAttachment. InterconnectAttachment автоматически подключит Interconnect к сети и региону, в которых настроен Cloud Router. Это поле содержит ссылку на ресурс Router в GCP. Указать ее можно двумя способами. Во-первых, можно передать словарь с ключом ‘selfLink’ и значением selfLink ресурса. Также можно добавить `register: name-of-resource` в задачу gcp_compute_router, а затем задать для этого поля router значение “{{ name-of-resource }}”. |
scopes list / элементы=string | Массив используемых областей действия |
service_account_contents jsonarg | Содержимое JSON-файла учетной записи службы в виде словаря или JSON-строки, представляющей его. |
service_account_email string | Необязательный адрес электронной почты учетной записи службы, если выбран machineaccount и пользователь не хочет использовать адрес по умолчанию. |
service_account_file path | Путь к JSON-файлу учетной записи службы, если в качестве типа выбрано serviceaccount. |
state string | Должен ли указанный объект существовать в GCP Варианты:
|
type string | Тип InterconnectAttachment, который требуется создать. По умолчанию — DEDICATED. Допустимые значения: «DEDICATED», «PARTNER», «PARTNER_PROVIDER» |
vlan_tag8021q integer | Тег VLAN IEEE 802.1Q для этого подключения в диапазоне 2–4094. Для типа PARTNER им будет управлять вышестоящий узел. |
Примеры
- name: create a interconnect attachment
google.cloud.gcp_compute_interconnect_attachment:
name: test_object
region: us-central1
project: test_project
auth_kind: serviceaccount
interconnect: https://googleapis.com/compute/v1/projects/test_project/global/interconnects/...
router: https://googleapis.com/compute/v1/projects/test_project/regions/us-central1/routers/...
service_account_file: "/tmp/auth.pem"
state: present
register: disk
Возвращаемые значения
Общие возвращаемые значения описаны здесь, ниже перечислены поля, уникальные для этого модуля:
Ключ | Описание |
|---|---|
adminEnabled boolean | Включено или отключено подключение VLAN. При использовании типа PARTNER это активирует подключение interconnect до начала его использования. Возвращается: успешно |
bandwidth string | Выделенная пропускная способность подключения interconnect. Для подключений типа DEDICATED пользователь может задать пропускную способность. Для подключений типа PARTNER пропускную способность должен задать партнер Google, обслуживающий interconnect. Для типа PARTNER значение доступно только для чтения, для PARTNER_PROVIDER и DEDICATED его можно изменять. Значение по умолчанию — BPS_10G. Возвращается: успешно |
candidateSubnets list / elements=string | До 16 префиксов-кандидатов, которые можно использовать для ограничения выделения адресов cloudRouterIpAddress и customerRouterIpAddress для этого подключения. Все префиксы должны входить в пространство локальных адресов канала (169.254.0.0/16) и иметь длину /29 или меньше (/28, /27 и т. д.). Google попытается выбрать неиспользуемый префикс /29 из предоставленных префиксов-кандидатов. Запрос завершится ошибкой, если все возможные префиксы /29 используются на периферии сети Google. Если префиксы не указаны, Google случайным образом выберет неиспользуемый префикс /29 из всего пространства локальных адресов канала. Возвращается: успешно |
cloudRouterIpAddress string | Адрес IPv4 и длина префикса, которые будут настроены в интерфейсе Cloud Router для этого подключения interconnect. Возвращается: успешно |
creationTimestamp string | Время создания в текстовом формате RFC3339. Возвращается: успешно |
customerRouterIpAddress string | Адрес IPv4 и длина префикса, которые будут настроены в подинтерфейсе маршрутизатора клиента для этого подключения interconnect. Возвращается: успешно |
description string | Необязательное описание этого ресурса. Возвращается: успешно |
edgeAvailabilityDomain string | Требуемый домен доступности для подключения. Доступно только для типа PARTNER и только во время создания. Для повышения надежности клиентам следует настроить пару подключений, по одному для каждого домена доступности. Выбранный домен доступности будет передан партнеру с помощью ключа сопряжения, чтобы подготовленный канал находился в указанном домене. Если значение не указано, по умолчанию используется AVAILABILITY_DOMAIN_ANY. Возвращается: успешно |
encryption string | Указывает выбранный пользователем параметр шифрования этого подключения interconnect: NONE — значение по умолчанию, означающее, что подключение передает незашифрованный трафик. Виртуальные машины могут отправлять трафик через подключение этого типа и получать его от него. IPSEC означает, что подключение передает только трафик, зашифрованный устройством IPsec, например шлюзом HA VPN. Виртуальные машины не могут напрямую отправлять трафик через такое подключение или получать его от него. Чтобы использовать Cloud Interconnect с шифрованием IPsec, создайте подключение с этим параметром. В настоящее время публично недоступно. Возвращается: успешно |
googleReferenceId string | Идентификатор ссылки Google, используемый при создании запросов в службу поддержки Google, а также для диагностики проблем с подключением к серверной части. Возвращается: успешно |
id string | Уникальный идентификатор ресурса. Этот идентификатор задается сервером. Возвращается: успешно |
interconnect string | URL базового объекта Interconnect, через который будет проходить трафик этого подключения. Обязателен, если тип — DEDICATED; не должен быть указан, если тип — PARTNER. Возвращается: успешно |
ipsecInternalAddresses list / elements=string | URL адресов, зарезервированных для подключения interconnect. Используется только для подключений interconnect с параметром шифрования IPSEC. Адреса должны принадлежать диапазонам IP-адресов RFC 1918. При создании шлюза HA VPN через подключение interconnect, если подключение настроено на использование IP-адреса RFC 1918, IP-адрес шлюза VPN будет выделен из указанного здесь диапазона IP-адресов. Например, если интерфейс 0 шлюза HA VPN соединен с этим подключением interconnect, IP-адрес RFC 1918 для интерфейса 0 шлюза VPN будет выделен из IP-адреса, указанного для этого подключения interconnect. Если это поле не указано для подключения interconnect с параметром шифрования IPSEC, то при последующем создании шлюза HA VPN на этом подключении IP-адрес шлюза HA VPN будет выделен из регионального пула внешних IP-адресов. Возвращается: успешно |
mtu string | Максимальный размер блока передачи (MTU) в байтах для пакетов, проходящих через это подключение interconnect. В настоящее время допускаются только значения 1440 и 1500. Если значение не указано, по умолчанию используется 1440. Возвращается: успешно |
name string | Имя ресурса. Задается клиентом при создании ресурса. Имя должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом. Возвращается: успешно |
pairingKey string | [Только для чтения для типа PARTNER. Отсутствует для DEDICATED]. Непрозрачный идентификатор подключения PARTNER, используемый для начала подготовки у выбранного партнера. Имеет формат «XXXXX/region/domain». Возвращается: успешно |
partnerAsn string | [Только для чтения для типа PARTNER. Отсутствует для DEDICATED]. Необязательный номер ASN BGP маршрутизатора, который должен предоставить партнер уровня 3, если он настроил BGP от имени клиента. Возвращается: успешно |
privateInterconnectInfo complex | Информация, относящаяся к InterconnectAttachment. Это свойство заполняется, если тип interconnect, к которому выполнено подключение, — DEDICATED. Возвращается: успешно |
|
tag8021q integer |
Тег инкапсуляции 802.1q, используемый для трафика между Google и клиентом, проходящего в эту сеть и регион и обратно. Возвращается: успешно |
region string | Регион, в котором находится региональное подключение interconnect. Возвращается: успешно |
router dictionary | URL облачного маршрутизатора, используемого для динамической маршрутизации. Этот маршрутизатор должен находиться в том же регионе, что и InterconnectAttachment. InterconnectAttachment автоматически подключит Interconnect к сети и региону, в которых настроен Cloud Router. Возвращается: успешно |
state string | [Только для чтения] Текущее состояние работы этого подключения. Возвращается: успешно |
type string | Тип создаваемого InterconnectAttachment. По умолчанию используется DEDICATED. Возвращается: успешно |
vlanTag8021q integer | Тег VLAN IEEE 802.1Q для этого подключения в диапазоне 2–4094. При использовании типа PARTNER он будет управляться на вышестоящем уровне. Возвращается: успешно |
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/google/cloud/gcp_compute_interconnect_attachment_module.html