Модуль google.cloud.gcp_compute_region_disk_info — сбор информации о GCP RegionDisk
Примечание
Этот модуль входит в коллекцию google.cloud (версия 1.13.0).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.
Для установки используйте: ansible-galaxy collection install google.cloud. Для работы с этим модулем требуются дополнительные компоненты; подробную информацию см. в разделе Требования.
Чтобы использовать модуль в плейбуке, укажите: google.cloud.gcp_compute_region_disk_info.
Краткое описание
- Сбор информации о GCP RegionDisk
Требования
На хосте, выполняющем этот модуль, должны быть установлены перечисленные ниже компоненты.
- python >= 2.6
- requests >= 2.18.4
- google-auth >= 1.3.0
Параметры
Параметр | Комментарии |
|---|---|
access_token string | Токен доступа OAuth2, если тип учетных данных — accesstoken. |
auth_kind string / обязательный | Тип используемых учетных данных. Варианты:
|
env_type string | Указывает, в какой среде Ansible выполняется этот модуль. Задавайте этот параметр, только если знаете, что делаете. Он изменяет только строку User Agent для запросов к API. |
filters list / элементы=string | Список пар значений фильтров. Доступные фильтры перечислены здесь: https://cloud.google.com/sdk/gcloud/reference/topic/filters. Каждый дополнительный фильтр в списке добавляется как условие AND (filter1 и filter2). |
project string | Проект Google Cloud Platform, который следует использовать. |
region string / обязательный | Ссылка на регион, в котором находится диск. |
scopes list / элементы=string | Массив используемых областей доступа |
service_account_contents jsonarg | Содержимое JSON-файла учетной записи службы в виде словаря или JSON-строки, представляющей это содержимое. |
service_account_email string | Необязательный адрес электронной почты учетной записи службы, если выбран machineaccount и пользователь не хочет использовать адрес по умолчанию. |
service_account_file path | Путь к JSON-файлу учетной записи службы, если в качестве типа выбрано serviceaccount. |
Примечания
Примечание
- Для аутентификации можно задать service_account_file с помощью переменной среды
GCP_SERVICE_ACCOUNT_FILE. - Для аутентификации можно задать service_account_contents с помощью переменной среды
GCP_SERVICE_ACCOUNT_CONTENTS. - Для аутентификации можно задать service_account_email с помощью переменной среды
GCP_SERVICE_ACCOUNT_EMAIL. - Для аутентификации можно задать access_token с помощью переменной среды
GCP_ACCESS_TOKEN. - Для аутентификации можно задать auth_kind с помощью переменной среды
GCP_AUTH_KIND. - Для аутентификации можно задать scopes с помощью переменной среды
GCP_SCOPES. - Значения переменных среды используются, только если значения не заданы в плейбуке.
- Параметры service_account_email и service_account_file являются взаимоисключающими.
Примеры
- name: get info on a region disk
gcp_compute_region_disk_info:
region: us-central1
filters:
- name = test_object
project: test_project
auth_kind: serviceaccount
service_account_file: "/tmp/auth.pem"
Возвращаемые значения
Общие возвращаемые значения описаны здесь; ниже перечислены поля, уникальные для этого модуля:
Ключ | Описание |
|---|---|
resources complex | Список ресурсов Возвращается: всегда |
|
creationTimestamp string |
Временная метка создания в текстовом формате RFC3339. Возвращается: при успехе |
|
description string |
Необязательное описание этого ресурса. Укажите это свойство при создании ресурса. Возвращается: при успехе |
|
diskEncryptionKey complex |
Шифрует диск с помощью ключа шифрования, предоставленного клиентом. После шифрования диска с помощью ключа, предоставленного клиентом, при последующем использовании диска необходимо указывать тот же ключ (например, для создания снимка диска или образа либо подключения диска к виртуальной машине). Ключи шифрования, предоставленные клиентом, не защищают доступ к метаданным диска. Если при создании диска ключ шифрования не указан, диск будет зашифрован с помощью автоматически созданного ключа. Для последующего использования диска указывать ключ не потребуется. Возвращается: при успехе |
|
rawKey string |
Задает предоставленный клиентом 256-битный ключ шифрования, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса. Возвращается: при успехе |
|
sha256 string |
Хеш SHA-256 ключа шифрования, предоставленного клиентом и защищающего этот ресурс, закодированный в base64 согласно RFC 4648. Возвращается: при успехе |
|
id integer |
Уникальный идентификатор ресурса. Возвращается: при успехе |
|
labelFingerprint string |
Отпечаток, используемый для оптимистической блокировки этого ресурса. Используется внутренними механизмами при обновлении. Возвращается: при успехе |
|
labels dictionary |
Метки, применяемые к этому диску. Список пар ключ->значение. Возвращается: при успехе |
|
lastAttachTimestamp string |
Временная метка последнего подключения в текстовом формате RFC3339. Возвращается: при успехе |
|
lastDetachTimestamp string |
Временная метка последнего отключения в текстовом формате RFC3339. Возвращается: при успехе |
|
licenses list / элементы=string |
Все применимые общедоступные лицензии. Возвращается: при успехе |
|
name string |
Имя ресурса. Указывается клиентом при создании ресурса. Имя должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом. Возвращается: при успехе |
|
physicalBlockSizeBytes integer |
Размер физического блока постоянного диска в байтах. Если в запросе это значение не указано, используется значение по умолчанию. В настоящее время поддерживаются размеры 4096 и 16384; в будущем могут быть добавлены другие размеры. Если запрошено неподдерживаемое значение, в сообщении об ошибке будут перечислены значения, поддерживаемые для проекта вызывающей стороны. Возвращается: при успехе |
|
region string |
Ссылка на регион, в котором находится диск. Возвращается: при успехе |
|
replicaZones list / элементы=string |
URL зон, в которые следует реплицировать диск. Возвращается: при успехе |
|
sizeGb integer |
Размер постоянного диска в ГБ. Это поле можно указать при создании постоянного диска с помощью параметра sourceImage или sourceSnapshot либо указать отдельно, чтобы создать пустой постоянный диск. Если это поле указано вместе с sourceImage или sourceSnapshot, значение sizeGb должно быть не меньше размера sourceImage или снимка. Возвращается: при успехе |
|
sourceSnapshot dictionary |
Исходный снимок, использованный для создания этого диска. В качестве значения можно указать частичный или полный URL ресурса. Возвращается: при успехе |
|
sourceSnapshotEncryptionKey complex |
Ключ шифрования исходного снимка, предоставленный клиентом. Обязателен, если исходный снимок защищен ключом шифрования, предоставленным клиентом. Возвращается: при успехе |
|
rawKey string |
Задает предоставленный клиентом 256-битный ключ шифрования, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса. Возвращается: при успехе |
|
sha256 string |
Хеш SHA-256 ключа шифрования, предоставленного клиентом и защищающего этот ресурс, закодированный в base64 согласно RFC 4648. Возвращается: при успехе |
|
sourceSnapshotId string |
Уникальный идентификатор снимка, использованного для создания этого диска. Это значение указывает на конкретный снимок, использованный для создания постоянного диска. Например, если постоянный диск был создан из снимка, который впоследствии удалили, а затем создали заново с тем же именем, идентификатор исходного снимка укажет на конкретную версию использованного снимка. Возвращается: при успехе |
|
type string |
URL ресурса типа диска, описывающего тип диска, который следует использовать при создании диска. Укажите это значение при создании диска. Возвращается: при успехе |
|
users list / элементы=string |
Ссылки на пользователей диска (подключенные экземпляры) в формате: project/zones/zone/instances/instance . Возвращается: при успехе |
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/google/cloud/gcp_compute_region_disk_info_module.html