Spec-Zone.ru › Ansible

Модуль google.cloud.gcp_compute_region_disk – создание RegionDisk в GCP

Примечание

Этот модуль входит в коллекцию google.cloud (версия 1.13.0).

Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.

Для установки используйте: ansible-galaxy collection install google.cloud. Для использования этого модуля требуются дополнительные компоненты. Подробнее см. в разделе Требования.

Чтобы использовать модуль в сценарии, укажите: google.cloud.gcp_compute_region_disk.

  • Краткое описание
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Краткое описание

  • Постоянные диски — это надежные устройства хранения данных, работающие аналогично физическим дискам в настольном компьютере или на сервере. Compute Engine управляет аппаратным обеспечением этих устройств, обеспечивая резервирование данных и оптимизируя производительность. Постоянные диски доступны в виде стандартных жестких дисков (HDD) или твердотельных накопителей (SSD).
  • Постоянные диски расположены отдельно от экземпляров виртуальных машин, поэтому их можно отсоединить или переместить, чтобы сохранить данные даже после удаления экземпляров. Производительность постоянного диска автоматически масштабируется с увеличением его размера. Поэтому можно изменить размер существующих постоянных дисков или добавить к экземпляру новые, чтобы удовлетворить требования к производительности и объему хранилища.
  • Добавьте постоянный диск к экземпляру, если вам требуется надежное и доступное хранилище со стабильными характеристиками производительности.

Требования

На хосте, выполняющем этот модуль, должны быть установлены следующие компоненты.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр

Комментарии

access_token

string

Токен доступа OAuth2, если тип учетных данных — accesstoken.

auth_kind

string / обязательный

Тип используемых учетных данных.

Варианты:

  • "application"
  • "machineaccount"
  • "serviceaccount"
  • "accesstoken"

description

string

Необязательное описание этого ресурса. Укажите это свойство при создании ресурса.

disk_encryption_key

dictionary

Шифрует диск с помощью предоставленного пользователем ключа шифрования.

После шифрования диска с помощью предоставленного пользователем ключа необходимо будет указывать тот же ключ при последующем использовании диска (например, для создания снимка диска или образа либо для подключения диска к виртуальной машине).

Ключи шифрования, предоставленные пользователем, не защищают доступ к метаданным диска.

Если при создании диска не указать ключ шифрования, диск будет зашифрован автоматически сгенерированным ключом, и для последующего использования диска указывать ключ не потребуется.

raw_key

string

Задает предоставленный пользователем ключ шифрования длиной 256 бит, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса.

env_type

string

Указывает, в какой среде Ansible выполняется этот модуль.

Не задавайте этот параметр, если не знаете, что делаете.

Этот параметр изменяет только строку User Agent для всех запросов API.

labels

dictionary

Метки, применяемые к этому диску. Список пар ключ->значение.

licenses

list / elements=string

Все применимые общедоступные лицензии.

name

string / обязательный

Имя ресурса. Указывается клиентом при создании ресурса. Имя должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, которым не может быть дефис.

physical_block_size_bytes

integer

Размер физического блока постоянного диска в байтах. Если в запросе это значение не указано, используется значение по умолчанию. В настоящее время поддерживаются размеры 4096 и 16384; в будущем могут быть добавлены другие значения.

Если запрошено неподдерживаемое значение, в сообщении об ошибке будут перечислены значения, поддерживаемые для проекта вызывающей стороны.

project

string

Проект Google Cloud Platform, который следует использовать.

region

string / обязательный

Ссылка на регион, в котором находится диск.

replica_zones

list / elements=string / обязательный

URL зон, в которые следует реплицировать диск.

scopes

list / elements=string

Массив используемых областей действия

service_account_contents

jsonarg

Содержимое JSON-файла сервисного аккаунта в виде словаря или JSON-строки, представляющей его.

service_account_email

string

Необязательный адрес электронной почты сервисного аккаунта, если выбран параметр machineaccount и пользователь не хочет использовать адрес по умолчанию.

service_account_file

path

Путь к JSON-файлу сервисного аккаунта, если в качестве типа выбран serviceaccount.

size_gb

integer

Размер постоянного диска в ГБ. Это поле можно указать при создании постоянного диска с помощью параметра sourceImage или sourceSnapshot либо указать отдельно, чтобы создать пустой постоянный диск.

Если указать это поле вместе с sourceImage или sourceSnapshot, значение sizeGb не должно быть меньше размера sourceImage или снимка.

source_snapshot

dictionary

Исходный снимок, используемый для создания этого диска. Можно указать частичный или полный URL ресурса.

Это поле представляет ссылку на ресурс Snapshot в GCP. Его можно задать двумя способами. Во-первых, можно указать словарь с ключом ‘selfLink’ и значением selfLink ресурса. Во-вторых, можно добавить `register: name-of-resource` в задачу gcp_compute_snapshot, а затем присвоить этому полю source_snapshot значение “{{ name-of-resource }}”

source_snapshot_encryption_key

dictionary

Предоставленный пользователем ключ шифрования исходного снимка. Обязателен, если исходный снимок защищен ключом шифрования, предоставленным пользователем.

raw_key

string

Задает предоставленный пользователем ключ шифрования длиной 256 бит, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса.

state

string

Должен ли указанный объект существовать в GCP

Варианты:

  • "present" ← (по умолчанию)
  • "absent"

type

string

URL ресурса типа диска, указывающий, какой тип диска следует использовать для его создания. Укажите это значение при создании диска.

Примечания

Примечание

  • Справочник API: https://cloud.google.com/compute/docs/reference/rest/v1/regionDisks
  • Добавление региональных постоянных дисков и изменение их размера: https://cloud.google.com/compute/docs/disks/regional-persistent-disk
  • Для аутентификации можно задать service_account_file с помощью переменной среды GCP_SERVICE_ACCOUNT_FILE.
  • Для аутентификации можно задать service_account_contents с помощью переменной среды GCP_SERVICE_ACCOUNT_CONTENTS.
  • Для аутентификации можно задать service_account_email с помощью переменной среды GCP_SERVICE_ACCOUNT_EMAIL.
  • Для аутентификации можно задать access_token с помощью переменной среды GCP_ACCESS_TOKEN.
  • Для аутентификации можно задать auth_kind с помощью переменной среды GCP_AUTH_KIND.
  • Для аутентификации можно задать scopes с помощью переменной среды GCP_SCOPES.
  • Значения переменных среды используются, только если значения не заданы в сценарии.
  • Параметры service_account_email и service_account_file являются взаимоисключающими.

Примеры

- name: create a region disk
  google.cloud.gcp_compute_region_disk:
    name: test_object
    size_gb: 500
    disk_encryption_key:
      raw_key: SGVsbG8gZnJvbSBHb29nbGUgQ2xvdWQgUGxhdGZvcm0=
    region: us-central1
    replica_zones:
    - https://www.googleapis.com/compute/v1/projects/google.com:graphite-playground/zones/us-central1-a
    - https://www.googleapis.com/compute/v1/projects/google.com:graphite-playground/zones/us-central1-b
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"
    state: present

Возвращаемые значения

Общие возвращаемые значения описаны здесь; ниже перечислены поля, уникальные для этого модуля:

Ключ

Описание

creationTimestamp

string

Временная метка создания в текстовом формате RFC3339.

Возвращается: при успешном выполнении

description

string

Необязательное описание этого ресурса. Укажите это свойство при создании ресурса.

Возвращается: при успешном выполнении

diskEncryptionKey

complex

Шифрует диск с помощью предоставленного клиентом ключа шифрования.

После шифрования диска с помощью предоставленного клиентом ключа необходимо будет указывать тот же ключ при последующем использовании диска (например, для создания снимка диска или образа либо для подключения диска к виртуальной машине).

Ключи шифрования, предоставленные клиентом, не защищают доступ к метаданным диска.

Если при создании диска ключ шифрования не указан, диск будет зашифрован автоматически сгенерированным ключом, и для последующего использования диска указывать ключ не потребуется.

Возвращается: при успешном выполнении

rawKey

string

Указывает предоставленный клиентом ключ шифрования длиной 256 бит, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса.

Возвращается: при успешном выполнении

sha256

string

Хэш SHA-256 предоставленного клиентом ключа шифрования, защищающего этот ресурс, закодированный в base64 согласно RFC 4648.

Возвращается: при успешном выполнении

id

integer

Уникальный идентификатор ресурса.

Возвращается: при успешном выполнении

labelFingerprint

string

Отпечаток, используемый для оптимистической блокировки этого ресурса. Используется внутри системы при обновлении.

Возвращается: при успешном выполнении

labels

dictionary

Метки, применяемые к этому диску. Список пар ключ->значение.

Возвращается: при успешном выполнении

lastAttachTimestamp

string

Временная метка последнего подключения в текстовом формате RFC3339.

Возвращается: при успешном выполнении

lastDetachTimestamp

string

Временная метка последнего отключения в текстовом формате RFC3339.

Возвращается: при успешном выполнении

licenses

list / elements=string

Все применимые общедоступные лицензии.

Возвращается: при успешном выполнении

name

string

Имя ресурса. Указывается клиентом при создании ресурса. Имя должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, кроме последнего символа, которым не может быть дефис.

Возвращается: при успешном выполнении

physicalBlockSizeBytes

integer

Размер физического блока постоянного диска в байтах. Если в запросе не указан, используется значение по умолчанию. В настоящее время поддерживаются размеры 4096 и 16384; в будущем могут быть добавлены другие размеры.

Если запрошено неподдерживаемое значение, в сообщении об ошибке будут перечислены значения, поддерживаемые для проекта вызывающей стороны.

Возвращается: при успешном выполнении

region

string

Ссылка на регион, в котором находится диск.

Возвращается: при успешном выполнении

replicaZones

list / elements=string

URL-адреса зон, в которые следует реплицировать диск.

Возвращается: при успешном выполнении

sizeGb

integer

Размер постоянного диска в ГБ. Это поле можно указать при создании постоянного диска с помощью параметра sourceImage или sourceSnapshot либо указать отдельно для создания пустого постоянного диска.

Если это поле указано вместе с sourceImage или sourceSnapshot, значение sizeGb не должно быть меньше размера sourceImage или снимка.

Возвращается: при успешном выполнении

sourceSnapshot

dictionary

Исходный снимок, использованный для создания этого диска. Его можно указать в виде частичного или полного URL-адреса ресурса.

Возвращается: при успешном выполнении

sourceSnapshotEncryptionKey

complex

Ключ шифрования исходного снимка, предоставленный клиентом. Обязателен, если исходный снимок защищен ключом шифрования, предоставленным клиентом.

Возвращается: при успешном выполнении

rawKey

string

Указывает предоставленный клиентом ключ шифрования длиной 256 бит, закодированный в base64 согласно RFC 4648, для шифрования или расшифровки этого ресурса.

Возвращается: при успешном выполнении

sha256

string

Хэш SHA-256 предоставленного клиентом ключа шифрования, защищающего этот ресурс, закодированный в base64 согласно RFC 4648.

Возвращается: при успешном выполнении

sourceSnapshotId

string

Уникальный идентификатор снимка, использованного для создания этого диска. Это значение указывает на конкретный снимок, из которого был создан этот постоянный диск. Например, если постоянный диск был создан из снимка, который впоследствии удалили и создали заново под тем же именем, идентификатор исходного снимка укажет на конкретную версию использованного снимка.

Возвращается: при успешном выполнении

type

string

URL-адрес ресурса типа диска, описывающего тип диска, который следует использовать при его создании. Укажите это значение при создании диска.

Возвращается: при успешном выполнении

users

list / elements=string

Ссылки на пользователей диска (подключенные экземпляры) в формате: project/zones/zone/instances/instance .

Возвращается: при успешном выполнении

Авторы

  • Google Inc. (@googlecloudplatform)

Ссылки на коллекцию

  • Отслеживание проблем
  • Домашняя страница
  • Репозиторий (исходный код)

© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/google/cloud/gcp_compute_region_disk_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API