Модуль google.cloud.gcp_compute_snapshot_info — сбор информации о снимке GCP
Примечание
Этот модуль входит в коллекцию google.cloud (версия 1.13.0).
Возможно, эта коллекция уже установлена, если вы используете пакет ansible. Она не входит в ansible-core. Чтобы проверить, установлена ли она, выполните команду ansible-galaxy collection list.
Для установки используйте: ansible-galaxy collection install google.cloud. Для работы с этим модулем необходимы дополнительные компоненты; подробную информацию см. в разделе Требования.
Чтобы использовать модуль в плейбуке, укажите: google.cloud.gcp_compute_snapshot_info.
Краткое описание
- Сбор информации о снимке GCP
Требования
На узле, выполняющем этот модуль, должны быть установлены следующие компоненты.
- python >= 2.6
- requests >= 2.18.4
- google-auth >= 1.3.0
Параметры
Параметр | Комментарии |
|---|---|
access_token string | Токен доступа OAuth2, если тип учетных данных — accesstoken. |
auth_kind string / обязательный | Тип используемых учетных данных. Допустимые значения:
|
env_type string | Указывает, в какой среде Ansible выполняется этот модуль. Не задавайте этот параметр, если не знаете, что делаете. Он изменяет только строку User Agent для запросов к API. |
filters list / элементы=string | Список пар значений фильтров. Список доступных фильтров приведен здесь: https://cloud.google.com/sdk/gcloud/reference/topic/filters. Каждый дополнительный фильтр в списке будет добавлен как условие AND (filter1 и filter2). |
project string | Проект Google Cloud Platform, который следует использовать. |
scopes list / элементы=string | Массив используемых областей доступа |
service_account_contents jsonarg | Содержимое JSON-файла учетной записи службы в виде словаря или строки JSON, представляющей это содержимое. |
service_account_email string | Необязательный адрес электронной почты учетной записи службы. Используется, если выбрано machineaccount, а пользователь не хочет использовать адрес по умолчанию. |
service_account_file path | Путь к JSON-файлу учетной записи службы, если в качестве типа выбрано serviceaccount. |
Примечания
Примечание
- для аутентификации можно задать service_account_file с помощью переменной окружения
GCP_SERVICE_ACCOUNT_FILE. - для аутентификации можно задать service_account_contents с помощью переменной окружения
GCP_SERVICE_ACCOUNT_CONTENTS. - Для аутентификации можно задать service_account_email с помощью переменной окружения
GCP_SERVICE_ACCOUNT_EMAIL. - Для аутентификации можно задать access_token с помощью переменной окружения
GCP_ACCESS_TOKEN. - Для аутентификации можно задать auth_kind с помощью переменной окружения
GCP_AUTH_KIND. - Для аутентификации можно задать scopes с помощью переменной окружения
GCP_SCOPES. - Значения переменных окружения используются только в том случае, если значения в плейбуке не заданы.
- Параметры service_account_email и service_account_file являются взаимоисключающими.
Примеры
- name: get info on a snapshot
gcp_compute_snapshot_info:
filters:
- name = test_object
project: test_project
auth_kind: serviceaccount
service_account_file: "/tmp/auth.pem"
Возвращаемые значения
Общие возвращаемые значения описаны здесь; ниже перечислены поля, уникальные для этого модуля:
Ключ | Описание |
|---|---|
resources complex | Список ресурсов Возвращается: всегда |
|
creationTimestamp string |
Время создания в текстовом формате RFC3339. Возвращается: при успешном выполнении |
|
description string |
Необязательное описание этого ресурса. Возвращается: при успешном выполнении |
|
diskSizeGb integer |
Размер снимка в ГБ. Возвращается: при успешном выполнении |
|
id integer |
Уникальный идентификатор ресурса. Возвращается: при успешном выполнении |
|
labelFingerprint string |
Отпечаток, используемый для оптимистической блокировки этого ресурса. Используется внутри системы при обновлении. Возвращается: при успешном выполнении |
|
labels dictionary |
Метки, применяемые к этому снимку. Возвращается: при успешном выполнении |
|
licenses list / элементы=string |
Список общедоступных лицензий, применимых к этому снимку. Они могут быть указаны, например, если исходный образ имеет прикрепленные лицензии (например, образ Windows). Вложенный объект snapshotEncryptionKey шифрует снимок с помощью ключа шифрования, предоставленного пользователем. Возвращается: при успешном выполнении |
|
name string |
Имя ресурса, задаваемое клиентом при создании ресурса. Имя должно содержать от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно содержать от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`: первый символ должен быть строчной буквой, а все последующие символы, кроме последнего, — дефисом, строчной буквой или цифрой; последний символ не может быть дефисом. Возвращается: при успешном выполнении |
|
snapshotEncryptionKey complex |
Ключ шифрования снимка, предоставленный пользователем. Обязателен, если исходный снимок защищен ключом шифрования, предоставленным пользователем. Возвращается: при успешном выполнении |
|
kmsKeyName string |
Имя ключа шифрования, хранящегося в Google Cloud KMS. Возвращается: при успешном выполнении |
|
kmsKeyServiceAccount string |
Учетная запись службы, используемая для запроса шифрования указанным ключом KMS. Если значение не задано, используется учетная запись службы агента службы Compute Engine. Возвращается: при успешном выполнении |
|
rawKey string |
256-битный ключ шифрования, предоставленный пользователем и закодированный в base64 по RFC 4648 для шифрования или расшифрования этого ресурса. Возвращается: при успешном выполнении |
|
sha256 string |
Хеш SHA-256 ключа шифрования, предоставленного пользователем и защищающего этот ресурс, закодированный в base64 по RFC 4648. Возвращается: при успешном выполнении |
|
sourceDisk dictionary |
Ссылка на диск, использованный для создания этого снимка. Возвращается: при успешном выполнении |
|
sourceDiskEncryptionKey complex |
Ключ шифрования исходного снимка, предоставленный пользователем. Обязателен, если исходный снимок защищен ключом шифрования, предоставленным пользователем. Возвращается: при успешном выполнении |
|
kmsKeyName string |
Имя ключа шифрования, хранящегося в Google Cloud KMS. Возвращается: при успешном выполнении |
|
kmsKeyServiceAccount string |
Учетная запись службы, используемая для запроса шифрования указанным ключом KMS. Если значение не задано, используется учетная запись службы агента службы Compute Engine. Возвращается: при успешном выполнении |
|
rawKey string |
256-битный ключ шифрования, предоставленный пользователем и закодированный в base64 по RFC 4648 для шифрования или расшифрования этого ресурса. Возвращается: при успешном выполнении |
|
storageBytes integer |
Объем хранилища, используемого снимком. Поскольку снимки используют общее хранилище, ожидается, что это значение будет меняться при создании или удалении снимков. Возвращается: при успешном выполнении |
|
storageLocations list / элементы=string |
Местоположение хранилища снимка в Cloud Storage (региональное или мульти-региональное). Возвращается: при успешном выполнении |
|
zone string |
Ссылка на зону, в которой размещен диск. Возвращается: при успешном выполнении |
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2025 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/projects/ansible/latest/collections/google/cloud/gcp_compute_snapshot_info_module.html