netapp.ontap.na_ontap_volume_autosize модуль – NetApp ONTAP управление авторазмером томов
Примечание
Этот модуль является частью коллекции netapp.ontap (версия 22.12.0).
У вас, возможно, уже установлена эта коллекция, если вы используете пакет ansible. Она не включена в ansible-core. Чтобы проверить установку, выполните ansible-galaxy collection list.
Для установки используйте: ansible-galaxy collection install netapp.ontap. Для использования этого модуля необходимы дополнительные требования, см. Требования для получения подробностей.
Для использования в плейбуке укажите: netapp.ontap.na_ontap_volume_autosize.
Новое в netapp.ontap 2.9.0
Обзор
- Изменение авторазмера тома
Требования
Ниже перечислены требования, необходимые на хосте, на котором выполняется этот модуль.
- Ansible 2.9 или более поздняя версия - рекомендуется версия 2.12 или более поздняя.
- Python3 - рекомендуется версия 3.9 или более поздняя.
- При использовании ZAPI, netapp-lib 2018.11.13 или более поздняя версия (установить с помощью «pip install netapp-lib»), сильно рекомендуется netapp-lib 2020.3.12, так как она предоставляет лучшие сообщения об ошибках для проблем с подключением
- физическая или виртуальная кластерная система Data ONTAP, модули поддерживают Data ONTAP 9.1 и выше, поддержка REST требует ONTAP 9.6 или более поздней версии
Параметры
Параметр | Комментарии |
|---|---|
cert_filepath string добавлено в netapp.ontap 20.6.0 | путь к файлу сертификата клиента SSL (.pem). не поддерживается с python 2.6. |
feature_flags dictionary добавлено в netapp.ontap 20.5.0 | Включить или отключить новую функцию. Это может быть использовано для включения экспериментальной функции или отключения новой функции, которая нарушает обратную совместимость. Поддерживаемые ключи и значения могут быть изменены без уведомления. Неизвестные ключи игнорируются. |
force_ontap_version string добавлено в netapp.ontap 21.23.0 | Переопределить версию кластера ONTAP при использовании REST. Поведение не определено, если версия не соответствует целевому кластеру. Это предоставлено в качестве временного решения, когда версия кластера не может быть прочитана из-за проблем с разрешениями. Смотрите https://github.com/ansible-collections/netapp.ontap/wiki/Known-issues. Это должно быть в формате 9.10 или 9.10.1, где каждый элемент является целым числом. Когда Игнорируется с ZAPI. |
grow_threshold_percent integer | Указывает процент емкости гибкого тома, при котором инициируется автоматическое увеличение. Пороговое значение по умолчанию варьируется от 85% до 98% в зависимости от размера тома. Это ошибка, если пороговое значение увеличения меньше или равно пороговому значению уменьшения. Диапазон от 0 до 100 |
hostname string / required | Имя хоста или IP-адрес экземпляра ONTAP. |
http_port integer | Переопределить порт по умолчанию (80 или 443) этим портом |
https boolean | Включить и отключить https. Игнорируется при использовании REST, так как поддерживается только https. Игнорируется при использовании проверки подлинности сертификата SSL, так как она требует SSL. Варианты:
|
increment_size string | Укажите размер увеличения гибкого тома, используя следующий формат < число > [k|m|g|t] Количество - это абсолютный размер для установки. Конечные 'k', 'm', 'g' и 't' указывают желаемые единицы измерения, а именно 'килобайты', 'мегабайты', 'гигабайты' и 'терабайты' (соответственно). |
key_filepath string добавлено в netapp.ontap 20.6.0 | путь к файлу ключа клиента SSL. |
maximum_size string | Укажите максимально допустимый размер гибкого тома, используя следующий формат < число > [k|m|g|t] Количество - это абсолютный размер для установки. Конечные 'k', 'm', 'g' и 't' указывают желаемые единицы измерения, а именно 'килобайты', 'мегабайты', 'гигабайты' и 'терабайты' (соответственно). Значение по умолчанию на 20% больше размера тома на момент включения автомасштабирования. Это ошибка, если максимальный размер тома меньше текущего размера тома. Это также ошибка, если максимальный размер меньше или равен минимальному размеру. |
minimum_size string | Укажите минимально допустимый размер гибкого тома, используя следующий формат < число > [k|m|g|t] Количество - это абсолютный размер для установки. Конечные 'k', 'm', 'g' и 't' указывают желаемые единицы измерения, а именно 'килобайты', 'мегабайты', 'гигабайты' и 'терабайты' (соответственно). Значение по умолчанию - размер тома на момент включения режима 'grow_shrink'. Это ошибка, если минимальный размер больше или равен максимальному размеру. |
mode string | Укажите режим работы автомасштабирования гибкого тома. Варианты:
|
ontapi integer | Используемая версия API ontap |
password псевдонимы: pass string | Пароль для указанного пользователя. |
reset boolean | Устанавливает значения maximum_size, increment_size, minimum_size, grow_threshold_percent, shrink_threshold_percent и mode по умолчанию Если параметр reset присутствует, система всегда будет выполнять действие сброса, поэтому идемпотентность не поддерживается. Варианты:
|
shrink_threshold_percent integer | Указывает процент емкости гибкого тома, при котором инициируется автоматическое уменьшение. Пороговое значение уменьшения по умолчанию составляет 50%. Это ошибка, если пороговое значение уменьшения больше или равно пороговому значению увеличения. Диапазон от 0 до 100 |
use_rest string | Использовать REST или ZAPI. always – всегда будет использовать REST API, если модуль поддерживает REST. Предупреждение выдается, если модуль не поддерживает REST. Ошибка выдается, если параметр модуля не поддерживается в REST. never – всегда будет использовать ZAPI, если модуль поддерживает ZAPI. Ошибка может быть выдана, если параметр REST не поддерживается в ZAPI. auto – попытается использовать REST API, если модуль поддерживает REST и параметры модулей поддерживаются. В противном случае возвращается к ZAPI. По умолчанию: |
имя_пользователя псевдонимы: user строка | Это может быть учетная запись на уровне кластера или SVM, в зависимости от того, требуется ли API на уровне кластера или SVM. Для получения дополнительной информации, пожалуйста, обратитесь к документации https://mysupport.netapp.com/NOW/download/software/nmsdk/9.4/. Поддерживаются два метода аутентификации
Для использования сертификата, сертификат должен быть установлен в кластере ONTAP, и должна быть включена аутентификация по сертификатам. |
validate_certs логическое | Если установлено в Это следует устанавливать только в Варианты:
|
volume строка / обязательно | Имя гибкого тома, для которого мы хотим установить автоматический размер. |
vserver строка / обязательно | Имя vserver для использования. |
Примечания
Примечание
- Модули с префиксом na_ontap разработаны для поддержки платформы хранения ONTAP.
- https включен по умолчанию и рекомендуется. Для включения http в кластере необходимо выполнить следующие команды ‘set -privilege advanced;’ ‘system services web modify -http-enabled true;’
Примеры
- name: Modify volume autosize
netapp.ontap.na_ontap_volume_autosize:
hostname: 10.193.79.189
username: admin
password: netapp1!
volume: ansibleVolumesize12
mode: grow
grow_threshold_percent: 99
increment_size: 50m
maximum_size: 10g
minimum_size: 21m
shrink_threshold_percent: 40
vserver: ansible_vserver
- name: Reset volume autosize
netapp.ontap.na_ontap_volume_autosize:
hostname: 10.193.79.189
username: admin
password: netapp1!
volume: ansibleVolumesize12
reset: true
vserver: ansible_vserver
Ссылки на коллекцию
© 2012–2018 Michael DeHaan
© 2018–2024 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/latest/collections/netapp/ontap/na_ontap_volume_autosize_module.html