netapp.ontap.na_ontap_zapit module – NetApp ONTAP Run any ZAPI on ONTAP
Примечание
Этот модуль является частью коллекции netapp.ontap (версия 22.12.0).
Эта коллекция может быть уже установлена, если вы используете пакет ansible. Она не включена в ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.
Для установки используйте: ansible-galaxy collection install netapp.ontap. Для использования этого модуля необходимы дополнительные требования, см. Требования для получения подробной информации.
Для использования в playbook, укажите: netapp.ontap.na_ontap_zapit.
Новое в netapp.ontap 20.4.0
Краткое описание
- Вызов ZAPI на ONTAP.
- ZAPI кластера выполняются с использованием учетной записи администратора кластера.
- ZAPI виртуального сервера могут выполняться с использованием учетной записи vsadmin или с использованием туннелирования виртуального сервера (администратор кластера с параметром vserver).
- В случае успеха возвращается словарь JSON как
response. - В случае ошибки ZAPI,
status,errno,reasonустанавливаются для помощи в диагностике проблемы, - и вызов сообщается как ошибка («неудачно»).
- Другие ошибки (например, проблемы с подключением) сообщаются как ошибка Ansible.
Требования
Ниже указаны требования, необходимые на хосте, который выполняет этот модуль.
- Ansible 2.9 или более поздней версии - рекомендуется 2.12 или более поздней версии.
- Python3 - рекомендуется 3.9 или более поздней версии.
- При использовании ZAPI, netapp-lib 2018.11.13 или более поздней версии (установка с помощью «pip install netapp-lib»), netapp-lib 2020.3.12 настоятельно рекомендуется, поскольку она обеспечивает лучшее отображение ошибок для проблем с подключением
- физическая или виртуальная кластерная система Data ONTAP, модули поддерживают Data ONTAP 9.1 и выше, поддержка REST требует ONTAP 9.6 или выше
Параметры
Параметр | Комментарии |
|---|---|
cert_filepath строка добавлено в netapp.ontap 20.6.0 | путь к файлу клиентского сертификата SSL (.pem). не поддерживается с python 2.6. |
feature_flags словарь добавлено в netapp.ontap 20.5.0 | Включить или отключить новую функцию. Это может использоваться для включения экспериментальной функции или отключения новой функции, которая нарушает обратную совместимость. Поддерживаемые ключи и значения могут изменяться без уведомления. Неизвестные ключи игнорируются. |
hostname строка / обязательно | Имя хоста или IP-адрес экземпляра ONTAP. |
http_port целое число | Переопределить порт по умолчанию (80 или 443) этим портом |
https булево | Включить и отключить https. Игнорируется при использовании REST, так как поддерживается только https. Игнорируется при использовании проверки подлинности сертификата SSL, так как она требует SSL. Варианты:
|
key_filepath строка добавлено в netapp.ontap 20.6.0 | путь к файлу закрытого ключа SSL. |
ontapi целое число | Версия API ONTAP для использования |
password псевдонимы: pass строка | Пароль для указанного пользователя. |
use_rest строка | Этот модуль поддерживает только ZAPI и не может быть переключен на REST never – всегда будет использовать ZAPI, если модуль поддерживает ZAPI. Ошибка может быть выдана, если параметр REST не поддерживается в ZAPI. auto – всегда будет использовать ZAPI. По умолчанию: |
username псевдонимы: user строка | Это может быть учетная запись в масштабе кластера или SVM, в зависимости от того, требуется ли API уровня кластера или уровня SVM. Для получения дополнительной информации, пожалуйста, прочитайте документацию https://mysupport.netapp.com/NOW/download/software/nmsdk/9.4/. Поддерживаются два метода аутентификации
Для использования сертификата сертификат должен быть установлен в кластере ONTAP, и должна быть включена аутентификация сертификатов. |
validate_certs булево | Если установлено значение Это должно быть установлено в значение Варианты:
|
vserver строка | если указано, принудительно включает туннелирование виртуального сервера. имя пользователя идентифицирует учетную запись администратора кластера. |
zapi словарь / обязательно | Словарь для zapi и аргументов. Тег XML <tag>value</tag> представляет собой словарь с тегом в качестве ключа. Значение может быть другим словарем, списком словарей, строкой или ничего. например, <tag/> представлен как tag: Один zapi может вызываться за один раз. Ansible выдает предупреждение, если обнаружены дублирующиеся ключи, и использует только последнюю запись. |
Примечания
Примечание
- Модули с префиксом na_ontap созданы для поддержки платформы хранения ONTAP.
- https включен по умолчанию и рекомендуется. Чтобы включить http в кластере, необходимо выполнить следующие команды «set -privilege advanced;»; «system services web modify -http-enabled true;»
Примеры
-
name: Ontap ZAPI
hosts: localhost
gather_facts: False
collections:
- netapp.ontap
vars:
login: &login
hostname: "{{ admin_ip }}"
username: "{{ admin_username }}"
password: "{{ admin_password }}"
https: true
validate_certs: false
svm_login: &svm_login
hostname: "{{ svm_admin_ip }}"
username: "{{ svm_admin_username }}"
password: "{{ svm_admin_password }}"
https: true
validate_certs: false
tasks:
- name: run ontap ZAPI command as cluster admin
netapp.ontap.na_ontap_zapit:
<<: *login
zapi:
system-get-version:
register: output
- debug: var=output
- name: run ontap ZAPI command as cluster admin
netapp.ontap.na_ontap_zapit:
<<: *login
zapi:
vserver-get-iter:
register: output
- debug: var=output
- name: run ontap ZAPI command as cluster admin
netapp.ontap.na_ontap_zapit:
<<: *login
zapi:
vserver-get-iter:
desired-attributes:
vserver-info:
- aggr-list:
- aggr-name
- allowed-protocols:
- protocols
- vserver-aggr-info-list:
- vserser-aggr-info
- uuid
query:
vserver-info:
vserver-name: trident_svm
register: output
- debug: var=output
- name: run ontap ZAPI command as vsadmin
netapp.ontap.na_ontap_zapit:
<<: *svm_login
zapi:
vserver-get-iter:
desired-attributes:
vserver-info:
- uuid
register: output
- debug: var=output
- name: run ontap ZAPI command as vserver tunneling
netapp.ontap.na_ontap_zapit:
<<: *login
vserver: trident_svm
zapi:
vserver-get-iter:
desired-attributes:
vserver-info:
- uuid
register: output
- debug: var=output
- name: run ontap active-directory ZAPI command
netapp.ontap.na_ontap_zapit:
<<: *login
vserver: trident_svm
zapi:
active-directory-account-create:
account-name: testaccount
admin-username: testuser
admin-password: testpass
domain: testdomain
organizational-unit: testou
register: output
ignore_errors: True
- debug: var=output
Значения возврата
Общие значения возврата описаны здесь, следующие являются полями, уникальными для данного модуля:
Ключ | Описание |
|---|---|
errno строка | Если ZAPI был выполнен, но завершился ошибкой, код ошибки, установленный ZAPI. Отсутствует, если выполнение прошло успешно или если вызов ZAPI не может быть выполнен. Возвращается: При ошибке |
reason строка | Если ZAPI был выполнен, но завершился ошибкой, причина ошибки, установленная ZAPI. Отсутствует, если выполнение прошло успешно или если вызов ZAPI не может быть выполнен. Возвращается: При ошибке |
response словарь | Если выполнение прошло успешно, json-словарь, представляющий данные, возвращенные ZAPI. Если ZAPI был выполнен, но завершился ошибкой, пустой словарь. Отсутствует, если вызов ZAPI не может быть выполнен. Возвращается: При успехе |
status строка | Если ZAPI был выполнен, но завершился ошибкой, статус, установленный ZAPI. Отсутствует, если выполнение прошло успешно или если вызов ZAPI не может быть выполнен. Возвращается: При ошибке |
Ссылки на сборку
© 2012–2018 Michael DeHaan
© 2018–2024 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/latest/collections/netapp/ontap/na_ontap_zapit_module.html