openstack.cloud.openstack inventory – OpenStack инвентаризация источника
Примечание
Этот плагин инвентаризации входит в состав коллекции openstack.cloud (версия 2.2.0).
У вас, возможно, уже установлена эта коллекция, если вы используете пакет ansible. Она не включена в ansible-core. Чтобы проверить, установлена ли она, выполните ansible-galaxy collection list.
Для установки используйте: ansible-galaxy collection install openstack.cloud. Для использования этого плагина инвентаризации необходимы дополнительные требования, см. Требования для получения подробностей.
Для использования его в книге задач укажите: openstack.cloud.openstack.
Обзор
- Сбор серверов из облаков OpenStack и добавление их в качестве хостов Ansible в ваш инвентарь.
- Используйте файл конфигурации YAML
openstack.{yaml,yml}для настройки этого плагина инвентаризации. - Использует учетные данные облака из стандартных файлов конфигурации YAML
clouds{,-public}.yaml.
Требования
Ниже приведены требования, необходимые на локальном узле контроллера, который выполняет эту инвентаризацию.
- python >= 3.6
- openstacksdk >= 1.0.0
Параметры
Параметр | Комментарии |
|---|---|
all_projects boolean | Список серверов всех проектов Выбори:
|
cache boolean | Включить/выключить кеширование данных источника инвентаризации. Требуется настройка плагина кеша для работы. Выбори:
Настройка:
|
cache_connection string | Данные или путь подключения к кешу. Подробности см. в документации к плагину кеша. Настройка:
|
cache_plugin string | Плагин кеша для данных источника инвентаризации. По умолчанию: Настройка:
|
cache_prefix string | Префикс для файлов/таблиц плагина кеша По умолчанию: Настройка:
|
cache_timeout integer | Время жизни кеша в секундах По умолчанию: Настройка:
|
clouds_yaml_path list / elements=string | Заменить путь к файлу Если это значение указано, оно будет проверяться в первую очередь. Пути поиска для учетных данных облака дополняются файлами Документация по стандартным путям поиска приведена по адресу https://docs.openstack.org/os-client-config/latest/user/configuration.html#config-files. Настройка:
|
compose dictionary | Создать переменные из выражений jinja2. По умолчанию: |
expand_hostvars boolean | Обогатить факты сервера дополнительными запросами к службам OpenStack. Это включает запросы к Cinder и Neutron, что может быть длительным для облаков с большим количеством серверов. Значение по умолчанию для expand_hostvars противоположно значению по умолчанию для параметра Выбори:
|
fail_on_errors boolean | Скрипт инвентаризации завершается с ошибкой, возвращая не имеющих хостов, при соединении с облаком неудачно (например, из-за плохих учетных данных или проблем с подключением). Когда fail_on_errors равно Значение по умолчанию для fail_on_errors противоположно значению по умолчанию для параметра Выбори:
|
groups dictionary | Добавление хостов в группу на основе условных операторов Jinja2. По умолчанию: |
inventory_hostname string | Регистрация имени хоста инвентаризации. При установке в При установке в Значение по умолчанию для inventory_hostname противоположно значению по умолчанию для параметра Выбори:
|
keyed_groups список / элементы=словарь | Добавить хосты в группу на основе значений переменной. По умолчанию: |
|
default_value строка добавлено в ansible-core 2.12 |
Значение по умолчанию, когда значение переменной хоста — пустая строка. Этот параметр взаимоисключающий с |
|
key строка |
Ключ из входного словаря, используемый для создания групп |
|
parent_group строка |
родительская группа для группы keyed |
|
prefix строка |
Имя группы keyed будет начинаться с этого префикса По умолчанию: |
|
separator строка |
Разделитель, используемый для построения имени keyed группы По умолчанию: |
|
trailing_separator логический добавлено в ansible-core 2.12 |
Установите этот параметр в Этот параметр взаимоисключающий с Варианты:
|
leading_separator логический добавлено в ansible-core 2.11 | Используется совместно с keyed_groups. По умолчанию, группа keyed, у которой не указан префикс или разделитель, будет иметь имя, начинающееся с нижнего подчёркивания. Это потому, что префикс по умолчанию — «», а разделитель по умолчанию — «_». Установите этот параметр в False, чтобы опустить ведущее нижнее подчёркивание (или другой разделитель), если префикс не задан. Если имя группы получено из сопоставления, разделитель всё равно используется для конкатенации элементов. Чтобы вообще не использовать разделитель в имени группы, установите разделитель для группы keyed в пустую строку. Варианты:
|
legacy_groups логический | Автоматически создавать группы из переменных хоста. Варианты:
|
only_clouds список / элементы=строка | Список облаков в По умолчанию: |
plugin строка / обязательно | Токен, который отмечает заданный YAML-конфигурационный файл как допустимый входной файл для этого плагина инвентаризации. Варианты:
|
private логический | Использовать частные интерфейсы серверов (если доступны) при определении IP-адресов для хостов Ansible. Использование private полезно при запуске Ansible с сервера в облаке, когда необходимо гарантировать, что серверы общаются только по частным сетям. Варианты:
|
show_all логический | Определяет, должны ли быть перечислены все серверы. Если show_all равно Варианты:
|
strict логический | Если Так как в выражениях можно использовать факты, они могут быть недоступны, и такие ошибки по умолчанию игнорируются. Варианты:
|
use_extra_vars логический добавлено в ansible-core 2.11 | Объединить дополнительные переменные в доступные переменные для составления (высший приоритет). Варианты:
Настройка:
|
use_names boolean | Когда use_names принимает значение Когда use_names принимает значение Варианты:
|
Примеры
# Create a file called openstack.yaml, add the following content and run # $> ansible-inventory --list -vvv -i openstack.yaml plugin: openstack.cloud.openstack all_projects: false expand_hostvars: true fail_on_errors: true only_clouds: - "devstack-admin" strict: true
Ссылки на сборку
© 2012–2018 Michael DeHaan
© 2018–2024 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/latest/collections/openstack/cloud/openstack_inventory.html