Spec-Zone.ru › Ansible 2.10

google.cloud.gcp_compute_forwarding_rule_info – Сбор информации о GCP Правиле перенаправления

Примечание

Этот плагин входит в коллекцию google.cloud (версия 1.0.1).

Для установки используйте: ansible-galaxy collection install google.cloud.

Для использования в книге задач, укажите: google.cloud.gcp_compute_forwarding_rule_info.

  • Обзор
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Обзор

  • Сбор информации о GCP Правиле перенаправления

Требования

Ниже перечислены требования к хосту, на котором выполняется этот модуль.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
auth_kind
строка / обязательный
    Варианты:
  • application
  • machineaccount
  • serviceaccount
Тип используемых учетных данных.
env_type
строка
Указывает, в какой среде Ansible выполняется этот модуль.
Это не нужно устанавливать, если вы не знаете, что делаете.
Это изменяет только строку User Agent для всех запросов API.
filters
список / элементы=строка
Список пар значений фильтров. Доступные фильтры перечислены здесь https://cloud.google.com/sdk/gcloud/reference/topic/filters.
Каждый дополнительный фильтр в списке будет добавлен как условие И (filter1 и filter2) .
project
строка
Проект Google Cloud Platform для использования.
region
строка / обязательный
Ссылка на регион, в котором находится региональное правило перенаправления.
Это поле не применимо к глобальным правилам перенаправления.
scopes
список / элементы=строка
Массив используемых областей видимости
service_account_contents
jsonarg
Содержание файла JSON учетной записи сервиса, либо в виде словаря, либо в виде JSON строки, его представляющей.
service_account_email
строка
Необязательный адрес электронной почты учетной записи сервиса, если выбран machineaccount, и пользователь не хочет использовать адрес по умолчанию.
service_account_file
путь
Путь к файлу JSON учетной записи сервиса, если тип serviceaccount выбран в качестве типа.

Примечания

Примечание

  • для аутентификации можно установить service_account_file, используя переменную окружения gcp_service_account_file.
  • для аутентификации можно установить service_account_contents, используя переменную окружения GCP_SERVICE_ACCOUNT_CONTENTS.
  • для аутентификации можно установить service_account_email, используя переменную окружения GCP_SERVICE_ACCOUNT_EMAIL.
  • для аутентификации можно установить auth_kind, используя переменную окружения GCP_AUTH_KIND.
  • для аутентификации можно установить scopes, используя переменную окружения GCP_SCOPES.
  • Значения переменных среды будут использованы только в том случае, если значения в книге задач не заданы.
  • Параметры service_account_email и service_account_file взаимоисключающие.

Примеры

- name: get info on a forwarding rule
  gcp_compute_forwarding_rule_info:
    region: us-west1
    filters:
    - name = test_object
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"

Возвращаемые значения

Общие возвращаемые значения документированы здесь, следующие поля уникальны для этого модуля:

Ключ Возвращаемое значение Описание
resources
complex
всегда
Список ресурсов

allowGlobalAccess
boolean
успех
Если true, клиенты могут получить доступ к ILB со всех регионов.
В противном случае доступ разрешен только из локального региона, в котором находится ILB.

allPorts
boolean
успех
Для балансировки нагрузки TCP/UDP внутри сети (т.е. схема балансировки - INTERNAL, протокол - TCP/UDP), установите это значение в true, чтобы разрешить перенаправление пакетов, адресованных любым портам, на бэкенды, настроенные с этим правилом перенаправления. Используется с backend service. Не может быть установлено, если установлены port или portRange.

backendService
dictionary
успех
BackendService для получения соответствующего трафика. Используется только для балансировки нагрузки внутри сети.

creationTimestamp
string
успех
Дата и время создания в формате RFC3339.

description
string
успех
Необязательное описание этого ресурса. Укажите это свойство при создании ресурса.

id
integer
успех
Уникальный идентификатор ресурса.

IPAddress
string
успех
IP-адрес, по которому это правило перенаправления обслуживает трафик.
Адреса ограничены схемой балансировки нагрузки (EXTERNAL или INTERNAL) и областью (глобальной или региональной).
При схеме балансировки EXTERNAL, для глобальных правил перенаправления, адрес должен быть глобальным IP-адресом, а для региональных правил перенаправления, адрес должен находиться в том же регионе, что и правило перенаправления. Если это поле пустое, будет назначен временный IPv4-адрес из той же области (глобальной или региональной). Региональное правило перенаправления поддерживает только IPv4. Глобальное правило перенаправления поддерживает IPv4 или IPv6.
При схеме балансировки INTERNAL, это может быть только IP-адрес RFC 1918, принадлежащий сети/подсети, настроенной для правила перенаправления. По умолчанию, если это поле пустое, будет автоматически выделен временный внутренний IP-адрес из диапазона IP-адресов подсети или сети, настроенной для этого правила перенаправления.
Адрес может быть указан как буквальным IP-адресом, так и ссылкой на URL существующего ресурса Address. Следующие примеры являются допустимыми: * 100.1.2.3 * https://www.googleapis.com/compute/v1/projects/project/regions/region/addresses/address * projects/project/regions/region/addresses/address * regions/region/addresses/address * global/addresses/address * address .

IPProtocol
string
успех
Протокол IP, к которому относится данное правило.
При схеме балансировки INTERNAL, допустимы только TCP и UDP.

loadBalancingScheme
string
успех
Указывает, для чего используется ForwardingRule, и может быть EXTERNAL, INTERNAL или INTERNAL_MANAGED. EXTERNAL используется для шлюзов Classic Cloud VPN, перенаправления протоколов на виртуальные машины с внешнего IP-адреса, а также для HTTP(S), SSL Proxy, TCP Proxy, и сетевых балансировщиков TCP/UDP.
INTERNAL используется для перенаправления протоколов на виртуальные машины с внутреннего IP-адреса, и для внутренних балансировщиков TCP/UDP.
INTERNAL_MANAGED используется для внутренних балансировщиков HTTP(S).

name
string
успех
Имя ресурса; предоставляется клиентом при создании ресурса. Длина имени должна быть от 1 до 63 символов и соответствовать RFC1035. То есть, длина имени должна быть от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом.

network
dictionary
успех
Для внутренней балансировки нагрузки это поле идентифицирует сеть, к которой должен принадлежать IP-адрес балансировки нагрузки для данного правила перенаправления. Если это поле не указано, будет использоваться сеть по умолчанию.
Это поле используется только для внутренней балансировки нагрузки.

networkTier
string
успех
Уровень сети, используемый для настройки этого адреса. Если это поле не указано, предполагается PREMIUM.

portRange
string
успех
Это поле используется вместе с полем target для TargetHttpProxy, TargetHttpsProxy, TargetSslProxy, TargetTcpProxy, TargetVpnGateway, TargetPool, TargetInstance.
Применимо только в случае, если IPProtocol — TCP, UDP или SCTP. Будут перенаправляться только пакеты, адресованные портам в указанном диапазоне, на целевые объекты.
Правила перенаправления с одинаковыми [IPAddress, IPProtocol] должны иметь непересекающиеся диапазоны портов.
Некоторые типы целевых объектов имеют ограничения на допустимые порты: * TargetHttpProxy: 80, 8080 * TargetHttpsProxy: 443 * TargetTcpProxy: 25, 43, 110, 143, 195, 443, 465, 587, 700, 993, 995, 1883, 5222 * TargetSslProxy: 25, 43, 110, 143, 195, 443, 465, 587, 700, 993, 995, 1883, 5222 * TargetVpnGateway: 500, 4500 .

ports
list / elements=string
успех
Это поле используется вместе с полем backend_service для внутренней балансировки нагрузки.
При схеме балансировки INTERNAL можно настроить один порт или список портов, разделенных запятыми. Будут перенаправляться только пакеты, адресованные этим портам, на бэкенды, настроенные с этим правилом перенаправления.
Можно указать максимум 5 портов.

region
string
успех
Ссылка на регион, в котором находится региональное правило перенаправления.
Это поле не применимо к глобальным правилам перенаправления.

serviceLabel
string
успех
Необязательный префикс к имени службы для этого правила перенаправления.
Если указан, будет первым тегом полностью квалифицированного имени службы.
Тег должен быть длиной от 1 до 63 символов и соответствовать RFC1035.
То есть, длина тега должна быть от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом.
Это поле используется только для внутренней балансировки нагрузки.

serviceName
string
успех
Внутреннее полное имя службы для этого правила перенаправления.
Это поле используется только для внутренней балансировки нагрузки.

subnetwork
dictionary
успех
Подсеть, к которой должен принадлежать IP-адрес балансировки нагрузки для данного правила перенаправления. Это поле используется только для внутренней балансировки нагрузки.
Если указанная сеть находится в режиме автоподсети, это поле необязательно. Однако, если сеть находится в режиме пользовательской подсети, подсеть необходимо указать.

target
string
успех
URL целевого ресурса, который должен получать соответствующий трафик.
Целевой объект должен находиться в том же регионе, что и правило перенаправления.
Перенаправляемый трафик должен быть соответствующего типа для целевого объекта.



Авторы

  • Google Inc. (@googlecloudplatform)

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/google/cloud/gcp_compute_forwarding_rule_info_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API