Spec-Zone.ru › Ansible 2.10

google.cloud.gcp_compute_global_address_info – Сбор информации о GCP GlobalAddress

Примечание

Этот плагин входит в состав коллекции google.cloud (версия 1.0.1).

Для его установки используйте: ansible-galaxy collection install google.cloud.

Для использования в плейбуке укажите: google.cloud.gcp_compute_global_address_info.

  • Обзор
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Обзор

  • Сбор информации о GCP GlobalAddress

Требования

Ниже приведены требования, необходимые на хосте, на котором выполняется этот модуль.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
auth_kind
строка / обязательный
    Варианты:
  • application
  • machineaccount
  • serviceaccount
Тип используемых учетных данных.
env_type
строка
Указывает, в какой среде Ansible вы выполняете этот модуль.
Это не должно устанавливаться, если вы не знаете, что делаете.
Это изменяет только строку User Agent для всех запросов к API.
filters
список / элементы=строка
Список пар значений фильтров. Доступные фильтры перечислены здесь https://cloud.google.com/sdk/gcloud/reference/topic/filters.
Каждый дополнительный фильтр в списке будет добавлен как условие И (filter1 и filter2).
project
строка
Проект Google Cloud Platform, который нужно использовать.
scopes
список / элементы=строка
Массив используемых областей
service_account_contents
jsonarg
Содержимое файла JSON учетной записи службы, либо в словаре, либо в виде строки JSON, которая его представляет.
service_account_email
строка
Необязательный адрес электронной почты учетной записи службы, если выбран machineaccount, и пользователь не хочет использовать адрес по умолчанию.
service_account_file
путь
Путь к файлу JSON учетной записи службы, если в качестве типа выбран serviceaccount.

Примечания

Примечание

  • для аутентификации можно установить service_account_file, используя переменную среды gcp_service_account_file.
  • для аутентификации можно установить service_account_contents, используя переменную среды GCP_SERVICE_ACCOUNT_CONTENTS.
  • для аутентификации можно установить service_account_email, используя переменную среды GCP_SERVICE_ACCOUNT_EMAIL.
  • для аутентификации можно установить auth_kind, используя переменную среды GCP_AUTH_KIND.
  • для аутентификации можно установить scopes, используя переменную среды GCP_SCOPES.
  • Значения переменных среды будут использоваться только в том случае, если значения плейбука не заданы.
  • Параметры service_account_email и service_account_file взаимоисключающие.

Примеры

- name: get info on a global address
  gcp_compute_global_address_info:
    filters:
    - name = test_object
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"

Возвращаемые значения

Общие возвращаемые значения описаны здесь, следующие поля уникальны для данного модуля:

Ключ Возвращаемое значение Описание
resources
сложное
всегда
Список ресурсов

address
строка
успешно
Статический внешний IP-адрес, представленный этим ресурсом.

addressType
строка
успешно
Тип адреса для резервирования.
* EXTERNAL означает публичный/внешний одиночный IP-адрес.
* INTERNAL означает внутренние IP-диапазоны, принадлежащие к некоторой сети.

creationTimestamp
строка
успешно
Дата и время создания в формате RFC3339.

description
строка
успешно
Необязательное описание этого ресурса.

id
целое число
успешно
Уникальный идентификатор ресурса. Этот идентификатор определяется сервером.

ipVersion
строка
успешно
Версия IP, которая будет использоваться этим адресом. Значение по умолчанию — `IPV4`.

name
строка
успешно
Имя ресурса. Предоставляется клиентом при создании ресурса. Имя должно иметь длину от 1 до 63 символов и соответствовать RFC1035. Точнее, длина имени должна быть от 1 до 63 символов, и оно должно соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом.

network
словарь
успешно
URL сети, в которой необходимо зарезервировать IP-диапазон. IP-диапазон должен находиться в пространстве RFC1918. Сеть не может быть удалена, если на нее ссылаются какие-либо зарезервированные IP-диапазоны.
Это должно быть установлено только при использовании внутреннего адреса.

prefixLength
целое число
успешно
Длина префикса IP-диапазона. Если она отсутствует, это означает, что поле address — это одиночный IP-адрес.
Это поле не применимо к адресам с addressType=EXTERNAL.

purpose
строка
успешно
Назначение ресурса. Для глобальных внутренних адресов он может быть * VPC_PEERING — для сетей-партнеров. Это должно быть установлено только при использовании внутреннего адреса.

region
строка
успешно
Ссылка на регион, в котором находится региональный адрес.



Авторы

  • Google Inc. (@googlecloudplatform)

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/google/cloud/gcp_compute_global_address_info_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API