Spec-Zone.ru › Ansible 2.10

google.cloud.gcp_compute_global_address – Создаёт GCP GlobalAddress

Примечание

Этот плагин входит в коллекцию google.cloud (версия 1.0.1).

Для его установки используйте: ansible-galaxy collection install google.cloud.

Для использования в книге задач, укажите: google.cloud.gcp_compute_global_address.

  • Обзор
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Обзор

  • Представляет ресурс Global Address. Global Address используется для балансировки нагрузки HTTP(S).

Требования

Ниже перечислены требования, необходимые на хосте, на котором выполняется этот модуль.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
address
строка
Статический внешний IP-адрес, представленный этим ресурсом.
address_type
строка
По умолчанию:
"EXTERNAL"
Тип адреса для резервирования.
* EXTERNAL указывает публичный/внешний одиночный IP-адрес.
* INTERNAL указывает внутренние IP-диапазоны, принадлежащие определенной сети.
Некоторые допустимые значения: "EXTERNAL", "INTERNAL"
auth_kind
строка / обязательный
    Варианты:
  • application
  • machineaccount
  • serviceaccount
Тип используемых учетных данных.
description
строка
Необязательное описание этого ресурса.
env_type
строка
Указывает, в какой среде Ansible вы выполняете этот модуль.
Это поле следует устанавливать только в том случае, если вы это понимаете.
Это влияет только на строку User Agent для любых запросов к API.
ip_version
строка
Версия IP, которая будет использоваться этим адресом. Значение по умолчанию - `IPV4`.
Некоторые допустимые значения: "IPV4", "IPV6"
name
строка / обязательный
Имя ресурса. Предоставляется клиентом при создании ресурса. Имя должно быть длиной от 1 до 63 символов и соответствовать RFC1035. Более точно, длина имени должна быть от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы должны быть тире, строчной буквой или цифрой, за исключением последнего символа, который не может быть тире.
network
словарь
URL сети, в которой необходимо зарезервировать IP-диапазон. IP-диапазон должен быть в пространстве RFC1918. Сеть не может быть удалена, если к ней относятся какие-либо зарезервированные IP-диапазоны.
Это поле следует устанавливать только при использовании внутреннего адреса.
Это поле представляет ссылку на ресурс сети GCP. Его можно указать двумя способами. Во-первых, можно поместить словарь с ключом 'selfLink' и значением selfLink вашего ресурса. Во-вторых, можно добавить `register: имя-ресурса` к задаче gcp_compute_network, а затем установить это поле network к "{{ имя-ресурса }}"
prefix_length
целое число
Длина префикса IP-диапазона. Если её нет, то это означает, что поле address представляет одиночный IP-адрес.
Это поле не применимо к адресам с addressType=EXTERNAL.
project
строка
Проект Google Cloud Platform, который следует использовать.
purpose
строка
Цель ресурса. Для глобальных внутренних адресов может быть * VPC_PEERING - для сетевого взаимного соединения. Это поле следует устанавливать только при использовании внутреннего адреса.
Некоторые допустимые значения: "VPC_PEERING"
scopes
список / элементы=строка
Массив используемых областей
service_account_contents
jsonarg
Содержимое JSON-файла учетной записи службы, либо в виде словаря, либо в виде JSON-строки, его представляющей.
service_account_email
строка
Необязательный адрес электронной почты учетной записи службы, если выбран machineaccount, и пользователь не хочет использовать адрес по умолчанию.
service_account_file
путь
Путь к JSON-файлу учетной записи службы, если тип выбран как serviceaccount.
state
строка
    Варианты:
  • present ←
  • absent
Нужно ли, чтобы данный объект существовал в GCP

Примечания

Примечание

  • Ссылка на API: https://cloud.google.com/compute/docs/reference/v1/globalAddresses
  • Резервирование статического внешнего IP-адреса: https://cloud.google.com/compute/docs/ip-addresses/reserve-static-external-ip-address
  • для аутентификации можно установить service_account_file с помощью переменной среды gcp_service_account_file.
  • для аутентификации можно установить service_account_contents с помощью переменной среды GCP_SERVICE_ACCOUNT_CONTENTS.
  • для аутентификации можно установить service_account_email с помощью переменной среды GCP_SERVICE_ACCOUNT_EMAIL.
  • для аутентификации можно установить auth_kind с помощью переменной среды GCP_AUTH_KIND.
  • для аутентификации можно установить scopes с помощью переменной среды GCP_SCOPES.
  • Значения переменных среды будут использоваться только в том случае, если значения в книге задач не установлены.
  • Параметры service_account_email и service_account_file взаимоисключающие.

Примеры

- name: create a global address
  google.cloud.gcp_compute_global_address:
    name: test_object
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"
    state: present

Возвращаемые значения

Общие возвращаемые значения описаны здесь, следующие — поля, уникальные для этого модуля:

Ключ Возвращаемое значение Описание
address
строка
успех
Статический внешний IP-адрес, представленный этим ресурсом.

addressType
строка
успех
Тип адреса для резервирования.
* EXTERNAL указывает публичный/внешний одиночный IP-адрес.
* INTERNAL указывает внутренние IP-диапазоны, принадлежащие определенной сети.

creationTimestamp
строка
успех
Дата и время создания в формате RFC3339.

description
строка
успех
Необязательное описание этого ресурса.

id
целое число
успех
Уникальный идентификатор ресурса. Этот идентификатор определён сервером.

ipVersion
строка
успех
Версия IP, которая будет использоваться этим адресом. Значение по умолчанию - `IPV4`.

name
строка
успех
Имя ресурса. Предоставляется клиентом при создании ресурса. Имя должно быть длиной от 1 до 63 символов и соответствовать RFC1035. Более точно, длина имени должна быть от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы должны быть тире, строчной буквой или цифрой, за исключением последнего символа, который не может быть тире.

network
словарь
успех
URL сети, в которой необходимо зарезервировать IP-диапазон. IP-диапазон должен быть в пространстве RFC1918. Сеть не может быть удалена, если к ней относятся какие-либо зарезервированные IP-диапазоны.

prefixLength
целое число
успех
Длина префикса IP-диапазона. Если её нет, то это означает, что поле address представляет одиночный IP-адрес.
Это поле не применимо к адресам с addressType=EXTERNAL.

purpose
строка
успех
Цель ресурса. Для глобальных внутренних адресов может быть * VPC_PEERING - для сетевого взаимного соединения.

region
строка
успех
Ссылка на регион, в котором находится региональный адрес.



Авторы

  • Google Inc. (@googlecloudplatform)

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/google/cloud/gcp_compute_global_address_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API