google.cloud.gcp_compute_global_forwarding_rule_info – Сбор информации о GCP GlobalForwardingRule
Примечание
Этот плагин является частью коллекции google.cloud (версия 1.0.1).
Для его установки используйте: ansible-galaxy collection install google.cloud.
Для использования в книге задач укажите: google.cloud.gcp_compute_global_forwarding_rule_info.
Описание
- Сбор информации о GCP GlobalForwardingRule
Требования
Ниже приведены требования, необходимые на хосте, на котором выполняется этот модуль.
- python >= 2.6
- requests >= 2.18.4
- google-auth >= 1.3.0
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| auth_kind строка / обязательно |
| Тип используемых учетных данных. |
| env_type строка | Указывает, в какой среде Ansible вы выполняете этот модуль. Это не должно быть установлено, если вы не знаете, что делаете. Это изменяет только строку User Agent для всех запросов к API. | |
| filters список / элементы=строка | Список пар значений фильтров. Доступные фильтры перечислены здесь https://cloud.google.com/sdk/gcloud/reference/topic/filters. Каждый дополнительный фильтр в списке будет добавлен как условие И (filter1 и filter2). | |
| project строка | Проект Google Cloud Platform для использования. | |
| scopes список / элементы=строка | Массив используемых областей | |
| service_account_contents jsonarg | Содержимое файла JSON учетной записи службы, либо в виде словаря, либо как строка JSON, которая его представляет. | |
| service_account_email строка | Необязательный адрес электронной почты учетной записи службы, если выбран machineaccount, и пользователь не хочет использовать адрес по умолчанию. | |
| service_account_file путь | Путь к файлу JSON учетной записи службы, если тип выбран как serviceaccount. |
Примечания
Примечание
- для аутентификации можно установить service_account_file с помощью переменной среды
gcp_service_account_file. - для аутентификации можно установить service_account_contents с помощью переменной среды
GCP_SERVICE_ACCOUNT_CONTENTS. - Для аутентификации можно установить service_account_email с помощью переменной среды
GCP_SERVICE_ACCOUNT_EMAIL. - Для аутентификации можно установить auth_kind с помощью переменной среды
GCP_AUTH_KIND. - Для аутентификации можно установить scopes с помощью переменной среды
GCP_SCOPES. - Значения переменных среды будут использоваться только в том случае, если значения книги задач не заданы.
- Параметры service_account_email и service_account_file взаимоисключающие.
Примеры
- name: get info on a global forwarding rule
gcp_compute_global_forwarding_rule_info:
filters:
- name = test_object
project: test_project
auth_kind: serviceaccount
service_account_file: "/tmp/auth.pem"
Значения возврата
Общие значения возврата описаны здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание | |||
|---|---|---|---|---|---|
| resources complex | всегда | Список ресурсов | |||
| creationTimestamp string | успех | Маркер создания в формате RFC3339. | |||
| description string | успех | Необязательное описание этого ресурса. Укажите это свойство при создании ресурса. | |||
| id integer | успех | Уникальный идентификатор ресурса. | |||
| IPAddress string | успех | IP-адрес, на котором это правило переадресации обслуживает трафик. Адреса ограничены схемой балансировки нагрузки правила переадресации (EXTERNAL или INTERNAL) и областью (глобальная или региональная). Когда схема балансировки — EXTERNAL, для глобальных правил переадресации адрес должен быть глобальным IP-адресом, а для региональных правил переадресации — адресом в той же области, что и правило переадресации. Если это поле пусто, будет назначен временный IPv4-адрес из той же области (глобальной или региональной). Региональное правило переадресации поддерживает только IPv4. Глобальное правило переадресации поддерживает IPv4 или IPv6. Когда схема балансировки — INTERNAL, это может быть только IP-адрес RFC 1918, принадлежащий сети/подсети, настроенной для правила переадресации. По умолчанию, если это поле пусто, будет автоматически выделен временный внутренний IP-адрес из диапазона IP-адресов подсети или сети, настроенной для этого правила переадресации. Адрес можно указать либо в виде IP-адреса, либо в виде URL-ссылки на существующий ресурс Address. Следующие примеры являются допустимыми: * 100.1.2.3 * https://www.googleapis.com/compute/v1/projects/project/regions/region/addresses/address * projects/project/regions/region/addresses/address * regions/region/addresses/address * global/addresses/address * address . | |||
| IPProtocol string | успех | IP-протокол, к которому относится это правило. При схеме балансировки INTERNAL_SELF_MANAGED допустим только TCP. | |||
| ipVersion string | успех | Версия IP, которая будет использоваться этим глобальным правилом переадресации. | |||
| loadBalancingScheme string | успех | Указывает, для чего будет использоваться GlobalForwardingRule. Значение INTERNAL_SELF_MANAGED означает, что это будет использоваться для внутреннего глобального HTTP(S) балансировщика. Значение EXTERNAL означает, что это будет использоваться для внешнего глобального балансировщика (HTTP(S) балансировщик, внешний TCP/UDP балансировщик, SSL прокси). ПРИМЕЧАНИЕ: в настоящее время глобальные правила переадресации не могут использоваться для внутренней балансировки. | |||
| metadataFilters complex | успех | Непрозрачные критерии фильтрации, используемые Loadbalancer для ограничения конфигурации маршрутизации для ограниченного набора клиентов, соответствующих xDS. В своих запросах xDS к Loadbalancer клиенты xDS представляют метаданные узла. Если произойдет совпадение, соответствующая конфигурация маршрутизации будет доступна для этих прокси. Для каждого metadataFilter в этом списке, если его filterMatchCriteria установлено в MATCH_ANY, по крайней мере, одна из filterLabels должна совпадать с соответствующей меткой, предоставленной в метаданных. Если filterMatchCriteria установлено в MATCH_ALL, все filterLabels должны совпадать с соответствующими метками в предоставленных метаданных. metadataFilters, указанные здесь, могут быть переопределены теми, что указаны в UrlMap, на который ссылается это ForwardingRule. metadataFilters применяются только к Loadbalancer, у которых loadBalancingScheme установлено в INTERNAL_SELF_MANAGED. | |||
| filterLabels complex | успех | Список пар меток и значений, которые должны совпадать с метками в предоставленных метаданных на основе filterMatchCriteria. Этот список не должен быть пустым и может содержать не более 64 записей. | |||
| name string | успех | Имя метки метаданных. Длина должна быть от 1 до 1024 символов включительно. | |||
| value string | успех | Значение, с которым должна совпадать метка. Значение имеет максимальную длину 1024 символов. | |||
| filterMatchCriteria string | успех | Определяет, как отдельные соответствия filterLabel в списке filterLabels вносят вклад в соответствие overall metadataFilter. MATCH_ANY - по крайней мере, одна из filterLabels должна иметь соответствующую метку в предоставленных метаданных. MATCH_ALL - все filterLabels должны иметь соответствующие метки в предоставленных метаданных. | |||
| name string | успех | Имя ресурса; предоставляется клиентом при создании ресурса. Имя должно быть длиной от 1 до 63 символов и соответствовать RFC1035. Точнее, имя должно быть длиной от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы должны быть тире, строчной буквой или цифрой, за исключением последнего символа, который не может быть тире. | |||
| network dictionary | успех | Это поле не используется для внешней балансировки. Для балансировки INTERNAL_SELF_MANAGED это поле идентифицирует сеть, к которой должен принадлежать IP-адрес балансировщика для этого глобального правила переадресации. Если это поле не указано, будет использоваться сеть по умолчанию. | |||
| portRange string | успех | Это поле используется вместе с полем target для TargetHttpProxy, TargetHttpsProxy, TargetSslProxy, TargetTcpProxy, TargetVpnGateway, TargetPool, TargetInstance. Применимо только тогда, когда IPProtocol равен TCP, UDP или SCTP, только пакеты, адресованные портам в указанном диапазоне, будут переадресованы целевому объекту. Правила переадресации с одинаковой парой [IPAddress, IPProtocol] должны иметь непересекающиеся диапазоны портов. Некоторые типы целевого объекта переадресации имеют ограничения на допустимые порты: * TargetHttpProxy: 80, 8080 * TargetHttpsProxy: 443 * TargetTcpProxy: 25, 43, 110, 143, 195, 443, 465, 587, 700, 993, 995, 1883, 5222 * TargetSslProxy: 25, 43, 110, 143, 195, 443, 465, 587, 700, 993, 995, 1883, 5222 * TargetVpnGateway: 500, 4500 . | |||
| target string | успех | URL целевого ресурса для получения соответствующего трафика. Переадресованный трафик должен быть подходящего типа для целевого объекта. Для балансировки INTERNAL_SELF_MANAGED допустимы только целевые объекты HTTP и HTTPS. | |||
Авторы
- Google Inc. (@googlecloudplatform)
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/google/cloud/gcp_compute_global_forwarding_rule_info_module.html