Spec-Zone.ru › Ansible 2.10

google.cloud.gcp_compute_image_info – Сбор информации о GCP-изображении

Примечание

Этот плагин входит в коллекцию google.cloud (версия 1.0.1).

Для его установки используйте: ansible-galaxy collection install google.cloud.

Для использования в книге задач укажите: google.cloud.gcp_compute_image_info.

  • Краткое описание
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Краткое описание

  • Сбор информации о GCP-изображении

Требования

Ниже перечислены требования, необходимые на хосте, на котором выполняется этот модуль.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
auth_kind
строка / обязательно
    Варианты:
  • application
  • machineaccount
  • serviceaccount
Тип используемых учетных данных.
env_type
строка
Указывает, в какой среде Ansible выполняется этот модуль.
Это поле не следует устанавливать, если вы не знаете, что делаете.
Это поле только изменяет строку User Agent для всех запросов к API.
filters
список / элементы=строка
Список пар значений фильтров. Доступные фильтры перечислены здесь https://cloud.google.com/sdk/gcloud/reference/topic/filters.
Каждый дополнительный фильтр в списке будет добавлен как условие И (filter1 и filter2).
project
строка
Проект Google Cloud Platform, который нужно использовать.
scopes
список / элементы=строка
Массив используемых областей
service_account_contents
jsonarg
Содержимое файла JSON учетной записи службы, либо в виде словаря, либо как строка JSON, которая его представляет.
service_account_email
строка
Дополнительный адрес электронной почты учетной записи службы, если выбран machineaccount, и пользователь не хочет использовать адрес по умолчанию.
service_account_file
путь
Путь к файлу JSON учетной записи службы, если в качестве типа выбран serviceaccount.

Примечания

Примечание

  • для аутентификации можно установить service_account_file с помощью переменной среды gcp_service_account_file.
  • для аутентификации можно установить service_account_contents с помощью переменной среды GCP_SERVICE_ACCOUNT_CONTENTS.
  • для аутентификации можно установить service_account_email с помощью переменной среды GCP_SERVICE_ACCOUNT_EMAIL.
  • для аутентификации можно установить auth_kind с помощью переменной среды GCP_AUTH_KIND.
  • для аутентификации можно установить scopes с помощью переменной среды GCP_SCOPES.
  • Значения переменных среды будут использованы только в том случае, если значения в книге задач не заданы.
  • Параметры service_account_email и service_account_file взаимоисключают друг друга.

Примеры

- name: get info on an image
  gcp_compute_image_info:
    filters:
    - name = test_object
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"

Возвращаемые значения

Общие возвращаемые значения описаны здесь, следующие поля уникальны для этого модуля:

Ключевые данные Возвращаемое значение Описание
resources
сложный тип
всегда
Список ресурсов

archiveSizeBytes
целое число
успех
Размер архива образа tar.gz, хранящегося в Google Cloud Storage (в байтах).

creationTimestamp
строка
успех
Отметка времени создания в формате RFC3339.

deprecated
сложный тип
успех
Статус устаревания, связанный с этим образом.

deleted
строка
успех
Необязательная отметка времени RFC3339, после которой состояние этого ресурса предполагается изменить на УДАЛЕН. Эта информация носит только справочный характер, и статус не изменится, пока клиент явно не изменит его.

deprecated
строка
успех
Необязательная отметка времени RFC3339, после которой состояние этого ресурса предполагается изменить на УСТАРЕЛ. Эта информация носит только справочный характер, и статус не изменится, пока клиент явно не изменит его.

obsolete
строка
успех
Необязательная отметка времени RFC3339, после которой состояние этого ресурса предполагается изменить на УСТАРЕВШИЙ. Эта информация носит только справочный характер, и статус не изменится, пока клиент явно не изменит его.

replacement
строка
успех
URL рекомендуемой замены для устаревшего ресурса.
Рекомендуемый заменяющий ресурс должен быть того же типа, что и устаревший ресурс.

state
строка
успех
Состояние устаревания этого ресурса. Может быть УСТАРЕЛ, УСТАРЕВШИЙ или УДАЛЕН. Операции, которые создают новый ресурс, используя устаревший ресурс, завершатся успешно, но с предупреждением, указывающим на устаревший ресурс и рекомендуя его замену. Операции, использующие устаревшие или удалённые ресурсы, будут отклонены и приведут к ошибке.

description
строка
успех
Необязательное описание этого ресурса. Укажите это свойство при создании ресурса.

diskSizeGb
целое число
успех
Размер образа при восстановлении на постоянный диск (в ГБ).

family
строка
успех
Имя семейства образов, к которому принадлежит этот образ. Вы можете создавать диски, указывая семейство образов вместо имени конкретного образа. Семейство образов всегда возвращает свой последний образ, который не устарел. Имя семейства образов должно соответствовать RFC1035.

guestOsFeatures
сложный тип
успех
Список функций для включения в гостевой операционной системе.
Применимо только для загружаемых образов.

type
строка
успех
Тип поддерживаемой функции.

id
целое число
успех
Уникальный идентификатор ресурса. Этот идентификатор определяется сервером.

imageEncryptionKey
сложный тип
успех
Шифрует образ с помощью предоставленного клиентом ключа шифрования.
После шифрования образа с помощью предоставленного клиентом ключа, вы должны предоставить тот же ключ, если вы используете образ позже (например, для создания диска из образа).

rawKey
строка
успех
Указывает 256-битный ключ шифрования, предоставленный клиентом, закодированный в base64 RFC 4648 для шифрования или расшифровки этого ресурса.

sha256
строка
успех
Закодированный в base64 RFC 4648 SHA-256 хеш предоставленного клиентом ключа шифрования, защищающего этот ресурс.

labelFingerprint
строка
успех
Отпечаток, используемый для оптимистической блокировки этого ресурса. Используется внутри при обновлениях.

labels
словарь
успех
Метки, применяемые к этому образу.

licenses
список / элементы=строка
успех
Любой соответствующий URI лицензии.

name
строка
успех
Имя ресурса; предоставляется клиентом при создании ресурса. Имя должно быть длиной от 1 до 63 символов и соответствовать RFC1035. Точнее, длина имени должна быть от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы должны быть тире, строчной буквой или цифрой, за исключением последнего символа, который не может быть тире.

rawDisk
сложный тип
успех
Параметры образа сырого диска.

containerType
строка
успех
Формат, используемый для кодирования и передачи блочного устройства, который должен быть TAR. Это просто контейнерный и передаточный формат, а не формат выполнения. Предоставляется клиентом при создании образа диска.

sha1Checksum
строка
успех
Необязательная SHA1 контрольная сумма образа диска перед распаковкой.
Это предоставляется клиентом при создании образа диска.

source
строка
успех
Полный URL Google Cloud Storage, где хранится хранилище диска. Вы должны предоставить либо это свойство, либо свойство sourceDisk, но не оба.

sourceDisk
словарь
успех
Источник диска для создания образа на основе него.
Вы должны предоставить либо это свойство, либо свойство rawDisk.source, но не оба, для создания образа.

sourceDiskEncryptionKey
сложный тип
успех
Ключ шифрования, предоставленный клиентом, для источника диска. Требуется, если источник диска защищен предоставленным клиентом ключом шифрования.

rawKey
строка
успех
Указывает 256-битный ключ шифрования, предоставленный клиентом, закодированный в base64 RFC 4648 для шифрования или расшифровки этого ресурса.

sha256
строка
успех
Закодированный в base64 RFC 4648 SHA-256 хеш предоставленного клиентом ключа шифрования, защищающего этот ресурс.

sourceDiskId
строка
успех
Значение идентификатора диска, использованного для создания этого образа. Это значение может быть использовано для определения, был ли образ взят с текущего или предыдущего экземпляра данного имени диска.

sourceImage
словарь
успех
URL источника образа, использованного для создания этого образа. Для создания образа необходимо предоставить полный или частичный URL одного из следующих: URL selfLink Это свойство URL rawDisk.source URL sourceDisk.

sourceSnapshot
словарь
успех
URL источника снимка, использованного для создания этого образа.
Для создания образа необходимо предоставить полный или частичный URL одного из следующих: URL selfLink Это свойство URL sourceImage URL rawDisk.source URL sourceDisk.

sourceType
строка
успех
Тип образа, использованного для создания этого диска. По умолчанию и единственное значение — RAW.



Авторы

  • Google Inc. (@googlecloudplatform)

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/google/cloud/gcp_compute_image_info_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API