google.cloud.gcp_compute_region_disk_info – Сбор информации о диске GCP RegionDisk
Примечание
Этот плагин входит в коллекцию google.cloud (версия 1.0.1).
Для его установки используйте: ansible-galaxy collection install google.cloud
Для использования в плейбуке укажите: google.cloud.gcp_compute_region_disk_info
Описание
- Сбор информации о диске GCP RegionDisk
Требования
Ниже перечислены требования, необходимые на хосте, на котором будет выполняться этот модуль.
- python >= 2.6
- requests >= 2.18.4
- google-auth >= 1.3.0
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| auth_kind строка / обязательно |
| Тип используемых учетных данных. |
| env_type строка | Указывает, в какой среде Ansible выполняется этот модуль. Не устанавливайте это значение, если вы не знаете, что делаете. Это изменяет только строку User Agent для любых запросов к API. | |
| filters список / элементы=строка | Список пар значений фильтров. Доступные фильтры перечислены здесь https://cloud.google.com/sdk/gcloud/reference/topic/filters. Каждый дополнительный фильтр в списке будет добавлен как условие И (filter1 и filter2). | |
| project строка | Проект Google Cloud Platform, который нужно использовать. | |
| region строка / обязательно | Ссылка на регион, в котором находится диск. | |
| scopes список / элементы=строка | Массив используемых областей | |
| service_account_contents jsonarg | Содержание файла JSON учетной записи службы, либо в словаре, либо в строке JSON, представляющей его. | |
| service_account_email строка | Дополнительный адрес электронной почты учетной записи службы, если выбран machineaccount, и пользователь не хочет использовать адрес по умолчанию. | |
| service_account_file путь | Путь к файлу JSON учетной записи службы, если тип выбран как serviceaccount. |
Примечания
Примечание
- для аутентификации можно установить service_account_file, используя переменную среды
gcp_service_account_file - для аутентификации можно установить service_account_contents, используя переменную среды
GCP_SERVICE_ACCOUNT_CONTENTS - для аутентификации можно установить service_account_email, используя переменную среды
GCP_SERVICE_ACCOUNT_EMAIL - для аутентификации можно установить auth_kind, используя переменную среды
GCP_AUTH_KIND - для аутентификации можно установить scopes, используя переменную среды
GCP_SCOPES - Значения переменных среды будут использоваться только в том случае, если значения плейбука не заданы.
- Параметры service_account_email и service_account_file взаимоисключающие.
Примеры
- name: get info on a region disk
gcp_compute_region_disk_info:
region: us-central1
filters:
- name = test_object
project: test_project
auth_kind: serviceaccount
service_account_file: "/tmp/auth.pem"
Возвращаемые значения
Общие возвращаемые значения документированы здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание | ||
|---|---|---|---|---|
| resources complex | всегда | Список ресурсов | ||
| creationTimestamp string | успех | Маркер создания в формате текста RFC3339. | ||
| description string | успех | Необязательное описание этого ресурса. Укажите это свойство при создании ресурса. | ||
| diskEncryptionKey complex | успех | Шифрует диск с помощью предоставленного пользователем ключа шифрования. После шифрования диска с предоставленным пользователем ключом, необходимо предоставить тот же ключ, если вы используете диск позже (например, для создания моментального снимка диска или образа, или для подключения диска к виртуальной машине). Ключи шифрования, предоставленные пользователем, не защищают доступ к метаданным диска. Если при создании диска вы не предоставите ключ шифрования, диск будет зашифрован с помощью автоматически сгенерированного ключа, и вам не нужно предоставлять ключ для использования диска позже. | ||
| rawKey string | успех | Указывает 256-битный ключ шифрования, предоставленный пользователем, закодированный в RFC 4648 base64 для шифрования или дешифрования этого ресурса. | ||
| sha256 string | успех | Закодированный в RFC 4648 base64 SHA-256 хэш ключа шифрования, предоставленного пользователем, который защищает этот ресурс. | ||
| id integer | успех | Уникальный идентификатор ресурса. | ||
| labelFingerprint string | успех | Отпечаток, используемый для оптимистической блокировки этого ресурса. Используется в ходе внутренних обновлений. | ||
| labels dictionary | успех | Метки для применения к этому диску. Список пар ключ-значение. | ||
| lastAttachTimestamp string | успех | Последняя метка времени подключения в формате текста RFC3339. | ||
| lastDetachTimestamp string | успех | Последняя метка времени отсоединения в формате текста RFC3339. | ||
| licenses list / elements=string | успех | Все применимые общедоступные лицензии. | ||
| name string | успех | Имя ресурса. Предоставляется клиентом при создании ресурса. Имя должно быть длиной от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно быть длиной от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы должны быть тире, строчной буквой или цифрой, за исключением последнего символа, который не может быть тире. | ||
| physicalBlockSizeBytes integer | успех | Физический размер блока постоянного диска в байтах. Если не указано в запросе, используется значение по умолчанию. В настоящее время поддерживаются размеры 4096 и 16384, в будущем могут быть добавлены другие размеры. Если запрашивается недопустимое значение, сообщение об ошибке укажет поддерживаемые значения для проекта вызывающего. | ||
| region string | успех | Ссылка на регион, в котором находится диск. | ||
| replicaZones list / elements=string | успех | URL-адреса зон, в которые должен быть реплицирован диск. | ||
| sizeGb integer | успех | Размер постоянного диска, указанный в ГБ. Вы можете указать это поле при создании постоянного диска, используя параметр sourceImage или sourceSnapshot, или указать его отдельно для создания пустого постоянного диска. Если вы указываете это поле вместе с sourceImage или sourceSnapshot, значение sizeGb не должно быть меньше размера sourceImage или размера снимка. | ||
| sourceSnapshot dictionary | успех | Используемый исходный снимок для создания этого диска. Вы можете указать его как частичный или полный URL-адрес ресурса. | ||
| sourceSnapshotEncryptionKey complex | успех | Ключ шифрования, предоставленный пользователем, для исходного снимка. Требуется, если исходный снимок защищен ключом шифрования, предоставленным пользователем. | ||
| rawKey string | успех | Указывает 256-битный ключ шифрования, предоставленный пользователем, закодированный в RFC 4648 base64 для шифрования или дешифрования этого ресурса. | ||
| sha256 string | успех | Закодированный в RFC 4648 base64 SHA-256 хэш ключа шифрования, предоставленного пользователем, который защищает этот ресурс. | ||
| sourceSnapshotId string | успех | Уникальный идентификатор снимка, используемого для создания этого диска. Это значение идентифицирует точный снимок, который использовался для создания этого постоянного диска. Например, если вы создали постоянный диск из снимка, который был позже удален и пересоздан под тем же именем, идентификатор исходного снимка будет идентифицировать точную версию снимка, которая была использована. | ||
| type string | успех | URL ресурса типа диска, описывающего тип диска, который следует использовать для создания диска. Укажите это при создании диска. | ||
| users list / elements=string | успех | Ссылки на пользователей диска (подключенные виртуальные машины) в формате: project/zones/zone/instances/instance. | ||
Авторы
- Google Inc. (@googlecloudplatform)
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/google/cloud/gcp_compute_region_disk_info_module.html