Spec-Zone.ru › Ansible 2.10

google.cloud.gcp_compute_router_info – Сбор информации о маршрутизаторе GCP

Примечание

Этот плагин входит в коллекцию google.cloud (версия 1.0.1).

Для его установки используйте: ansible-galaxy collection install google.cloud.

Для использования в книге задач укажите: google.cloud.gcp_compute_router_info.

  • Обзор
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Обзор

  • Сбор информации о маршрутизаторе GCP

Требования

Ниже приведены требования, необходимые на хосте, на котором выполняется этот модуль.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
auth_kind
строка / обязательно
    Варианты:
  • application
  • machineaccount
  • serviceaccount
Тип используемых учетных данных.
env_type
строка
Указывает, в какой среде Ansible выполняется этот модуль.
Это не следует устанавливать, если вы не знаете, что делаете.
Это изменяет только строку User Agent для всех запросов API.
filters
список / элементы=строка
Список пар значений фильтров. Доступные фильтры перечислены здесь https://cloud.google.com/sdk/gcloud/reference/topic/filters.
Каждый дополнительный фильтр в списке будет добавлен как условие И (filter1 и filter2).
project
строка
Проект Google Cloud Platform, который нужно использовать.
region
строка / обязательно
Регион, в котором находится маршрутизатор.
scopes
список / элементы=строка
Массив используемых областей
service_account_contents
jsonarg
Содержимое файла JSON учетной записи службы, либо в виде словаря, либо как строка JSON, представляющая его.
service_account_email
строка
Дополнительный адрес электронной почты учетной записи службы, если выбран machineaccount и пользователь не хочет использовать адрес по умолчанию.
service_account_file
путь
Путь к файлу JSON учетной записи службы, если выбран тип serviceaccount.

Примечания

Примечание

  • для аутентификации можно установить service_account_file с помощью переменной среды gcp_service_account_file.
  • для аутентификации можно установить service_account_contents с помощью переменной среды GCP_SERVICE_ACCOUNT_CONTENTS.
  • для аутентификации можно установить service_account_email с помощью переменной среды GCP_SERVICE_ACCOUNT_EMAIL.
  • для аутентификации можно установить auth_kind с помощью переменной среды GCP_AUTH_KIND.
  • для аутентификации можно установить scopes с помощью переменной среды GCP_SCOPES.
  • Значения переменных среды будут использоваться только в том случае, если значения в книге задач не заданы.
  • Параметры service_account_email и service_account_file взаимоисключающие.

Примеры

- name: get info on a router
  gcp_compute_router_info:
    region: us-central1
    filters:
    - name = test_object
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"

Возвращаемые значения

Общие возвращаемые значения документированы здесь, следующие поля уникальны для данного модуля:

Ключ Возвращаемое Описание
resources
сложный
всегда
Список ресурсов

bgp
сложный
успех
Информация о BGP, специфичная для данного маршрутизатора.

advertisedGroups
список / элементы=строка
успех
Указанный пользователем список групп префиксов для рекламы в пользовательском режиме.
Это поле может быть заполнено только в том случае, если advertiseMode равен CUSTOM и рекламируется всем peer-маршрутизаторам. Эти группы будут рекламироваться дополнительно к указанным префиксам. Оставьте это поле пустым, чтобы не рекламировать никаких пользовательских групп.
Это поле перечисления имеет одно допустимое значение: ALL_SUBNETS .

advertisedIpRanges
сложный
успех
Указанный пользователем список отдельных диапазонов IP-адресов для рекламы в пользовательском режиме. Это поле может быть заполнено только в том случае, если advertiseMode равен CUSTOM и рекламируется всем peer-маршрутизаторам. Эти диапазоны IP-адресов будут рекламироваться дополнительно к указанным группам.
Оставьте это поле пустым, чтобы не рекламировать никаких пользовательских диапазонов IP-адресов.

description
строка
успех
Указанное пользователем описание диапазона IP-адресов.

range
строка
успех
Диапазон IP-адресов для рекламы. Значение должно быть строкой в формате CIDR.

advertiseMode
строка
успех
Указанный пользователем флаг, указывающий, какой режим использовать для рекламы.

asn
целое число
успех
Локальный номер автономной системы BGP (ASN). Должен быть частным ASN RFC6996, либо 16-разрядным, либо 32-разрядным. Значение будет фиксированным для этого ресурса маршрутизатора. Все VPN-туннели, которые подключаются к этому маршрутизатору, будут иметь тот же локальный ASN.

creationTimestamp
строка
успех
Дата и время создания в формате RFC3339.

description
строка
успех
Дополнительное описание этого ресурса.

id
целое число
успех
Уникальный идентификатор ресурса.

name
строка
успех
Имя ресурса. Длина имени должна составлять от 1 до 63 символов и соответствовать RFC1035. В частности, длина имени должна составлять от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом.

network
словарь
успех
Ссылка на сеть, к которой принадлежит этот маршрутизатор.

region
строка
успех
Регион, в котором находится маршрутизатор.



Авторы

  • Google Inc. (@googlecloudplatform)

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/google/cloud/gcp_compute_router_info_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API