Spec-Zone.ru › Ansible 2.10

google.cloud.gcp_compute_router – Создаёт маршрутизатор GCP

Примечание

Этот плагин входит в коллекцию google.cloud (версия 1.0.1).

Для его установки используйте: ansible-galaxy collection install google.cloud.

Чтобы использовать его в книге задач, укажите: google.cloud.gcp_compute_router.

  • Описание
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Описание

  • Представляет ресурс маршрутизатора.

Требования

Ниже перечислены требования к хосту, на котором будет выполняться этот модуль.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
auth_kind
строка / обязательно
    Варианты:
  • application
  • machineaccount
  • serviceaccount
Тип используемых учетных данных.
bgp
словарь
Информация BGP, специфичная для данного маршрутизатора.
advertise_mode
строка
Значение по умолчанию:
"DEFAULT"
Указанный пользователем флаг, указывающий режим использования для рекламы.
Некоторые допустимые значения: "DEFAULT", "CUSTOM"
advertised_groups
список / элементы=строка
Указанный пользователем список групп префиксов для рекламы в режиме custom.
Это поле может быть заполнено только в случае, если advertiseMode = CUSTOM и рекламируется всем узлам маршрутизатора. Эти группы будут рекламироваться помимо любых указанных префиксов. Оставьте это поле пустым, чтобы не рекламировать никакие группы custom.
Это поле имеет одно допустимое значение: ALL_SUBNETS.
advertised_ip_ranges
список / элементы=словарь
Указанный пользователем список отдельных IP-диапазонов для рекламы в режиме custom. Это поле может быть заполнено только в случае, если advertiseMode = CUSTOM и рекламируется всем узлам маршрутизатора. Эти IP-диапазоны будут рекламироваться помимо любых указанных групп.
Оставьте это поле пустым, чтобы не рекламировать никакие custom IP-диапазоны.
description
строка
Указанное пользователем описание для IP-диапазона.
range
строка / обязательно
IP-диапазон для рекламы. Значение должно быть строкой в формате CIDR.
asn
целое число / обязательно
Локальный номер автономной системы BGP (ASN). Должен быть частным ASN в соответствии с RFC6996, либо 16-разрядным, либо 32-разрядным. Значение будет фиксироваться для этого ресурса маршрутизатора. Все VPN-туннели, подключенные к этому маршрутизатору, будут иметь одинаковый локальный ASN.
description
строка
Необязательное описание данного ресурса.
env_type
строка
Указывает, в какой среде Ansible выполняется этот модуль.
Это поле следует устанавливать только в том случае, если вы знаете, что делаете.
Это поле изменяет только строку User-Agent для любых запросов к API.
name
строка / обязательно
Имя ресурса. Длина имени должна составлять 1–63 символа и соответствовать RFC1035. То есть, имя должно содержать 1–63 символа и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом.
network
словарь / обязательно
Ссылка на сеть, к которой принадлежит этот маршрутизатор.
Это поле представляет ссылку на ресурс сети GCP. Его можно указать двумя способами. Во-первых, вы можете поместить словарь с ключом 'selfLink' и значением selfLink вашего ресурса. Во-вторых, вы можете добавить `register: имя-ресурса` к задаче gcp_compute_network, а затем установить это поле network в "{{ имя-ресурса }}"
project
строка
Проект Google Cloud Platform, который использовать.
region
строка / обязательно
Регион, в котором находится маршрутизатор.
scopes
список / элементы=строка
Массив используемых областей видимости
service_account_contents
jsonarg
Содержимое файла JSON учетной записи сервиса, либо в виде словаря, либо в виде JSON-строки, представляющей его.
service_account_email
строка
Необязательный адрес электронной почты учетной записи сервиса, если выбрано machineaccount и пользователь не хочет использовать адрес по умолчанию.
service_account_file
путь
Путь к файлу JSON учетной записи сервиса, если в качестве типа выбран serviceaccount.
state
строка
    Варианты:
  • present ←
  • absent
Необходимо ли наличие данного объекта в GCP

Примечания

Примечание

  • Ссылка на API: https://cloud.google.com/compute/docs/reference/rest/v1/routers
  • Маршрутизатор Google Cloud: https://cloud.google.com/router/docs/
  • для проверки подлинности можно установить service_account_file, используя переменную среды gcp_service_account_file.
  • для проверки подлинности можно установить service_account_contents, используя переменную среды GCP_SERVICE_ACCOUNT_CONTENTS.
  • Для проверки подлинности можно установить service_account_email, используя переменную среды GCP_SERVICE_ACCOUNT_EMAIL.
  • Для проверки подлинности можно установить auth_kind, используя переменную среды GCP_AUTH_KIND.
  • Для проверки подлинности можно установить scopes, используя переменную среды GCP_SCOPES.
  • Значения переменных среды будут использоваться только в том случае, если значения в книге задач не заданы.
  • Параметры service_account_email и service_account_file взаимоисключающие.

Примеры

- name: create a network
  google.cloud.gcp_compute_network:
    name: network-router
    project: "{{ gcp_project }}"
    auth_kind: "{{ gcp_cred_kind }}"
    service_account_file: "{{ gcp_cred_file }}"
    state: present
  register: network

- name: create a router
  google.cloud.gcp_compute_router:
    name: test_object
    network: "{{ network }}"
    bgp:
      asn: 64514
      advertise_mode: CUSTOM
      advertised_groups:
      - ALL_SUBNETS
      advertised_ip_ranges:
      - range: 1.2.3.4
      - range: 6.7.0.0/16
    region: us-central1
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"
    state: present

Возвращаемые значения

Общие возвращаемые значения описаны в этом разделе, следующие поля уникальны для данного модуля:

Ключ Возвращаемое значение Описание
bgp
сложный
успех
Информация о BGP, специфичная для этого маршрутизатора.

advertisedGroups
список / элементы=строка
успех
Указанный пользователем список групп префиксов для рекламы в пользовательском режиме.
Это поле может быть заполнено только в том случае, если advertiseMode имеет значение CUSTOM и передается всем peer-маршрутизаторам. Эти группы будут рекламироваться дополнительно к любым указанным префиксам. Оставьте это поле пустым, чтобы не рекламировать пользовательские группы.
Это поле перечисления имеет одно допустимое значение: ALL_SUBNETS.

advertisedIpRanges
сложный
успех
Указанный пользователем список отдельных диапазонов IP-адресов для рекламы в пользовательском режиме. Это поле может быть заполнено только в том случае, если advertiseMode имеет значение CUSTOM и передается всем peer-маршрутизаторам. Эти диапазоны IP-адресов будут рекламироваться дополнительно к любым указанным группам.
Оставьте это поле пустым, чтобы не рекламировать пользовательские диапазоны IP-адресов.

description
строка
успех
Указанное пользователем описание диапазона IP-адресов.

range
строка
успех
Диапазон IP-адресов для рекламы. Значение должно быть строкой в формате CIDR.

advertiseMode
строка
успех
Указанный пользователем флаг, указывающий режим рекламы.

asn
целое число
успех
Локальный номер автономной системы BGP (ASN). Должен быть частным ASN RFC6996, 16-разрядным или 32-разрядным. Значение будет фиксированным для этого ресурса маршрутизатора. Все VPN-туннели, подключенные к этому маршрутизатору, будут иметь тот же локальный ASN.

creationTimestamp
строка
успех
Маркер времени создания в формате RFC3339.

description
строка
успех
Необязательное описание этого ресурса.

id
целое число
успех
Уникальный идентификатор ресурса.

name
строка
успех
Имя ресурса. Длина имени должна составлять от 1 до 63 символов и соответствовать RFC1035. В частности, имя должно иметь длину от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы должны быть дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом.

network
словарь
успех
Ссылка на сеть, к которой принадлежит этот маршрутизатор.

region
строка
успех
Регион, в котором находится маршрутизатор.



Авторы

  • Google Inc. (@googlecloudplatform)

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/google/cloud/gcp_compute_router_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API