Spec-Zone.ru › Ansible 2.10

google.cloud.gcp_compute_snapshot_info – Сбор информации о снимке GCP

Примечание

Этот плагин входит в коллекцию google.cloud (версия 1.0.1).

Для его установки используйте: ansible-galaxy collection install google.cloud.

Для использования в книге задач укажите: google.cloud.gcp_compute_snapshot_info.

  • Обзор
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Обзор

  • Сбор информации о снимке GCP

Требования

Ниже перечислены требования, необходимые на хосте, на котором выполняется этот модуль.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
auth_kind
строка / обязательно
    Варианты:
  • application
  • machineaccount
  • serviceaccount
Тип используемых учетных данных.
env_type
строка
Указывает, в какой среде Ansible выполняется этот модуль.
Это поле не должно устанавливаться, если вы не знаете, что делаете.
Это изменяет только строку User Agent для всех запросов API.
filters
список / элементы=строка
Список пар значений фильтров. Доступные фильтры перечислены здесь https://cloud.google.com/sdk/gcloud/reference/topic/filters.
Каждый дополнительный фильтр в списке будет добавлен как условие И (filter1 и filter2).
project
строка
Проект Google Cloud Platform, который нужно использовать.
scopes
список / элементы=строка
Массив используемых областей
service_account_contents
jsonarg
Содержимое файла JSON учетной записи службы, представленное в виде словаря или JSON-строки.
service_account_email
строка
Дополнительный адрес электронной почты учетной записи службы, если выбран machineaccount, и пользователь не хочет использовать адрес по умолчанию.
service_account_file
путь
Путь к файлу JSON учетной записи службы, если в качестве типа выбран serviceaccount.

Примечания

Примечание

  • Для аутентификации можно установить service_account_file с помощью переменной среды gcp_service_account_file.
  • Для аутентификации можно установить service_account_contents с помощью переменной среды GCP_SERVICE_ACCOUNT_CONTENTS.
  • Для аутентификации можно установить service_account_email с помощью переменной среды GCP_SERVICE_ACCOUNT_EMAIL.
  • Для аутентификации можно установить auth_kind с помощью переменной среды GCP_AUTH_KIND.
  • Для аутентификации можно установить scopes с помощью переменной среды GCP_SCOPES.
  • Значения переменных среды будут использованы только в том случае, если значения в книге задач не заданы.
  • Параметры service_account_email и service_account_file взаимоисключающие.

Примеры

- name: get info on a snapshot
  gcp_compute_snapshot_info:
    filters:
    - name = test_object
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"

Возвращаемые значения

Общие возвращаемые значения описаны в этом разделе, ниже приведены поля, уникальные для этого модуля:

Ключ Возвращаемое Описание
resources
сложный
всегда
Список ресурсов

creationTimestamp
строка
успех
Дата и время создания в формате RFC3339.

description
строка
успех
Необязательное описание этого ресурса.

diskSizeGb
целое число
успех
Размер снимка в ГБ.

id
целое число
успех
Уникальный идентификатор ресурса.

labelFingerprint
строка
успех
Отпечаток, используемый для оптимистической блокировки этого ресурса. Используется в процессе обновлений.

labels
словарь
успех
Метки, применяемые к этому снимку.

licenses
список / элементы=строка
успех
Список общедоступных лицензий, применимых к этому снимку. Это может быть из-за того, что к исходному изображению были прикреплены лицензии (например, изображение Windows). объект snapshotEncryptionKey Шифрует снимок с помощью предоставленного пользователем ключа шифрования.

name
строка
успех
Имя ресурса, предоставленное клиентом при создании ресурса. Длина имени должна составлять от 1 до 63 символов и соответствовать RFC1035. То есть имя должно иметь длину от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы должны быть дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом.

snapshotEncryptionKey
сложный
успех
Ключ шифрования, предоставленный пользователем, для снимка. Требуется, если исходный снимок защищен ключом шифрования, предоставленным пользователем.

kmsKeyName
строка
успех
Имя ключа шифрования, хранящегося в Google Cloud KMS.

kmsKeyServiceAccount
строка
успех
Учетная запись службы, используемая для запроса шифрования для данного ключа KMS.
Если отсутствует, используется служба агента Compute Engine.

rawKey
строка
успех
Указывает 256-битный ключ шифрования, предоставленный пользователем, закодированный в RFC 4648 base64 для шифрования или расшифровки этого ресурса.

sha256
строка
успех
RFC 4648 base64 закодированный SHA-256 хэш ключа шифрования, предоставленного пользователем, защищающего этот ресурс.

sourceDisk
словарь
успех
Ссылка на диск, используемый для создания снимка.

sourceDiskEncryptionKey
сложный
успех
Ключ шифрования, предоставленный пользователем, для исходного снимка. Требуется, если исходный снимок защищен ключом шифрования, предоставленным пользователем.

kmsKeyName
строка
успех
Имя ключа шифрования, хранящегося в Google Cloud KMS.

kmsKeyServiceAccount
строка
успех
Учетная запись службы, используемая для запроса шифрования для данного ключа KMS.
Если отсутствует, используется служба агента Compute Engine.

rawKey
строка
успех
Указывает 256-битный ключ шифрования, предоставленный пользователем, закодированный в RFC 4648 base64 для шифрования или расшифровки этого ресурса.

storageBytes
целое число
успех
Размер используемого хранилища снимка. Поскольку снимки используют общее хранилище, ожидается, что это число будет изменяться при создании/удалении снимка.

storageLocations
список / элементы=строка
успех
Расположение хранилища Cloud Storage снимка (региональное или многорегиональное).

zone
строка
успех
Ссылка на зону размещения диска.



Авторы

  • Google Inc. (@googlecloudplatform)

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/google/cloud/gcp_compute_snapshot_info_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API