Spec-Zone.ru › Ansible 2.10

google.cloud.gcp_compute_snapshot – Создаёт снимок GCP

Примечание

Этот плагин входит в коллекцию google.cloud (версия 1.0.1).

Для установки используйте: ansible-galaxy collection install google.cloud.

Для использования в плейбуке укажите: google.cloud.gcp_compute_snapshot.

  • Описание
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Значения возврата

Описание

  • Представляет ресурс снимка диска постоянного хранения.
  • Используйте снимки для резервного копирования данных с дисков постоянного хранения. Снимки отличаются от общедоступных и пользовательских образов, которые в основном используются для создания виртуальных машин или настройки шаблонов виртуальных машин. Снимки полезны для периодического резервного копирования данных на дисках постоянного хранения. Вы можете создавать снимки с дисков постоянного хранения, даже если они подключены к работающим виртуальным машинам.
  • Снимки являются инкрементными, поэтому вы можете создавать регулярные снимки на диске постоянного хранения быстрее и с значительно меньшими затратами, чем если бы вы регулярно создавали полный образ диска.

Требования

Ниже перечислены требования, необходимые на узле, на котором выполняется данный модуль.

  • python >= 2.6
  • requests >= 2.18.4
  • google-auth >= 1.3.0

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
auth_kind
строка / обязательно
    Варианты:
  • application
  • machineaccount
  • serviceaccount
Тип используемых учетных данных.
description
строка
Необязательное описание данного ресурса.
env_type
строка
Указывает, в какой среде Ansible выполняется данный модуль.
Это следует устанавливать только в том случае, если вы знаете, что делаете.
Это изменяет только строку User Agent для всех запросов к API.
labels
словарь
Метки для применения к этому снимку.
name
строка / обязательно
Имя ресурса, предоставленное клиентом при создании ресурса. Имя должно быть длиной от 1 до 63 символов и соответствовать RFC1035. То есть имя должно быть длиной от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы — дефисом, строчной буквой или цифрой, за исключением последнего символа, который не может быть дефисом.
project
строка
Проект Google Cloud Platform, который следует использовать.
scopes
список / элементы=строка
Массив областей, которые следует использовать.
service_account_contents
jsonarg
Содержимое файла JSON учетной записи службы, либо в словаре, либо в виде JSON-строки, которая его представляет.
service_account_email
строка
Необязательный адрес электронной почты учетной записи службы, если выбран machineaccount, и пользователь не хочет использовать адрес по умолчанию.
service_account_file
путь
Путь к файлу JSON учетной записи службы, если в качестве типа выбран serviceaccount.
snapshot_encryption_key
словарь
Ключ шифрования, предоставленный клиентом, для снимка. Требуется, если исходный снимок защищен ключом шифрования, предоставленным клиентом.
kms_key_name
строка
Имя ключа шифрования, хранящегося в Google Cloud KMS.
kms_key_service_account
строка
Учетная запись службы, используемая для запроса шифрования для данного ключа KMS.
Если отсутствует, используется служба учетной записи агента Compute Engine.
raw_key
строка
Указывает 256-битный ключ шифрования, предоставленный клиентом, закодированный в base64 RFC 4648, для шифрования или дешифрования этого ресурса.
source_disk
словарь / обязательно
Ссылка на диск, используемый для создания снимка.
Это поле представляет ссылку на ресурс диска в GCP. Его можно указать двумя способами. Во-первых, можно поместить словарь с ключом 'name' и значением имени вашего ресурса. Во-вторых, можно добавить `register: name-of-resource` к задаче gcp_compute_disk, а затем установить это поле source_disk в "{{ name-of-resource }}"
source_disk_encryption_key
словарь
Ключ шифрования, предоставленный клиентом, для исходного снимка. Требуется, если исходный снимок защищен ключом шифрования, предоставленным клиентом.
kms_key_name
строка
Имя ключа шифрования, хранящегося в Google Cloud KMS.
kms_key_service_account
строка
Учетная запись службы, используемая для запроса шифрования для данного ключа KMS.
Если отсутствует, используется служба учетной записи агента Compute Engine.
raw_key
строка
Указывает 256-битный ключ шифрования, предоставленный клиентом, закодированный в base64 RFC 4648, для шифрования или дешифрования этого ресурса.
state
строка
    Варианты:
  • present ←
  • absent
Требуется ли существование данного объекта в GCP
storage_locations
список / элементы=строка
Расположение хранилища Cloud Storage снимка (региональное или многорегиональное).
zone
строка
Ссылка на зону, в которой размещен диск.

Примечания

Примечание

  • Ссылка на API: https://cloud.google.com/compute/docs/reference/rest/v1/snapshots
  • Официальная документация: https://cloud.google.com/compute/docs/disks/create-snapshots
  • для проверки подлинности можно установить service_account_file с помощью переменной среды gcp_service_account_file.
  • для проверки подлинности можно установить service_account_contents с помощью переменной среды GCP_SERVICE_ACCOUNT_CONTENTS.
  • для проверки подлинности можно установить service_account_email с помощью переменной среды GCP_SERVICE_ACCOUNT_EMAIL.
  • для проверки подлинности можно установить auth_kind с помощью переменной среды GCP_AUTH_KIND.
  • для проверки подлинности можно установить scopes с помощью переменной среды GCP_SCOPES.
  • Значения переменных среды будут использоваться только в том случае, если значения в плейбуке не заданы.
  • Параметры service_account_email и service_account_file взаимоисключающие.

Примеры

- name: create a disk
  google.cloud.gcp_compute_disk:
    name: disk-snapshot
    zone: us-central1-a
    project: "{{ gcp_project }}"
    auth_kind: "{{ gcp_cred_kind }}"
    service_account_file: "{{ gcp_cred_file }}"
    state: present
  register: disk

- name: create a snapshot
  google.cloud.gcp_compute_snapshot:
    name: test_object
    source_disk: "{{ disk }}"
    zone: us-central1-a
    labels:
      my_label: value
    project: test_project
    auth_kind: serviceaccount
    service_account_file: "/tmp/auth.pem"
    state: present

Значения возврата

Общие значения возврата описаны в этом разделе, следующие поля уникальны для данного модуля:

Ключ Результат Описание
creationTimestamp
string
успех
Марка времени создания в формате RFC3339.

description
string
успех
Необязательное описание данного ресурса.

diskSizeGb
integer
успех
Размер снимка в ГБ.

id
integer
успех
Уникальный идентификатор ресурса.

labelFingerprint
string
успех
Отпечаток метки, используемый для оптимистической блокировки этого ресурса. Используется во внутренних обновлениях.

labels
dictionary
успех
Метки для применения к этому снимку.

licenses
list / elements=string
успех
Список общедоступных лицензий, применимых к этому снимку. Это может быть из-за того, что к исходному изображению были прикреплены лицензии (например, изображение Windows). Вложенный объект snapshotEncryptionKey Шифрует снимок с использованием предоставленного клиентом ключа шифрования.

name
string
успех
Имя ресурса; предоставляется клиентом при создании ресурса. Имя должно быть длиной от 1 до 63 символов и соответствовать RFC1035. Точнее, имя должно быть длиной от 1 до 63 символов и соответствовать регулярному выражению `[a-z]([-a-z0-9]*[a-z0-9])?`, что означает, что первый символ должен быть строчной буквой, а все последующие символы должны быть тире, строчной буквой или цифрой, за исключением последнего символа, который не может быть тире.

snapshotEncryptionKey
complex
успех
Ключ шифрования, предоставленный клиентом, для снимка. Требуется, если исходный снимок защищен ключом шифрования, предоставленным клиентом.

kmsKeyName
string
успех
Имя ключа шифрования, хранящегося в Google Cloud KMS.

kmsKeyServiceAccount
string
успех
Учетная запись сервиса, используемая для запроса шифрования для данного ключа KMS.
Если отсутствует, используется учетная запись сервисного агента Compute Engine.

rawKey
string
успех
Указывает 256-битный ключ шифрования, предоставленный клиентом, закодированный в RFC 4648 base64 для шифрования или дешифрования этого ресурса.

sha256
string
успех
Закодированный в RFC 4648 base64 SHA-256 хэш ключа шифрования, предоставленного клиентом, который защищает этот ресурс.

sourceDisk
dictionary
успех
Ссылка на диск, используемый для создания этого снимка.

sourceDiskEncryptionKey
complex
успех
Ключ шифрования, предоставленный клиентом, для исходного снимка. Требуется, если исходный снимок защищен ключом шифрования, предоставленным клиентом.

kmsKeyName
string
успех
Имя ключа шифрования, хранящегося в Google Cloud KMS.

kmsKeyServiceAccount
string
успех
Учетная запись сервиса, используемая для запроса шифрования для данного ключа KMS.
Если отсутствует, используется учетная запись сервисного агента Compute Engine.

rawKey
string
успех
Указывает 256-битный ключ шифрования, предоставленный клиентом, закодированный в RFC 4648 base64 для шифрования или дешифрования этого ресурса.

storageBytes
integer
успех
Размер хранилища, используемого снимком. Поскольку снимки используют совместное хранилище, это значение ожидается, что оно изменится при создании/удалении снимка.

storageLocations
list / elements=string
успех
Расположение хранилища облачного хранилища Google Cloud Storage для снимка (региональное или мультитегиональное).

zone
string
успех
Ссылка на зону, в которой размещен диск.



Авторы

  • Google Inc. (@googlecloudplatform)

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.10/collections/google/cloud/gcp_compute_snapshot_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API