cisco.aci.aci_config_rollback – Предоставляет функциональность отката и предварительного просмотра отката (config:ImportP)
Примечание
Этот плагин входит в коллекцию cisco.aci (версия 2.0.0).
Для его установки используйте: ansible-galaxy collection install cisco.aci.
Чтобы использовать его в playbook, укажите: cisco.aci.aci_config_rollback.
Обзор
- Предоставляет функциональность отката и предварительного просмотра отката для Cisco ACI fabric.
- Откаты конфигурации выполняются с использованием снимков
aci_snapshotс классом configImportP.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| annotation строка | Пользовательская строка для аннотирования объекта. Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_ANNOTATION. | |
| certificate_name строка | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если был предоставлен файл с именем private_key, по умолчанию используется имя файла private_key, без расширения.Если для private_key было предоставлено содержимое в формате PEM, по умолчанию используется значение username. Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_CERTIFICATE_NAME.псевдонимы: cert_name | |
| compare_export_policy строка | Политика экспорта, к которой compare_snapshot привязана. | |
| compare_snapshot строка | Имя снимка для сравнения с snapshot. | |
| description строка | Описание политики импорта. псевдонимы: descr | |
| export_policy строка | Политика экспорта, к которой snapshot привязана. | |
| fail_on_decrypt булево |
| Определяет, должен ли APIC прервать откат, если не удается расшифровать защищенные данные. APIC по умолчанию устанавливает значение yes, если оно не задано. |
| host строка / обязательно | IP-адрес или имя хоста APIC, разрешаемый хостом Ansible. Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_HOST.псевдонимы: hostname | |
| import_mode строка |
| Определяет, как APIC должен обработать импорт. APIC по умолчанию устанавливает значение atomic, если оно не задано. |
| import_policy строка | Имя политики импорта, используемой для отката конфигурации. | |
| import_type строка |
| Определяет, как текущая и cнимок конфигурации должны сравниваться для замены. APIC по умолчанию устанавливает значение replace, если оно не задано. |
| output_level строка |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current dictinfo добавляет информационный вывод, включая previous, proposed и sent dictsdebug добавляет вывод отладки, включая filter_string, method, response, status и url информациюЕсли значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_OUTPUT_LEVEL. |
| output_path строка | Путь к файлу, который будет использован для выгрузки объектов конфигурации ACI JSON, сгенерированных модулем. Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_OUTPUT_PATH. | |
| owner_key строка | Пользовательская строка для атрибута ownerKey объекта ACI. Этот атрибут представляет ключ, позволяющий клиентам владеть своими данными для корреляции сущностей. Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_OWNER_KEY. | |
| owner_tag строка | Пользовательская строка для атрибута ownerTag объекта ACI. Этот атрибут представляет тег, позволяющий клиентам добавлять свои собственные данные. Например, для указания того, кто создал этот объект. Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_OWNER_TAG. | |
| password строка | Пароль для аутентификации. Этот параметр исключает private_key. Если private_key также предоставлен, он будет использован вместо него.Если значение не указано в задаче, вместо него будут использованы переменные окружения ACI_PASSWORD или ANSIBLE_NET_PASSWORD. | |
| port целое число | Номер порта для подключения REST. Значение по умолчанию зависит от параметра use_ssl.Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_PORT. | |
| private_key строка | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемое для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name, которое используется.Этот параметр исключает password. Если password также предоставлен, он будет проигнорирован.Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_PRIVATE_KEY.псевдонимы: cert_key | |
| snapshot строка / обязательно | Имя снимка для отката или базовый снимок для сравнения. Модуль aci_snapshot может использоваться для запроса списка доступных снимков. | |
| state строка |
| Используйте preview для предварительного просмотра различий между двумя снимками.Используйте rollback для возврата конфигурации к предыдущему снимку. |
| timeout целое число | Значение по умолчанию: 30 | Таймаут уровня сокета в секундах. Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_TIMEOUT. |
| use_proxy булево |
| Если no, прокси не будет использоваться, даже если он определен в переменной окружения на целевых хостах.Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_USE_PROXY. |
| use_ssl булево |
| Если no, вместо стандартного подключения HTTPS будет использовано HTTP-соединение.Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_USE_SSL. |
| username строка | Значение по умолчанию: "admin" | Имя пользователя для аутентификации. Если значение не указано в задаче, вместо него будут использованы переменные окружения ACI_USERNAME или ANSIBLE_NET_USERNAME.псевдонимы: user |
| validate_certs булево |
| Если no, сертификаты SSL не будут проверяться.Это следует установить только на no при работе с сайтами, контролируемыми лично, использующими самоподписанные сертификаты.Если значение не указано в задаче, вместо него будет использовано значение переменной окружения ACI_VALIDATE_CERTS. |
См. также
См. также
- cisco.aci.aci_config_snapshot
-
Официальная документация по модулю cisco.aci.aci_config_snapshot.
- APIC Management Information Model reference
-
Дополнительная информация о внутреннем классе APIC config:ImportP.
- Руководство по Cisco ACI
-
Подробная информация о том, как управлять инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
-
Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
---
- name: Create a Snapshot
cisco.aci.aci_config_snapshot:
host: apic
username: admin
password: SomeSecretPassword
export_policy: config_backup
state: present
delegate_to: localhost
- name: Query Existing Snapshots
cisco.aci.aci_config_snapshot:
host: apic
username: admin
password: SomeSecretPassword
export_policy: config_backup
state: query
delegate_to: localhost
- name: Compare Snapshot Files
cisco.aci.aci_config_rollback:
host: apic
username: admin
password: SomeSecretPassword
export_policy: config_backup
snapshot: run-2017-08-28T06-24-01
compare_export_policy: config_backup
compare_snapshot: run-2017-08-27T23-43-56
state: preview
delegate_to: localhost
- name: Rollback Configuration
cisco.aci.aci_config_rollback:
host: apic
username: admin
password: SomeSecretPassword
import_policy: rollback_config
export_policy: config_backup
snapshot: run-2017-08-28T06-24-01
state: rollback
delegate_to: localhost
- name: Rollback Configuration
cisco.aci.aci_config_rollback:
host: apic
username: admin
password: SomeSecretPassword
import_policy: rollback_config
export_policy: config_backup
snapshot: run-2017-08-28T06-24-01
description: Rollback 8-27 changes
import_mode: atomic
import_type: replace
fail_on_decrypt: yes
state: rollback
delegate_to: localhost
Значения возврата
Общие значения возврата описаны здесь, ниже приведены поля, уникальные для данного модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| error словарь | ошибка | Информация об ошибке, возвращенная APIC Пример: {'code': '122', 'text': 'unknown managed object class foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Метод HTTP, используемый для запроса к APIC Пример: POST |
| preview строка | при состоянии preview | Предварительный просмотр между двумя моментами снимка |
| raw строка | ошибка разбора | Необработанный вывод, возвращаемый APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="unknown managed object class foo"/></imdata> |
| response строка | ошибка или отладка | Ответ HTTP от APIC Пример: OK (30 байт) |
| status целое число | ошибка или отладка | Код состояния HTTP от APIC Пример: 200 |
| url строка | ошибка или отладка | Используемый HTTP-url для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Авторы
- Jacob McGill (@jmcgill298)
© 2012–2018 Michael DeHaan
© 2018–2021 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.11/collections/cisco/aci/aci_config_rollback_module.html