cisco.aci.aci_static_node_mgmt_address – IP-адрес управления узла ACI по локальной или внешней сети
Примечание
Этот плагин входит в коллекцию cisco.aci (версия 2.0.0).
Для его установки используйте: ansible-galaxy collection install cisco.aci.
Для использования в книге задач укажите: cisco.aci.aci_static_node_mgmt_address.
Обзор
- IP-адрес узла Cisco ACI Fabric
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| annotation строка | Пользовательская строка для аннотирования объекта. Если значение не указано в задаче, используется значение переменной окружения ACI_ANNOTATION. | |
| certificate_name строка | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если указано имя файла private_key, по умолчанию используется имя файла private_key, без расширения.Если для private_key предоставлено содержимое в формате PEM, по умолчанию используется значение username. Если значение не указано в задаче, используется значение переменной окружения ACI_CERTIFICATE_NAME.псевдонимы: cert_name | |
| epg строка | Имя группы конечных точек | |
| host строка / обязательно | IP-адрес или имя хоста, разрешимое контроллером Ansible. Если значение не указано в задаче, используется значение переменной окружения ACI_HOST.псевдонимы: hostname | |
| ipv4_address строка | IP-адрес IPv4 локального/удаленного управления псевдонимы: ip | |
| ipv4_gw строка | IP-адрес шлюза локальной/удаленной сети управления псевдонимы: gw | |
| ipv6_address строка | IP-адрес IPv6 локального/удаленного управления псевдонимы: ipv6 | |
| ipv6_gw строка | IP-адрес шлюза локальной/удаленной сети управления | |
| node_id целое число | Идентификатор узла ACI Fabric для листа, спины или APIC | |
| output_level строка |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарьinfo добавляет информативный вывод, включая previous, proposed и sent словариdebug добавляет отладочный вывод, включая filter_string, method, response, status и url информациюЕсли значение не указано в задаче, используется значение переменной окружения ACI_OUTPUT_LEVEL. |
| output_path строка | Путь к файлу, который будет использован для вывода объектов конфигурации ACI JSON, созданных модулем. Если значение не указано в задаче, используется значение переменной окружения ACI_OUTPUT_PATH. | |
| owner_key строка | Пользовательская строка для атрибута ownerKey объекта ACI. Этот атрибут представляет собой ключ, позволяющий клиентам владеть своими данными для корреляции сущностей. Если значение не указано в задаче, используется значение переменной окружения ACI_OWNER_KEY. | |
| owner_tag строка | Пользовательская строка для атрибута ownerTag объекта ACI. Этот атрибут представляет собой метку, позволяющую клиентам добавлять свои данные. Например, для указания того, кто создал этот объект. Если значение не указано в задаче, используется значение переменной окружения ACI_OWNER_TAG. | |
| password строка | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если также указано private_key, оно будет использовано вместо него.Если значение не указано в задаче, используется значение переменных окружения ACI_PASSWORD или ANSIBLE_NET_PASSWORD. | |
| pod_id целое число | Номер подсети листа, спины или APIC | |
| port целое число | Порт, используемый для подключения REST. Значение по умолчанию зависит от параметра use_ssl. Если значение не указано в задаче, используется значение переменной окружения ACI_PORT. | |
| private_key строка | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемого для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name, которое используется.Этот параметр взаимоисключающий с password. Если также указано password, оно будет проигнорировано.Если значение не указано в задаче, используется значение переменной окружения ACI_PRIVATE_KEY.псевдонимы: cert_key | |
| state строка |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| timeout целое число | По умолчанию: 30 | Таймаут на уровне сокета в секундах. Если значение не указано в задаче, используется значение переменной окружения ACI_TIMEOUT. |
| type строка / обязательно |
| Тип интерфейса управления |
| use_proxy логическое |
| Если no, прокси не будет использоваться, даже если он определен в переменной окружения на целевых хостах.Если значение не указано в задаче, используется значение переменной окружения ACI_USE_PROXY. |
| use_ssl логическое |
| Если no, вместо стандартного HTTPS-соединения будет использоваться HTTP-соединение.Если значение не указано в задаче, используется значение переменной окружения ACI_USE_SSL. |
| username строка | По умолчанию: "admin" | Имя пользователя для аутентификации. Если значение не указано в задаче, используется значение переменных окружения ACI_USERNAME или ANSIBLE_NET_USERNAME.псевдонимы: user |
| validate_certs логическое |
| Если no, сертификаты SSL не будут проверены.Это следует устанавливать в no только при работе с сайтами, которыми вы управляете, и использующими самозаверяемые сертификаты.Если значение не указано в задаче, используется значение переменной окружения ACI_VALIDATE_CERTS. |
См. также
См. также
- Руководство по Cisco ACI
-
Подробная информация о том, как управлять инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
-
Подробное руководство по написанию собственных модулей Cisco ACI для участия в разработке.
Примеры
- name: Add ipv4 address to in band mgmt interface
cisco.aci.aci_static_node_mgmt_address:
host: "Host IP"
username: admin
password: SomeSecretePassword
epg: default
pod_id: 1
type: in_band
node_id: 1102
ipv4_address: "3.1.1.2/24"
ipv4_gw: "3.1.1.1"
state: present
delegate_to: localhost
- name: Add ipv4 address to out of band mgmt interface
cisco.aci.aci_static_node_mgmt_address:
host: "Host IP"
username: admin
password: SomeSecretePassword
epg: default
pod_id: 1
band_type: out_of_band
node_id: 1102
ipv4_address: "3.1.1.2/24"
ipv4_gw: "3.1.1.1"
state: present
delegate_to: localhost
- name: Remove ipv4 address to in band mgmt interface
cisco.aci.aci_static_node_mgmt_address:
host: "Host IP"
username: admin
password: SomeSecretePassword
epg: default
pod_id: 1
type: in_band
node_id: 1102
ipv4_address: "3.1.1.2/24"
ipv4_gw: "3.1.1.1"
state: absent
delegate_to: localhost
- name: Query the in band mgmt ipv4 address
cisco.aci.aci_static_node_mgmt_address:
host: "Host IP"
username: admin
password: SomeSecretePassword
epg: default
pod_id: 1
type: in_band
node_id: 1102
ipv4_address: "3.1.1.2/24"
ipv4_gw: "3.1.1.1"
state: query
delegate_to: localhost
- name: Query all addresses in epg out of band25wf
cisco.aci.aci_static_node_mgmt_address:
host: "Host IP"
username: admin
password: SomeSecretePassword
epg: default
type: out_of_band
state: query
delegate_to: localhost
- name: Query all in band addresses
cisco.aci.aci_static_node_mgmt_address:
host: "Host IP"
username: admin
password: SomeSecretePassword
type: in_band
state: query
delegate_to: localhost
Значения возврата
Общие значения возврата описаны здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список / элементы=строка | успех | Текущая конфигурация с APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращенная с APIC Пример: {'code': '122', 'text': 'неизвестный управляемый объект class foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Метод HTTP, используемый для запроса к APIC Пример: POST |
| previous список / элементы=строка | информация | Исходная конфигурация с APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собраная конфигурация из параметров пользователя Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращенный APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="unknown managed object class "/></imdata> |
| response строка | ошибка или отладка | Ответ HTTP с APIC Пример: class_map (30 байт) |
| sent список / элементы=строка | информация | Фактическая/минимальная конфигурация, отправленная на APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | Код состояния HTTP от APIC Пример: 200 |
| url строка | ошибка или отладка | Используемый HTTP URL для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Авторы
- Судхакар Шет Кудтаркар (@kudtarkar1)
- Леонель Эркот (@lhercot)
- Шреяс Сриш (@shrsr)
© 2012–2018 Michael DeHaan
© 2018–2021 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.11/collections/cisco/aci/aci_static_node_mgmt_address_module.html