fortinet.fortimanager.fmgr_firewall_sslsshprofile_smtps – Настройка параметров SMTPS.
Примечание
Этот плагин входит в коллекцию fortinet.fortimanager (версия 2.0.1).
Для его установки используйте: ansible-galaxy collection install fortinet.fortimanager.
Для использования в книге задач укажите: fortinet.fortimanager.fmgr_firewall_sslsshprofile_smtps.
Новое в версии 2.10: модуля fortinet.fortimanager
Обзор
- Этот модуль позволяет настроить устройство FortiManager.
- Примеры включают все параметры и значения, которые необходимо скорректировать в источниках данных перед использованием.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии | |
|---|---|---|---|
| adom строка / обязательно | параметр (adom) в запрошенном URL | ||
| bypass_validation логическое |
| устанавливать в True только при расхождении схемы модуля со структурой API FortiManager, модуль продолжает выполнение без проверки параметров | |
| firewall_sslsshprofile_smtps словарь | устанавливаемые параметры верхнего уровня | ||
| allow-invalid-server-cert строка |
| При включении разрешает SSL-сессии, валидация сертифицикатов которых не удалась. | |
| client-cert-request строка |
| Действие, основанное на запросе клиентского сертификата. | |
| ports целое число | нет описания | ||
| status строка |
| Настройка статуса проверки протокола. | |
| unsupported-ssl строка |
| Действие, основанное на том, что используемое SSL-шифрование не поддерживается. | |
| untrusted-cert строка |
| Разрешить, проигнорировать или заблокировать недоверенный сертификат SSL-сервера. | |
| rc_failed список / элементы=строка | список кодов rc, по которым будут выполняться условия для завершения с ошибкой | ||
| rc_succeeded список / элементы=строка | список кодов rc, по которым будут выполняться условия для завершения успешно | ||
| ssl-ssh-profile строка / обязательно | параметр (ssl-ssh-profile) в запрошенном URL | ||
| state строка / обязательно |
| направление для создания, обновления или удаления объекта | |
| workspace_locking_adom строка | адрес, который будет заблокирован для FortiManager, работающего в режиме рабочего пространства, значение может быть глобальным и другими, включая корень | ||
| workspace_locking_timeout целое число | По умолчанию: 300 | максимальное время в секундах ожидания, пока другой пользователь не разблокирует рабочее пространство | |
Примечания
Примечание
- В этом модуле FortiManager поддерживается работа в режиме блокировки рабочего пространства, параметры workspace_locking_adom и workspace_locking_timeout помогают в этом.
- Для создания или обновления объекта используйте направление present.
- Для удаления объекта используйте направление absent.
- Обычно выполнение одного модуля может завершиться ошибкой при возвращении ненулевого кода rc. Также вы можете переопределить условия завершения с ошибкой или успешно с параметрами rc_failed и rc_succeeded
Примеры
- hosts: fortimanager-inventory
collections:
- fortinet.fortimanager
connection: httpapi
vars:
ansible_httpapi_use_ssl: True
ansible_httpapi_validate_certs: False
ansible_httpapi_port: 443
tasks:
- name: Configure SMTPS options.
fmgr_firewall_sslsshprofile_smtps:
bypass_validation: False
workspace_locking_adom: <value in [global, custom adom including root]>
workspace_locking_timeout: 300
rc_succeeded: [0, -2, -3, ...]
rc_failed: [-2, -3, ...]
adom: <your own value>
ssl-ssh-profile: <your own value>
firewall_sslsshprofile_smtps:
allow-invalid-server-cert: <value in [disable, enable]>
client-cert-request: <value in [bypass, inspect, block]>
ports: <value of integer>
status: <value in [disable, deep-inspection]>
unsupported-ssl: <value in [bypass, inspect, block]>
untrusted-cert: <value in [allow, block, ignore]>
Возвращаемые значения
Общие возвращаемые значения документированы здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| request_url строка | всегда | Полный запрошенный URL Пример: /sys/login/user |
| response_code целое число | всегда | Статус запроса API |
| response_message строка | всегда | Описание ответа API Пример: OK. |
Авторы
- Link Zheng (@chillancezen)
- Jie Xue (@JieX19)
- Frank Shen (@fshen01)
- Hongbin Lu (@fgtdev-hblu)
© 2012–2018 Michael DeHaan
© 2018–2021 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.11/collections/fortinet/fortimanager/fmgr_firewall_sslsshprofile_smtps_module.html