Spec-Zone.ru › Ansible 2.11

netapp.ontap.na_ontap_info – NetApp информация сборщик

Примечание

Этот плагин является частью коллекции netapp.ontap (версия 21.1.1).

Для его установки используйте: ansible-galaxy collection install netapp.ontap.

Для использования в книге задач, укажите: netapp.ontap.na_ontap_info.

Новое в версии 2.9.0: от netapp.ontap

  • Описание
  • Требования
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения

Описание

  • Этот модуль позволяет собирать различную информацию о конфигурации ONTAP

Требования

Ниже приведены требования к хосту, на котором выполняется этот модуль.

  • Физическая или виртуальная кластеризованная система Data ONTAP. Модули поддерживают Data ONTAP 9.1 и более поздние версии.
  • Ansible 2.9
  • Python3 netapp-lib (2018.11.13) или более поздняя версия. Установите с помощью «pip install netapp-lib»
  • Поддержка REST требует ONTAP 9.6 или более поздней версии.
  • Для включения http в кластере необходимо выполнить следующие команды: «set -privilege advanced;» «system services web modify -http-enabled true;»
  • netapp-lib 2020.3.12 рекомендуется, так как он обеспечивает более подробные сообщения об ошибках для проблем с подключением.
  • netapp_lib

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
cert_filepath
строка
добавлено в 20.6.0 от netapp.ontap
путь к файлу сертификата SSL клиента (.pem).
не поддерживается с python 2.6.
continue_on_error
список / элементы=строка
По умолчанию:
"никогда"
По умолчанию, этот модуль завершается при первой ошибке.
Этот параметр позволяет указать список ошибок, при которых модуль не завершается.
Ошибки из списка отображаются в выводе, в соответствующем элементе информации, как запись "ошибка".
Возможные значения: всегда, никогда, missing_vserver_api_error, rpc_error, other_error.
missing_vserver_api_error - скорее всего, API доступен на уровне кластера, но не на уровне vserver.
rpc_error - некоторые запросы завершаются неудачно, потому что узел не может связаться с другим узлом в кластере.
key_error - запрос завершается неудачно, потому что возвращаемые данные не содержат ожидаемого ключа.
для ошибок ключа, обязательно сообщите об этом в Slack. Возможно, это изменение в новой версии ONTAP.
other_error - всё, что не указано в вышеперечисленных списках.
always будет продолжать при любой ошибке, never завершится при любой ошибке, они не могут использоваться с другими ключевыми словами.
desired_attributes
словарь
добавлено в 20.6.0 от netapp.ontap
Расширенная функция, требующая понимания внутренних механизмов ZAPI.
Позволяет запросить конкретный атрибут, который не возвращается по умолчанию, или ограничить возвращаемые атрибуты.
Словарь для элемента zapi desired-attributes.
Тег XML <tag>value</tag> — это словарь с тегом в качестве ключа.
Значение может быть другим словарем, списком словарей, строкой или пустым значением.
Например, <tag/> отображается как tag:
Если этот параметр установлен, можно вызвать только один подмножество за раз.
Ответственность вызывающей стороны — убедиться, что ключевые атрибуты присутствуют в нужном положении.
Модуль завершится ошибкой, если любой ключевой атрибут отсутствует.
feature_flags
словарь
добавлено в 20.5.0 от netapp.ontap
Включить или выключить новую функцию.
Это может быть использовано для включения экспериментальной функции или выключения новой функции, которая нарушает обратную совместимость.
Поддерживаемые ключи и значения могут изменяться без предварительного уведомления. Неизвестные ключи игнорируются.
gather_subset
список / элементы=строка
По умолчанию:
"все"
При указании этого аргумента информация, собираемая, будет ограничена определённым подмножеством. Возможные значения для этого аргумента включают "aggregate_info", "aggr_efficiency_info", "cifs_options_info", "cifs_server_info", "cifs_share_info", "cifs_vserver_security_info", "cluster_identity_info", "cluster_image_info", "cluster_log_forwarding_info", "cluster_node_info", "cluster_peer_info", "cluster_switch_info", "clock_info", "disk_info", "env_sensors_info", "event_notification_destination_info", "event_notification_info", "export_policy_info", "export_rule_info", "fcp_adapter_info", "fcp_alias_info", "fcp_service_info", "igroup_info", "iscsi_service_info", "job_schedule_cron_info", "kerberos_realm_info", "ldap_client", "ldap_config", "license_info", "lun_info", "lun_map_info", "metrocluster_check_info", "metrocluster_info", "metrocluster_node_info", "net_dev_discovery_info", "net_dns_info", "net_failover_group_info", "net_firewall_info", "net_ifgrp_info", "net_interface_info", "net_interface_service_policy_info", "net_ipspaces_info", "net_port_info", "net_port_broadcast_domain_info", "net_routes_info", "net_vlan_info", "nfs_info", "ntfs_dacl_info", "ntfs_sd_info", "ntp_server_info", "nvme_info", "nvme_interface_info", "nvme_namespace_info", "nvme_subsystem_info", "ontap_system_version", "ontap_version", "ontapi_version", "qos_adaptive_policy_info", "qos_policy_info", "qtree_info", "quota_report_info", "role_info", "security_key_manager_key_info", "security_login_account_info", "security_login_role_config_info", "security_login_role_info", "service_processor_info", "service_processor_network_info", "shelf_info" "sis_info", "sis_policy_info", "snapmirror_info", "snapmirror_destination_info", "snapmirror_policy_info", "snapshot_info", "snapshot_policy_info", "storage_failover_info", "storage_bridge_info", "subsys_health_info", "sysconfig_info", "sys_cluster_alerts", "volume_info", "volume_space_info", "vscan_info", "vscan_status_info", "vscan_scanner_pool_info", "vscan_connection_status_all_info", "vscan_connection_extended_stats_info", "vserver_info", "vserver_login_banner_info", "vserver_motd_info", "vserver_nfs_info", "vserver_peer_info", Можно указать список значений, чтобы включить большее подмножество. Значения также могут использоваться с начальным ! для указания того, что определённое подмножество не должно собираться.
nvme поддерживается с ONTAP 9.4 и выше.
используйте "help", чтобы получить список поддерживаемой информации для вашей системы.
hostname
строка / обязательно
Имя хоста или IP-адрес экземпляра ONTAP.
http_port
целое число
Переопределить порт по умолчанию (80 или 443) на этот порт
https
логическое значение
    Варианты:
  • нет ←
  • да
Включить и выключить https.
Игнорируется при использовании REST, так как только https поддерживается.
Игнорируется при использовании аутентификации с помощью сертификата SSL, так как она требует SSL.
key_filepath
строка
добавлено в 20.6.0 от netapp.ontap
путь к файлу ключа SSL клиента.
max_records
целое число
добавлено в 20.2.0 от netapp.ontap
По умолчанию:
1024
Максимальное количество записей, возвращаемых в одном вызове ZAPI. Допустимый диапазон [1..2^32-1]. Этот параметр контролирует внутреннее поведение этого модуля.
ontapi
целое число
Версия API ontap для использования
password
строка
Пароль для указанного пользователя.

псевдонимы: pass
query
словарь
добавлено в 20.7.0 от netapp.ontap
Расширенная функция, требующая понимания внутренних механизмов ZAPI.
Позволяет указать, какие объекты возвращать.
Словарь для элемента zapi query.
Тег XML <tag>value</tag> — это словарь с тегом в качестве ключа.
Значение может быть другим словарем, списком словарей, строкой или пустым значением.
Например, <tag/> отображается как tag:
Если этот параметр установлен, можно вызвать только один подмножество за раз.
state
строка
устарело начиная с 21.1.0.
этот параметр игнорировался и продолжает игнорироваться.
summary
логическое значение
добавлено в 20.4.0 от netapp.ontap
    Варианты:
  • нет ←
  • да
Логический флаг для управления возвратом всех атрибутов информации модуля или только имён.
Если true, возвращаются только имена.
use_native_zapi_tags
логическое значение
добавлено в 20.6.0 от netapp.ontap
    Варианты:
  • нет ←
  • да
По умолчанию, - в ключах возвращаемого словаря переводятся в _.
Если установлено в true, перевод отключён.
use_rest
строка
По умолчанию:
"авто"
REST API, если поддерживается целевой системой для всех ресурсов и атрибутов, необходимых модулю. В противном случае вернётся к ZAPI.
always — всегда будет использовать REST API
never — всегда будет использовать ZAPI
auto — попытается использовать REST API
username
строка
Это может быть учётная запись на уровне кластера или SVM, в зависимости от того, требуется ли API на уровне кластера или на уровне SVM.
Для получения дополнительной информации обратитесь к документации https://mysupport.netapp.com/NOW/download/software/nmsdk/9.4/.
Поддерживаются два метода аутентификации
1. аутентификация по протоколу basic, с использованием имени пользователя и пароля,
2. аутентификация по протоколу SSL с использованием файла сертификата SSL клиента и, необязательно, файла закрытого ключа.
Для использования сертификата, сертификат должен быть установлен в кластере ONTAP, и должна быть включена аутентификация по сертификату.

псевдонимы: user
validate_certs
логическое значение
    Варианты:
  • нет
  • да ←
Если установлено в no, сертификаты SSL не будут проверены.
Это следует устанавливать только в False на сайтах, контролируемых лично, использующих самозаверяющие сертификаты.
volume_move_target_aggr_info
словарь
добавлено в 20.5.0 от netapp.ontap
Обязательные параметры для volume_move_target_aggr_info
volume_name
строка / обязательно
добавлено в 20.5.0 от netapp.ontap
Имя тома, для которого нужно получить информацию о целевом агрегаторе
vserver
строка / обязательно
добавлено в 20.5.0 от netapp.ontap
vserver, на котором находится том
vserver
строка
добавлено в 19.11.0 от netapp.ontap
Если присутствует, 'vserver tunneling' ограничит вывод до vserver.
Обратите внимание, что не все подмножества поддерживаются на vserver, и 'все' вызовет ошибку.

Примечания

Примечание

  • Модули, начинающиеся с na\_ontap, разработаны для поддержки платформы хранения ONTAP.

Примеры

- name: Get NetApp info as Cluster Admin (Password Authentication)
  na_ontap_info:
    hostname: "na-vsim"
    username: "admin"
    password: "admins_password"
  register: ontap_info
- debug:
    msg: "{{ ontap_info.ontap_info }}"

- name: Get NetApp version as Vserver admin
  na_ontap_info:
    hostname: "na-vsim"
    username: "vsadmin"
    vserver: trident_svm
    password: "vsadmins_password"

- name: run ontap info module using vserver tunneling and ignoring errors
  na_ontap_info:
    hostname: "na-vsim"
    username: "admin"
    password: "admins_password"
    vserver: trident_svm
    summary: true
    continue_on_error:
      - missing_vserver_api_error
      - rpc_error

- name: Limit Info Gathering to Aggregate Information as Cluster Admin
  na_ontap_info:
    hostname: "na-vsim"
    username: "admin"
    password: "admins_password"
    gather_subset: "aggregate_info"
  register: ontap_info

- name: Limit Info Gathering to Volume and Lun Information as Cluster Admin
  na_ontap_info:
    hostname: "na-vsim"
    username: "admin"
    password: "admins_password"
    gather_subset:
      - volume_info
      - lun_info
  register: ontap_info

- name: Gather all info except for volume and lun information as Cluster Admin
  na_ontap_info:
    hostname: "na-vsim"
    username: "admin"
    password: "admins_password"
    gather_subset:
      - "!volume_info"
      - "!lun_info"
  register: ontap_info

- name: Gather Volume move information for a specific volume
  na_ontap_info:
    hostname: "na-vsim"
    username: "admin"
    password: "admins_password"
    gather_subset: volume_move_target_aggr_info
    volume_move_target_aggr_info:
      volume_name: carchitest
      vserver: ansible

- name: run ontap info module for aggregate module, requesting specific fields
  na_ontap_info:
    # <<: *login
    gather_subset: aggregate_info
    desired_attributes:
      aggr-attributes:
      aggr-inode-attributes:
        files-private-used:
      aggr-raid-attributes:
        aggregate-type:
    use_native_zapi_tags: true
    register: ontap
- debug: var=ontap

- name: run ontap info to get offline volumes with dp in the name
  na_ontap_info:
    # <<: *cert_login
    gather_subset: volume_info
    query:
      volume-attributes:
        volume-id-attributes:
          name: '*dp*'
        volume-state-attributes:
          state: offline
    desired_attributes:
      volume-attributes:
        volume-id-attributes:
          name:
        volume-state-attributes:
          state:
  register: ontap
- debug: var=ontap

Возвращаемые значения

Общие значения возвращаемых данных документированы здесь, ниже приведены поля, уникальные для этого модуля:

Ключ Возвращаемое значение Описание
ontap_info
словарь
всегда
Возвращает различные сведения о конфигурации кластера NetApp

Пример:
{ "ontap_info": { "aggregate_info": {...}, "cluster_identity_info": {...}, "cluster_image_info": {...}, "cluster_node_info": {...}, "igroup_info": {...}, "iscsi_service_info": {...}, "license_info": {...}, "lun_info": {...}, "metrocluster_check_info": {...}, "metrocluster_info": {...}, "metrocluster_node_info": {...}, "net_dns_info": {...}, "net_ifgrp_info": {...}, "net_interface_info": {...}, "net_interface_service_policy_info": {...}, "net_port_info": {...}, "ontap_system_version": {...}, "ontap_version": {...}, "ontapi_version": {...}, "qos_policy_info": {...}, "qos_adaptive_policy_info": {...}, "qtree_info": {...}, "quota_report_info": {...}, "security_key_manager_key_info": {...}, "security_login_account_info": {...}, "snapmirror_info": {...} "snapmirror_destination_info": {...} "storage_bridge_info": {...} "storage_failover_info": {...}, "volume_info": {...}, "vserver_login_banner_info": {...}, "vserver_motd_info": {...}, "vserver_info": {...}, "vserver_nfs_info": {...}, "vscan_status_info": {...}, "vscan_scanner_pool_info": {...}, "vscan_connection_status_all_info": {...}, "vscan_connection_extended_stats_info": {...} }


Авторы

  • Piotr Olczak (@dprts) <polczak@redhat.com>

© 2012–2018 Michael DeHaan
© 2018–2021 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.11/collections/netapp/ontap/na_ontap_info_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API