netapp.ontap.na_ontap_zapit – NetApp ONTAP Run any ZAPI on ONTAP
Примечание
Этот плагин является частью коллекции netapp.ontap (версия 21.1.1).
Для его установки используйте: ansible-galaxy collection install netapp.ontap.
Для использования в книге задач укажите: netapp.ontap.na_ontap_zapit.
Добавлено в версии 20.4.0: из netapp.ontap
Описание
- Вызов ZAPI на ONTAP.
- Запросы ZAPI кластера выполняются с использованием учетной записи администратора кластера.
- Запросы ZAPI сервера виртуальных машин могут выполняться с использованием учетной записи vsadmin или с использованием туннелирования сервера виртуальных машин (администратор кластера с параметром vserver).
- В случае успеха возвращается словарь JSON, как
response. - В случае ошибки ZAPI,
status,errno,reasonустанавливаются для помощи в диагностике проблемы, - и вызов сообщается как ошибка (‘failed’).
- Другие ошибки (например, проблемы с подключением) сообщаются как ошибка Ansible.
Требования
Ниже перечислены требования, необходимые на хосте, на котором выполняется этот модуль.
- Ansible 2.9
- Python3 netapp-lib (2018.11.13) или новее. Установите с помощью ‘pip install netapp-lib’
- netapp-lib 2020.3.12 настоятельно рекомендуется, поскольку он обеспечивает лучшую отчетность об ошибках при подключении.
- Физическая или виртуальная кластеризованная система Data ONTAP. Модули поддерживают Data ONTAP 9.1 и новее.
- Поддержка REST требует ONTAP 9.6 или новее.
- Для включения http в кластере необходимо выполнить следующие команды: ‘set -privilege advanced;’ ‘system services web modify -http-enabled true;’
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| cert_filepath строка добавлено в 20.6.0 из netapp.ontap | путь к файлу SSL-сертификата клиента (.pem). не поддерживается с python 2.6. | |
| feature_flags словарь добавлено в 20.5.0 из netapp.ontap | Включение или отключение новой функции. Это может быть использовано для включения экспериментальной функции или отключения новой функции, которая нарушает обратную совместимость. Поддерживаемые ключи и значения могут изменяться без предварительного уведомления. Неизвестные ключи игнорируются. | |
| hostname строка / обязательно | Имя хоста или IP-адрес экземпляра ONTAP. | |
| http_port целое число | Переопределите порт по умолчанию (80 или 443) с помощью этого порта. | |
| https логическое |
| Включение и отключение https. Игнорируется при использовании REST, так как поддерживается только https. Игнорируется при использовании аутентификации по сертификату SSL, так как она требует SSL. |
| key_filepath строка добавлено в 20.6.0 из netapp.ontap | путь к файлу закрытого ключа SSL-клиента. | |
| ontapi целое число | Используемая версия API ontap. | |
| password строка | Пароль для указанного пользователя. псевдонимы: pass | |
| use_rest строка | Значение по умолчанию: "auto" | REST API, если поддерживается целевой системой для всех ресурсов и атрибутов, необходимых модулю. В противном случае будет использоваться ZAPI. всегда -- всегда будет использовать REST API никогда -- всегда будет использовать ZAPI автоматически -- попытается использовать REST API |
| username строка | Это может быть учетная запись уровня кластера или SVM, в зависимости от того, требуется ли API уровня кластера или уровня SVM. Для получения дополнительной информации, пожалуйста, обратитесь к документации https://mysupport.netapp.com/NOW/download/software/nmsdk/9.4/. Поддерживаются два метода аутентификации: 1. основная аутентификация, использующая имя пользователя и пароль, 2. аутентификация по SSL-сертификату, использующая файл SSL-сертификата клиента и, необязательно, файл закрытого ключа. Для использования сертификата сертификат должен быть установлен в кластере ONTAP, и должна быть включена аутентификация по сертификатам. псевдонимы: user | |
| validate_certs логическое |
| Если установлено в no, сертификаты SSL не будут проверены.Это следует устанавливать только в False для использования на контролируемых лично сайтах с самоподписанными сертификатами. |
| vserver строка | если указано, принудительно активирует туннелирование сервера виртуальных машин. имя пользователя идентифицирует учетную запись администратора кластера. | |
| zapi словарь / обязательно | Словарь для zapi и аргументов. Тег XML <tag>значение</tag> представляет собой словарь с тегом в качестве ключа. Значение может быть другим словарем, списком словарей, строкой или пустым значением. Например, <tag/> представлено как tag:
Одновременно может быть вызван только один zapi. Ansible предупреждает о наличии дублирующихся ключей и использует только последнюю запись. |
Примечания
Примечание
- Модули, начинающиеся с na\_ontap, разработаны для поддержки платформы хранения ONTAP.
Примеры
-
name: Ontap ZAPI
hosts: localhost
gather_facts: False
collections:
- netapp.ontap
vars:
login: &login
hostname: "{{ admin_ip }}"
username: "{{ admin_username }}"
password: "{{ admin_password }}"
https: true
validate_certs: false
svm_login: &svm_login
hostname: "{{ svm_admin_ip }}"
username: "{{ svm_admin_username }}"
password: "{{ svm_admin_password }}"
https: true
validate_certs: false
tasks:
- name: run ontap ZAPI command as cluster admin
na_ontap_zapit:
<<: *login
zapi:
system-get-version:
register: output
- debug: var=output
- name: run ontap ZAPI command as cluster admin
na_ontap_zapit:
<<: *login
zapi:
vserver-get-iter:
register: output
- debug: var=output
- name: run ontap ZAPI command as cluster admin
na_ontap_zapit:
<<: *login
zapi:
vserver-get-iter:
desired-attributes:
vserver-info:
- aggr-list:
- aggr-name
- allowed-protocols:
- protocols
- vserver-aggr-info-list:
- vserser-aggr-info
- uuid
query:
vserver-info:
vserver-name: trident_svm
register: output
- debug: var=output
- name: run ontap ZAPI command as vsadmin
na_ontap_zapit:
<<: *svm_login
zapi:
vserver-get-iter:
desired-attributes:
vserver-info:
- uuid
register: output
- debug: var=output
- name: run ontap ZAPI command as vserver tunneling
na_ontap_zapit:
<<: *login
vserver: trident_svm
zapi:
vserver-get-iter:
desired-attributes:
vserver-info:
- uuid
register: output
- debug: var=output
- name: run ontap active-directory ZAPI command
na_ontap_zapit:
<<: *login
vserver: trident_svm
zapi:
active-directory-account-create:
account-name: testaccount
admin-username: testuser
admin-password: testpass
domain: testdomain
organizational-unit: testou
register: output
ignore_errors: True
- debug: var=output
Значения возврата
Общие значения возврата документированы здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| errno строка | При ошибке | Если ZAPI был выполнен, но завершился неудачей, код ошибки, установленный ZAPI. Отсутствует, если успешно, или если вызов ZAPI не может быть выполнен. |
| reason строка | При ошибке | Если ZAPI был выполнен, но завершился неудачей, причина ошибки, установленная ZAPI. Отсутствует, если успешно, или если вызов ZAPI не может быть выполнен. |
| response словарь | При успехе | Если успешно, словарь JSON, представляющий данные, возвращенные ZAPI. Если ZAPI был выполнен, но завершился неудачей, пустой словарь. Отсутствует, если вызов ZAPI не может быть выполнен. |
| status строка | При ошибке | Если ZAPI был выполнен, но завершился неудачей, статус, установленный ZAPI. Отсутствует, если успешно, или если вызов ZAPI не может быть выполнен. |
Авторы
- Команда Ansible NetApp (@carchi8py) <ng-ansibleteam@netapp.com>
© 2012–2018 Michael DeHaan
© 2018–2021 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.11/collections/netapp/ontap/na_ontap_zapit_module.html