aci_aep — Управление объектами профилей доступа (AEP) с возможностью присоединения (infra:AttEntityP, infra:ProvAcc)
Новая версия с 2.4.
Обзор
- Подключение к внешним виртуальным и физическим доменам с помощью профилей доступа (AEP) с возможностью присоединения на тканях Cisco ACI.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| aep обязательно | Имя профиля доступа с возможностью присоединения. псевдонимы: aep_name, name | |
| certificate_name | Имя сертификата X.509, присоединенного к пользователю APIC AAA, используемому для аутентификации на основе подписи. По умолчанию равно private_key базовому имени без расширения.псевдонимы: cert_name | |
| description | Описание AEP. псевдонимы: descr | |
| host обязательно | IP-адрес или имя хоста APIC, разрешимый хостом Ansible. псевдонимы: hostname | |
| infra_vlan bool (добавлен в 2.5) |
| Включить инфраструктурную VLAN. Функции гипервизора AEP. no отключит инфраструктурную VLAN, если она включена.псевдонимы: infrastructure_vlan |
| output_level |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарь.info добавляет информационный вывод, включая previous, proposed и sent словари.debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию. |
| password обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если также указан private_key, он будет использован вместо него. | |
| port | Номер порта для подключения REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| private_key обязательно | Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи. Имя ключа (без расширения) используется в качестве имени сертификата в ACI, если не указан certificate_name. Этот параметр взаимоисключающий с password. Если также указан password, он будет проигнорирован.псевдонимы: cert_key | |
| state |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| timeout int | По умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy bool |
| Если no, прокси не будет использоваться, даже если он определен в переменной среды на целевых хостах. |
| use_ssl bool |
| Если no, вместо стандартного HTTPS-соединения будет использоваться HTTP-соединение. |
| username | По умолчанию: "admin" | Имя пользователя для аутентификации. псевдонимы: user |
| validate_certs bool |
| Если no, сертификаты SSL не будут проверены.Это следует установить на no только при использовании на сайтах с самостоятельным контролем, использующих самозаверяющие сертификаты. |
Примечания
Примечание
- Дополнительную информацию о внутренних классах APIC infra:AttEntityP и infra:ProvAcc см. в справочнике по модели информации управления APIC.
- Подробнее о управлении вашей инфраструктурой ACI с помощью Ansible см. в руководстве Руководство по Cisco ACI.
Примеры
- name: Add a new AEP
aci_aep:
host: apic
username: admin
password: SomeSecretPassword
aep: ACI-AEP
description: default
state: present
- name: Remove an existing AEP
aci_aep:
host: apic
username: admin
password: SomeSecretPassword
aep: ACI-AEP
state: absent
- name: Query all AEPs
aci_aep:
host: apic
username: admin
password: SomeSecretPassword
state: query
- name: Query a specific AEP
aci_aep:
host: apic
username: admin
password: SomeSecretPassword
aep: ACI-AEP
state: query
Возвращаемые значения
Общие возвращаемые значения описаны здесь, следующие поля уникальны для данного модуля:
| Ключ | Результат | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация с APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращаемая с APIC Пример: {'code': '122', 'text': 'неизвестный управляемый объект foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация с APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собраная конфигурация из параметров пользователя Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный результат, возвращаемый APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный управляемый объект foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная на APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-URL, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
Этот модуль помечен как превью, что означает, что он не гарантирует обратную совместимость.
Техническое обслуживание
Этот модуль помечен как сообщество, что означает, что он поддерживается сообществом Ansible. См. Техническое обслуживание и поддержка модулей для получения дополнительной информации.
Список других модулей, которые также поддерживаются сообществом Ansible, см. здесь.
Автор
- Swetha Chunduri (@schunduri)
Подсказка
Если вы заметите какие-либо проблемы в этом документе, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.6/modules/aci_aep_module.html