aci_bd_subnet — Управление подсетями (fv:Subnet)
Новая версия с 2.4.
Описание
- Управление подсетями на платформах Cisco ACI.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| bd | Имя домена моста. Псевдонимы: bd_name | |
| certificate_name | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. По умолчанию равно private_key basename без расширения.Псевдонимы: cert_name | |
| description | Описание подсети. Псевдонимы: descr | |
| enable_vip bool |
| Определяет, должна ли подсеть обрабатываться как VIP; используется, когда BD расширена на несколько сайтов. APIC по умолчанию устанавливает no, если значение не задано при создании. |
| gateway | Адрес шлюза IPv4 или IPv6 для подсети. Псевдонимы: gateway_ip | |
| host обязательно | IP-адрес или имя хоста, разрешаемого хостом управления Ansible. Псевдонимы: hostname | |
| mask |
| Маска подсети для подсети. Это число, связанное с CIDR-нотацией. Псевдонимы: subnet_mask |
| nd_prefix_policy | Политика префикса обнаружения соседей IPv6 для связывания с подсетью. | |
| output_level |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарьinfo добавляет информационный вывод, включая previous, proposed и sent словариdebug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию |
| password обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если также указан private_key, будет использован он. | |
| port | Номер порта для подключения REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| preferred bool |
| Определяет, является ли подсеть предпочтительной по сравнению со всеми доступными подсетями. Только одна подсеть на семейство адресов (IPv4/IPv6) может быть предпочтительной в домене моста. APIC по умолчанию устанавливает no, если значение не задано при создании. |
| private_key обязательно | Файл в формате PEM, содержащий ваш закрытый ключ, используемый для аутентификации на основе подписи. Имя ключа (без расширения) используется в качестве имени сертификата в ACI, если не указан certificate_name. Этот параметр взаимоисключающий с password. Если также указан password, он будет проигнорирован.Псевдонимы: cert_key | |
| route_profile | Профиль маршрута для связывания с подсетью. | |
| route_profile_l3_out | L3 Out, содержащий связанный профиль маршрута. | |
| scope |
| Определяет область действия подсети. Вариант private позволяет обмениваться данными только с хостами в той же VRF.Вариант public позволяет рекламировать подсеть за пределами ACI Fabric и обмениваться данными с хостами в других VRF.Вариант shared ограничивает обмен данными хостами в той же VRF или в общей VRF. Значение — список вариантов, private и public взаимоисключают друг друга, но оба могут использоваться с shared. APIC по умолчанию устанавливает private, если значение не задано при создании. |
| state |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| subnet_control |
| Определяет состояние управления подсетью. Вариант querier_ip используется для обработки gateway_ip как IP-адреса источника запросов IGMP.Вариант nd_ra используется для обработки адреса gateway_ip как префикса объявления маршрутизатора обнаружения соседей.Вариант no_gw используется для удаления функции шлюза по умолчанию из адреса шлюза.APIC по умолчанию устанавливает nd_ra, если значение не задано при создании. |
| subnet_name | Имя подсети. Псевдонимы: name | |
| tenant | Имя арендатора. Псевдонимы: tenant_name | |
| timeout int | По умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy bool |
| Если no, прокси не будет использоваться, даже если он определён в переменной среды на целевых хостах. |
| use_ssl bool |
| Если no, вместо стандартного HTTPS-соединения будет использовано HTTP-соединение. |
| username | По умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs bool |
| Если no, сертификаты SSL не будут проверены.Это следует устанавливать в no только на контролируемых сайтах с самозаверенными сертификатами. |
Примечания
Примечание
- Параметр
gatewayявляется корневым ключом для доступа к подсети (не к имени), поэтомуgatewayтребуется, когда состояние —absentилиpresent. - Перед использованием данного модуля в своей книге задач необходимо убедиться, что
tenantиbdсуществуют. Для этого можно использовать модуль aci_tenant и aci_bd. - Дополнительную информацию о внутреннем классе APIC fv:Subnet можно найти в справочнике по модели управления информацией APIC.
- Для получения более подробной информации об управлении инфраструктурой ACI с помощью Ansible, обратитесь к Руководству по Cisco ACI.
Примеры
- name: Create a tenant
aci_tenant:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
- name: Create a bridge domain
aci_bd:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
bd: database
- name: Create a subnet
aci_bd_subnet:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
bd: database
gateway: 10.1.1.1
mask: 24
- name: Create a subnet with options
aci_bd_subnet:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
bd: database
subnet_name: sql
gateway: 10.1.2.1
mask: 23
description: SQL Servers
scope: public
route_profile_l3_out: corp
route_profile: corp_route_profile
- name: Update a subnets scope to private and shared
aci_bd_subnet:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
bd: database
gateway: 10.1.1.1
mask: 24
scope: [private, shared]
- name: Get all subnets
aci_bd_subnet:
host: apic
username: admin
password: SomeSecretPassword
state: query
- name: Get all subnets of specific gateway in specified tenant
aci_bd_subnet:
host: apic
username: admin
password: SomeSecretPassword
state: query
tenant: production
gateway: 10.1.1.1
mask: 24
- name: Get specific subnet
aci_bd_subnet:
host: apic
username: admin
password: SomeSecretPassword
state: query
tenant: production
bd: database
gateway: 10.1.1.1
mask: 24
- name: Delete a subnet
aci_bd_subnet:
host: apic
username: admin
password: SomeSecretPassword
state: absent
tenant: production
bd: database
gateway: 10.1.1.1
mask: 24
Возвращаемые значения
Общие возвращаемые значения описаны в документации, ниже приведены поля, уникальные для данного модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация из APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация из APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собранная конфигурация из предоставленных пользователем параметров Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращённый API REST APIC (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-адрес, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
Этот модуль помечен как превью, что означает, что он не гарантирует обратную совместимость.
Техническое обслуживание
Этот модуль помечен как сообщество, что означает, что он поддерживается сообществом Ansible. Подробную информацию см. в разделе Техническое обслуживание и поддержка модулей.
Список других модулей, поддерживаемых сообществом Ansible, см. здесь.
Автор
- Jacob McGill (@jmcgill298)
Подсказка
Если вы обнаружите какие-либо проблемы в этом руководстве, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.6/modules/aci_bd_subnet_module.html