Spec-Zone.ru › Ansible 2.6

aci_domain_to_encap_pool - Привязка домена к пулам Encap (infra:RsVlanNs)

Новая версия с 2.5.

  • Обзор
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения
  • Статус
  • Техническое обслуживание
    • Автор

Обзор

  • Привязывает домен к пулам Encap на Cisco ACI сетях.

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
certificate_name
Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи.
По умолчанию используется private_key имя файла без расширения.

Псевдонимы: cert_name
domain
Имя домена, который будет связан с пулом Encap.

Псевдонимы: domain_name, domain_profile
domain_type
    Варианты:
  • fc
  • l2dom
  • l3dom
  • phys
  • vmm
Определяет, является ли домен физическим (phys) или виртуальным (vmm).
host
обязательно
IP-адрес или имя хоста APIC, разрешаемого хостом управления Ansible.

Псевдонимы: hostname
output_level
    Варианты:
  • debug
  • info
  • normal ←
Влияет на вывод этого модуля ACI.
normal означает стандартный вывод, включая current словарь.
info добавляет информативный вывод, включая previous, proposed и sent словари.
debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию.
password
обязательно
Пароль для аутентификации.
Этот параметр взаимоисключающий с private_key. Если также указан private_key, он будет использован вместо него.
pool
Название пула.

Псевдонимы: pool_name
pool_allocation_mode
    Варианты:
  • dynamic
  • static
Способ, используемый для выделения encaps ресурсам.
Только vlan и vsan поддерживают режимы выделения.

Псевдонимы: allocation_mode, mode
pool_type
обязательно
    Варианты:
  • vlan
  • vsan
  • vxlan
Тип encaps pool.
port
Номер порта для использования в подключении REST.
Значение по умолчанию зависит от параметра `use_ssl`.
private_key
обязательно
Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи.
Имя ключа (без расширения) используется как имя сертификата в ACI, если не указан certificate_name.
Этот параметр взаимоисключающий с password. Если также указан password, он будет проигнорирован.

Псевдонимы: cert_key
state
    Варианты:
  • absent
  • present ←
  • query
Используйте present или absent для добавления или удаления.
Используйте query для перечисления объекта или нескольких объектов.
timeout
int
По умолчанию:
30
Таймаут сокета в секундах.
use_proxy
bool
    Варианты:
  • no
  • yes ←
Если no, прокси не будет использован, даже если он определён в переменной окружения на целевых хостах.
use_ssl
bool
    Варианты:
  • no
  • yes ←
Если no, будет использоваться соединение HTTP вместо стандартного HTTPS.
username По умолчанию:
"admin"
Имя пользователя для аутентификации.

Псевдонимы: user
validate_certs
bool
    Варианты:
  • no
  • yes ←
Если no, сертификаты SSL не будут проверены.
Это следует использовать только на контролируемых сайтах с самозаверяющими сертификатами.
vm_provider
    Варианты:
  • cloudfoundry
  • kubernetes
  • microsoft
  • openshift
  • openstack
  • redhat
  • vmware
Платформа виртуальных машин для домена VMM.
Поддержка Kubernetes была добавлена в ACI v3.0.
Поддержка CloudFoundry, OpenShift и Red Hat была добавлена в ACI v3.1.

Примечания

Примечание

  • Параметры domain и encap_pool должны быть заданы перед использованием этого модуля. Для этого можно использовать модули aci_domain и aci_encap_pool.
  • Дополнительную информацию о внутреннем классе APIC infra:RsVlanNs см. в справочнике по модели управления информацией APIC .
  • Для получения более подробной информации о том, как управлять инфраструктурой ACI с помощью Ansible, см. руководство Cisco ACI .

Примеры

- name: Add domain to VLAN pool binding
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: test_pool
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: present

- name: Remove domain to VLAN pool binding
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: test_pool
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: absent

- name: Query our domain to VLAN pool binding
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    pool: test_pool
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: query

- name: Query all domain to VLAN pool bindings
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain_type: phys
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: query

Возвращаемые значения

Общие возвращаемые значения описаны здесь, следующие поля уникальны для этого модуля:

Ключ Возвращаемое значение Описание
current
список
успех
Текущая конфигурация с APIC после завершения модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
error
словарь
ошибка
Информация об ошибке, возвращённая с APIC

Пример:
{'code': '122', 'text': 'неизвестный класс управляемого объекта foo'}
filter_string
строка
ошибка или отладка
Строка фильтра, использованная для запроса

Пример:
?rsp-prop-include=config-only
method
строка
ошибка или отладка
HTTP-метод, использованный для запроса к APIC

Пример:
POST
previous
список
информация
Исходная конфигурация с APIC до запуска модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
proposed
словарь
информация
Собраная конфигурация из предоставленных пользователем параметров

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}}
raw
строка
ошибка разбора
Необработанный вывод, возвращённый APIC REST API (xml или json)

Пример:
<?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata>
response
строка
ошибка или отладка
HTTP-ответ от APIC

Пример:
OK (30 байт)
sent
список
информация
Фактическая/минимальная конфигурация, отправленная на APIC

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда'}}}
status
целое число
ошибка или отладка
HTTP-статус с APIC

Пример:
200
url
строка
ошибка или отладка
HTTP-URL, использованный для запроса к APIC

Пример:
https://10.11.12.13/api/mo/uni/tn-production.json


Статус

Этот модуль помечен как превью, что означает, что он не гарантирует обратную совместимость.

Техническое обслуживание

Этот модуль помечен как сообщество, что означает, что он поддерживается сообществом Ansible. См. Поддержка и техническое обслуживание модулей для получения дополнительной информации.

Список других модулей, поддерживаемых сообществом Ansible, см. здесь.

Автор

  • Dag Wieers (@dagwieers)

Подсказка

Если вы заметили какие-либо проблемы в этом руководстве, вы можете отредактировать этот документ, чтобы улучшить его.

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.6/modules/aci_domain_to_encap_pool_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API