Spec-Zone.ru › Ansible 2.6

aci_encap_pool_range - Управление диапазонами encap, назначенными пулам (fvns:EncapBlk, fvns:VsanEncapBlk)

Новая версия с 2.5.

  • Описание
  • Параметры
  • Примечания
  • Примеры
  • Значения возврата
  • Статус
  • Техническое обслуживание
    • Автор

Описание

  • Управление диапазонами vlan, vxlan и vsan, назначенными пулам на устройствах Cisco ACI.

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
allocation_mode
    Варианты:
  • dynamic
  • inherit
  • static
Метод, используемый для распределения encap ресурсам.
Только vlan и vsan поддерживают режимы распределения.

Псевдонимы: mode
certificate_name
Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи.
По умолчанию private_key basename без расширения.

Псевдонимы: cert_name
description
Описание диапазона пула.

Псевдонимы: descr
host
обязательно
IP-адрес или имя хоста APIC, разрешимые хостом Ansible.

Псевдонимы: hostname
output_level
    Варианты:
  • debug
  • info
  • normal ←
Влияние на вывод этого модуля ACI.
normal означает стандартный вывод, включая current dict
info добавляет информативный вывод, включая previous, proposed и sent dicts
debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию
password
обязательно
Пароль для аутентификации.
Этот параметр исключает private_key. Если указан private_key, он будет использован вместо него.
pool
Имя пула, к которому должен быть назначен диапазон.

Псевдонимы: pool_name
pool_allocation_mode
    Варианты:
  • dynamic
  • static
Метод, используемый для распределения encap ресурсам.
Только vlan и vsan поддерживают режимы распределения.

Псевдонимы: pool_mode
pool_type
обязательно
    Варианты:
  • vlan
  • vxlan
  • vsan
Тип encap pool.

Псевдонимы: type
port
Порт, используемый для подключения REST.
Значение по умолчанию зависит от параметра `use_ssl`.
private_key
обязательно
Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи.
Имя ключа (без расширения) используется в качестве имени сертификата в ACI, если не указан certificate_name.
Этот параметр исключает password. Если указан password, он будет проигнорирован.

Псевдонимы: cert_key
range_end
Конец диапазона encap.

Псевдонимы: end
range_name
Имя, присваиваемое диапазону encap.

Псевдонимы: name, range
range_start
Начало диапазона encap.

Псевдонимы: start
state
    Варианты:
  • absent
  • present ←
  • query
Используйте present или absent для добавления или удаления.
Используйте query для получения списка объектов.
timeout
int
По умолчанию:
30
Таймаут сокета в секундах.
use_proxy
bool
    Варианты:
  • no
  • yes ←
Если no, прокси не будет использоваться, даже если он определён в переменной среды на целевых хостах.
use_ssl
bool
    Варианты:
  • no
  • yes ←
Если no, будет использовано HTTP-соединение вместо стандартного HTTPS-соединения.
username По умолчанию:
"admin"
Имя пользователя для аутентификации.

Псевдонимы: user
validate_certs
bool
    Варианты:
  • no
  • yes ←
Если no, сертификаты SSL не будут проверены.
Это следует устанавливать в no только при работе с самостоятельно подписанными сертификатами на контролируемых сайтах.

Примечания

Примечание

  • pool должен существовать для добавления или удаления диапазона.
  • Дополнительная информация об внутренних классах APIC fvns:EncapBlk и fvns:VsanEncapBlk из справочника по модели управления информацией APIC.
  • Обратитесь к Руководству Cisco ACI за дополнительной информацией по управлению инфраструктурой ACI с помощью Ansible.

Примеры

- name: Add a new VLAN pool range
  aci_encap_pool_range:
    host: apic
    username: admin
    password: SomeSecretPassword
    pool: production
    pool_type: vlan
    pool_allocation_mode: static
    range_name: anstest
    range_start: 20
    range_end: 40
    allocation_mode: inherit
    state: present

- name: Remove a VLAN pool range
  aci_encap_pool_range:
    host: apic
    username: admin
    password: SomeSecretPassword
    pool: production
    pool_type: vlan
    pool_allocation_mode: static
    range_name: anstest
    range_start: 20
    range_end: 40
    state: absent

- name: Query a VLAN range
  aci_encap_pool_range:
    host: apic
    username: admin
    password: SomeSecretPassword
    pool: production
    pool_type: vlan
    pool_allocation_mode: static
    range_name: anstest
    range_start: 20
    range_end: 50
    state: query

- name: Query a VLAN pool for ranges by range_name
  aci_encap_pool_range:
    host: apic
    username: admin
    password: SomeSecretPassword
    pool_type: vlan
    range_name: anstest
    state: query
  delegate_to: localhost
  register: query_result

- name: Query a VLAN pool for ranges by range_start
  aci_encap_pool_range:
    host: apic
    username: admin
    password: SomeSecretPassword
    pool_type: vlan
    range_start: 20
    state: query
  delegate_to: localhost
  register: query_result

- name: Query a VLAN pool for ranges by range_start and range_end
  aci_encap_pool_range:
    host: apic
    username: admin
    password: SomeSecretPassword
    pool_type: vlan
    range_start: 20
    range_end: 40
    state: query

- name: Query all VLAN pool ranges
  aci_encap_pool_range:
    host: apic
    username: admin
    password: SomeSecretPassword
    pool_type: vlan
    state: query

Значения возврата

Общие значения возврата описаны здесь, следующие — поля, уникальные для данного модуля:

Ключ Возвращаемое значение Описание
current
список
успех
Текущая конфигурация с APIC после завершения модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
error
словарь
ошибка
Информация об ошибке, возвращенная с APIC

Пример:
{'code': '122', 'text': 'неизвестный класс управляемого объекта foo'}
filter_string
строка
ошибка или отладка
Строка фильтра, используемая для запроса

Пример:
?rsp-prop-include=config-only
method
строка
ошибка или отладка
Метод HTTP, используемый для запроса к APIC

Пример:
POST
previous
список
информация
Исходная конфигурация с APIC до запуска модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
proposed
словарь
информация
Собраная конфигурация из предоставленных пользователем параметров

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}}
raw
строка
ошибка парсинга
Необработанный вывод, возвращенный API REST APIC (xml или json)

Пример:
<?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata>
response
строка
ошибка или отладка
HTTP ответ от APIC

Пример:
OK (30 байт)
sent
список
информация
Фактическая/минимальная конфигурация, отправленная на APIC

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда'}}}
status
целое число
ошибка или отладка
HTTP статус от APIC

Пример:
200
url
строка
ошибка или отладка
HTTP URL, используемый для запроса к APIC

Пример:
https://10.11.12.13/api/mo/uni/tn-production.json


Статус

Этот модуль помечен как превью, что означает, что он не гарантирует обратную совместимость.

Техническое обслуживание

Этот модуль помечен как сообщество, что означает, что он поддерживается сообществом Ansible. Подробнее см. Техническое обслуживание и поддержка модулей.

Список других модулей, поддерживаемых сообществом Ansible, см. здесь.

Автор

  • Jacob McGill (@jmcgill298)

Подсказка

Если вы заметите какие-либо проблемы в этом документе, вы можете отредактировать этот документ, чтобы улучшить его.

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.6/modules/aci_encap_pool_range_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API