aci_epg_to_domain - Привязка EPG к доменам (fv:RsDomAtt)
Новая версия 2.4.
Описание
- Привязка EPG к физическим и виртуальным доменам на Cisco ACI сетях.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| allow_useg |
| Разрешает микросегментацию. APIC по умолчанию использует encap, если не указано при создании. |
| ap | Имя существующего профиля сетевого приложения, который будет содержать EPG. Псевдонимы: app_profile, app_profile_name | |
| certificate_name | Имя X.509 сертификата, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. По умолчанию используется private_key без расширения.Псевдонимы: cert_name | |
| deploy_immediacy |
| Определяет, когда политика передается на аппаратный Policy CAM. APIC по умолчанию использует lazy, если не указано при создании. |
| domain | Имя физического или виртуального домена, ассоциируемого с EPG. Псевдонимы: domain_name, domain_profile | |
| domain_type |
| Определяет, является ли домен физическим (phys) или виртуальным (vmm). Псевдонимы: type |
| encap |
| Капсулирование VLAN для EPG при привязке домена VMM со статическим encap_mode. Выступает в качестве вторичного encap при использовании useg. |
| encap_mode |
| Метод капсулирования. APIC по умолчанию использует auto, если не указано при создании. |
| epg | Имя группы конечных точек. Псевдонимы: epg_name, name | |
| host обязательно | IP-адрес или имя хоста, разрешимое хостом управления Ansible. Псевдонимы: hostname | |
| netflow bool |
| Определяет, следует ли включить netflow. APIC по умолчанию использует no, если не указано при создании. |
| output_level |
| Влияет на вывод этого ACI модуля. normal означает стандартный вывод, включая current словарь.info добавляет информативный вывод, включая previous, proposed и sent словари.debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию. |
| password обязательно | Пароль для аутентификации. Этот параметр взаимно исключает private_key. Если указан private_key, он будет использован вместо него. | |
| port | Номер порта для подключения REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| primary_encap |
| Определяет основной ID VLAN при использовании useg. |
| private_key обязательно | Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи. Имя ключа (без расширения) используется как имя сертификата в ACI, если не указан certificate_name. Этот параметр взаимно исключает password. Если указан password, он будет проигнорирован.Псевдонимы: cert_key | |
| resolution_immediacy |
| Определяет, когда политики должны быть разрешены и доступны. APIC по умолчанию использует lazy, если не указано при создании. |
| state |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| tenant | Имя существующего арендатора. Псевдонимы: tenant_name | |
| timeout int | По умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy bool |
| Если no, прокси не будет использоваться, даже если он определён в переменной окружения на целевых хостах. |
| use_ssl bool |
| Если no, будет использоваться соединение HTTP вместо соединения HTTPS по умолчанию. |
| username | По умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs bool |
| Если no, сертификаты SSL не будут проверяться.Это следует устанавливать в no только при работе с собственными сертификатами на контролируемых сайтах. |
| vm_provider |
| Платформа VM для VMM домена. Поддержка Kubernetes добавлена в ACI v3.0. Поддержка CloudFoundry, OpenShift и Red Hat добавлена в ACI v3.1. |
Примечания
Примечание
tenant,ap,epg, иdomainдолжны существовать перед использованием этого модуля в вашем плейбуке. Модули aci_tenant aci_ap, aci_epg aci_domain могут быть использованы для этого.- Домены VMM OpenStack не должны создаваться с помощью этого модуля. Домен VMM OpenStack создается напрямую плагином Cisco APIC Neutron как часть установки и настройки. Этот модуль может использоваться для запроса статуса домена VMM OpenStack.
- Дополнительную информацию об внутреннем классе APIC fv:RsDomAtt см. в справке по модели информации управления APIC.
- Дополнительную информацию о том, как управлять инфраструктурой ACI с помощью Ansible, см. в Руководстве Cisco ACI.
Примеры
- name: Add a new physical domain to EPG binding
aci_epg_to_domain:
host: apic
username: admin
password: SomeSecretPassword
tenant: anstest
ap: anstest
epg: anstest
domain: anstest
domain_type: phys
state: present
- name: Remove an existing physical domain to EPG binding
aci_epg_to_domain:
host: apic
username: admin
password: SomeSecretPassword
tenant: anstest
ap: anstest
epg: anstest
domain: anstest
domain_type: phys
state: absent
- name: Query a specific physical domain to EPG binding
aci_epg_to_domain:
host: apic
username: admin
password: SomeSecretPassword
tenant: anstest
ap: anstest
epg: anstest
domain: anstest
domain_type: phys
state: query
- name: Query all domain to EPG bindings
aci_epg_to_domain:
host: apic
username: admin
password: SomeSecretPassword
state: query
Возвращаемые значения
Общие возвращаемые значения описаны здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращено | Описание |
|---|---|---|
| current список | успешно | Текущая конфигурация с APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация с APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Сборка конфигурации из предоставленных пользователем параметров Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращённый APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная на APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-URL, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
Этот модуль помечен как превью, что означает, что он не гарантирует обратную совместимость.
Техническое обслуживание
Этот модуль помечен как сообщество, что означает, что он поддерживается сообществом Ansible. Подробнее см. Техническое обслуживание и поддержка модулей.
Список других модулей, поддерживаемых сообществом Ansible, см. здесь.
Автор
- Jacob McGill (@jmcgill298)
Подсказка
Если вы обнаружите какие-либо проблемы в этой документации, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.6/modules/aci_epg_to_domain_module.html