aci_interface_policy_l2 - Управление политиками интерфейсов уровня 2 (l2:IfPol)
Новая версия с 2.4.
Описание
- Управление политиками интерфейсов уровня 2 на Cisco ACI тканях.
Псевдонимы: aci_intf_policy_l2
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| certificate_name | Имя X.509 сертификата, прикреплённого к пользователю APIC AAA, используемому для аутентификации на основе подписи. По умолчанию равно private_key базовому имени без расширения.Псевдонимы: cert_name | |
| description | Описание политики интерфейса уровня 2. Псевдонимы: descr | |
| host обязательно | IP-адрес или имя хоста APIC, разрешаемого хостом управления Ansible. Псевдонимы: hostname | |
| l2_policy обязательно | Имя политики интерфейса уровня 2. Псевдонимы: name | |
| output_level |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарь.info добавляет информационный вывод, включая previous, proposed и sent словари.debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию. |
| password обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если задан также private_key, он будет использован вместо него. | |
| port | Номер порта, используемого для подключения REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| private_key обязательно | Файл в формате PEM, содержащий ваш закрытый ключ, используемый для аутентификации на основе подписи. Имя ключа (без расширения) используется как имя сертификата в ACI, если не указано certificate_name. Этот параметр взаимоисключающий с password. Если задан также password, он будет проигнорирован.Псевдонимы: cert_key | |
| qinq |
| Определяет, отключен ли QinQ или порт должен рассматриваться как ядро или крайний порт. APIC по умолчанию устанавливает disabled при отсутствии задания при создании. |
| state |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| timeout int | По умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy bool |
| Если no, прокси не будет использоваться, даже если он определен в переменной среды на целевых хостах. |
| use_ssl bool |
| Если no, вместо стандартного HTTPS соединения будет использоваться соединение HTTP. |
| username | По умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs bool |
| Если no, сертификаты SSL не будут проверены.Это должно быть установлено как no только при использовании на контролируемых сайтах с самозаверяющимися сертификатами. |
| vepa |
| Определяет, отключен или включен агрегатор виртуальных портов Ethernet. APIC по умолчанию устанавливает disabled при отсутствии задания при создании. |
| vlan_scope |
| Область действия VLAN. APIC по умолчанию устанавливает global при отсутствии задания при создании. |
Примечания
Примечание
- Дополнительная информация об внутреннем классе APIC l2:IfPol из справочника по модели управления информацией APIC.
- Обратитесь к Руководству Cisco ACI для получения более подробной информации о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
Примеры
- aci_interface_policy_l2:
host: '{{ hostname }}'
username: '{{ username }}'
password: '{{ password }}'
l2_policy: '{{ l2_policy }}'
vlan_scope: '{{ vlan_policy }}'
description: '{{ description }}'
Возвращаемые значения
Общие возвращаемые значения описаны здесь, следующие — это поля, уникальные для данного модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация с APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращенная APIC Пример: {'code': '122', 'text': 'неизвестный управляемый объект класса foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Метод HTTP, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация с APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собраная конфигурация из предоставленных пользователем параметров Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращенный API REST APIC (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный управляемый объект класса foo"/></imdata> |
| response строка | ошибка или отладка | HTTP ответ с APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP статус с APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP url, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
Этот модуль помечен как предварительный просмотр, что означает, что он не гарантирует обратную совместимость.
Техническое обслуживание
Этот модуль помечен как сообщество, что означает, что его поддерживает сообщество Ansible. Подробнее см. Техническое обслуживание и поддержка модулей.
Список других модулей, поддерживаемых сообществом Ansible, см. здесь.
Автор
- Dag Wieers (@dagwieers)
Подсказка
Если вы обнаружите какие-либо проблемы в этом документе, вы можете изменить этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.6/modules/aci_interface_policy_l2_module.html