aci_vlan_pool - Управление пулами VLAN (fvns:VlanInstP)
Новая версия с 2.5.
Обзор
- Управление пулами VLAN на фэбрах Cisco ACI.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| certificate_name | Имя X.509 сертификата, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. По умолчанию, это private_key базовое имя без расширения.Псевдонимы: cert_name | |
| description | Описание для pool.Псевдонимы: descr | |
| host обязательно | IP-адрес или имя хоста APIC, разрешимые хостом управления Ansible. Псевдонимы: hostname | |
| output_level |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарь.info добавляет информационный вывод, включая previous, proposed и sent словари.debug добавляет вывод отладки, включая filter_string, method, response, status и url информацию. |
| password обязательно | Пароль для аутентификации. Этот параметр взаимоисключает private_key. Если private_key также указан, он будет использован вместо него. | |
| pool | Название пула. Псевдонимы: name, pool_name | |
| pool_allocation_mode |
| Метод, используемый для выделения VLAN для ресурсов. Псевдонимы: allocation_mode, mode |
| port | Номер порта для использования в соединении REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| private_key обязательно | Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи. Имя ключа (без расширения) используется в качестве имени сертификата в ACI, если не указано certificate_name.Этот параметр взаимоисключает password. Если password также указан, он будет проигнорирован.Псевдонимы: cert_key | |
| state |
| Используйте present или absent для добавления или удаления.Используйте query для вывода списка объекта или нескольких объектов. |
| timeout int | По умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy bool |
| Если no, прокси не будет использоваться, даже если он определен в переменной среды на целевых хостах. |
| use_ssl bool |
| Если no, будет использовано HTTP-соединение вместо стандартного HTTPS-соединения. |
| username | По умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs bool |
| Если no, сертификаты SSL не будут проверены.Это должно быть установлено как no только при использовании на сайтах под собственным контролем с самозаверенными сертификатами. |
Примечания
Примечание
- Дополнительную информацию о внутреннем классе APIC fvns:VlanInstP можно найти в справочнике по модели управления информацией APIC.
- Обратитесь к Руководству по Cisco ACI для более подробной информации о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
Примеры
- name: Add a new VLAN pool
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_allocation_mode: dynamic
description: Production VLANs
state: present
- name: Remove a VLAN pool
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_allocation_mode: dynamic
state: absent
- name: Query a VLAN pool
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_allocation_mode: dynamic
state: query
- name: Query all VLAN pools
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
state: query
Возвращаемые значения
Общие возвращаемые значения описаны в здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация из APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращенная из APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Метод HTTP, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация из APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собраная конфигурация из предоставленных пользователем параметров Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращенный API REST APIC (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-адрес, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
Этот модуль помечен как превью, что означает, что он не гарантирует обратную совместимость.
Техническое обслуживание
Этот модуль помечен как сообщество, что означает, что он поддерживается сообществом Ansible. Дополнительную информацию см. в разделе Техническое обслуживание и поддержка модулей.
Список других модулей, поддерживаемых сообществом Ansible, см. здесь.
Автор
- Jacob McGill (@jmcgill298)
- Dag Wieers (@dagwieers)
Подсказка
Если вы заметили какие-либо проблемы в этом руководстве, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.6/modules/aci_vlan_pool_module.html