Spec-Zone.ru › Ansible 2.6

openstack - Источник инвентаризации OpenStack

  • Обзор
  • Параметры
  • Примеры
  • Статус
    • Автор

Обзор

  • Получение хостов инвентаризации из облаков OpenStack
  • Использует конфигурационный файл openstack.(yml|yaml) в формате YAML для настройки плагина инвентаризации
  • Использует стандартный конфигурационный файл clouds.yaml в формате YAML для настройки учетных данных облака

Параметры

Параметр Варианты/Значения по умолчанию Конфигурация Комментарии
cache
boolean
По умолчанию:
"нет"
Элементы ini:

[inventory ]
cache = нет

переменная окружения:ANSIBLE_INVENTORY_CACHE
Включить/отключить кэширование исходных данных инвентаризации, требует настройки плагина кэша для работы.
cache_connection
Элементы ini:

[inventory ]
cache_connection = ЗНАЧЕНИЕ

переменная окружения:ANSIBLE_INVENTORY_CACHE_CONNECTION
Данные или путь соединения кэша, см. документацию по плагинам кэша для получения подробностей.
cache_plugin
Элементы ini:

[inventory ]
cache_plugin = ЗНАЧЕНИЕ

переменная окружения:ANSIBLE_INVENTORY_CACHE_PLUGIN
Плагин кэша для использования в исходных данных инвентаризации.
cache_timeout
целое число
По умолчанию:
3600
Элементы ini:

[inventory ]
cache_timeout = 3600

переменная окружения:ANSIBLE_INVENTORY_CACHE_TIMEOUT
Время хранения кэша в секундах
clouds_yaml_path
строка
Изменить путь к файлу clouds.yaml. Если это значение указано, оно будет проверено в первую очередь. Стандартный путь для инвентаризации ansible добавляет /etc/ansible/openstack.yaml и /etc/ansible/openstack.yml к обычным расположениям, документированным по адресу https://docs.openstack.org/os-client-config/latest/user/configuration.html#config-files
compose
словарь
По умолчанию:
{}
Создать переменные из выражений jinja2.
expand_hostvars
bool
    Варианты:
  • нет ←
  • да
Выполнить дополнительные команды на каждом хосте для заполнения дополнительной информации о хосте. Может взаимодействовать с cinder и neutron и может быть дорогостоящим для людей с большим количеством хостов. (Обратите внимание, что значение по умолчанию этого параметра противоположно значению по умолчанию старого скрипта инвентаризации openstack.py опции expand_hostvars)
fail_on_errors
bool
    Варианты:
  • нет ←
  • да
Приводит к отказу инвентаризации и возврату без хостов, если одно облако потерпело неудачу (например, плохие учетные данные или недоступность). При установке в значение False инвентаризация вернет столько хостов, сколько сможет, из облаков, с которыми сможет связаться. (Обратите внимание, что значение по умолчанию этого параметра противоположно значению по умолчанию старого скрипта инвентаризации openstack.py опции fail_on_errors)
groups
словарь
По умолчанию:
{}
Добавить хосты в группу на основе условных выражений Jinja2.
inventory_hostname
строка
    Варианты:
  • имя ←
  • uuid
Что зарегистрировать в качестве имени хоста инвентаризации. Если установлено в 'uuid', будет использован uuid сервера, и будет создана группа для имени сервера. Если установлено в 'имя', будет использовано имя сервера, если только не будет более одного сервера с таким же именем, в этом случае будет использоваться логика 'uuid'. По умолчанию используется 'имя', что противоположно старой опции openstack.py инвентаризации use_hostnames)
keyed_groups
список
По умолчанию:
[]
добавить хосты в группу на основе значений переменной
only_clouds
список
По умолчанию:
[]
Список облаков из clouds.yaml для использования вместо всего списка.
private
bool
    Варианты:
  • нет ←
  • да
Использовать частный интерфейс каждого сервера, если он есть, как IP хоста в инвентаризации. Это может быть полезно, если вы запускаете ansible внутри сервера в облаке и предпочитаете взаимодействие с вашими серверами через частную сеть.
show_all
bool
    Варианты:
  • нет ←
  • да
переключает отображение всех виртуальных машин по сравнению с отображением только тех, у которых есть рабочий IP-адрес
strict
boolean
По умолчанию:
"нет"
Если true, неверные записи являются фатальной ошибкой, в противном случае пропускаются и выполнение продолжается
Поскольку можно использовать факты в выражениях, они могут быть не всегда доступны, и мы по умолчанию игнорируем эти ошибки.

Примеры

# file must be named openstack.yaml or openstack.yml
# Make the plugin behave like the default behavior of the old script
plugin: openstack
expand_hostvars: yes
fail_on_errors: yes

Статус

Автор

  • НЕИЗВЕСТНО

Подсказка

Если вы обнаружите какие-либо проблемы в этом руководстве, вы можете отредактировать этот документ для его улучшения.

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.6/plugins/inventory/openstack.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API