aci_ap – Управление объектами профиля приложений верхнего уровня (AP) (fv:Ap)
Новая версия с 2.4.
Описание
- Управление объектами профиля приложений (AP) верхнего уровня на тканях Cisco ACI
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| ap - / обязательно | Имя профиля сетевой приложений. Псевдонимы: app_profile, app_profile_name, name | |
| certificate_name - | Имя сертификата X.509, прикреплённого к пользователю AAA APIC, используемому для аутентификации на основе подписи. По умолчанию равно private_key basename без расширения.Псевдонимы: cert_name | |
| description - | Описание для AP. Псевдонимы: descr | |
| host - / обязательно | IP-адрес или имя хоста APIC, разрешаемое хостом управления Ansible. Псевдонимы: hostname | |
| output_level - |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current dictinfo добавляет информационный вывод, включая previous, proposed и sent dictsdebug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию |
| password - / обязательно | Пароль для аутентификации. Этот параметр взаимоисключает private_key. Если задан private_key, будет использован он. | |
| port - | Номер порта для подключения REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| private_key - / обязательно | Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи. Имя ключа (без расширения) используется как имя сертификата в ACI, если не указан certificate_name. Этот параметр взаимоисключает password. Если задан password, он будет проигнорирован.Псевдонимы: cert_key | |
| state - |
| Используйте present или absent для добавления или удаления.Используйте query для отображения объекта или нескольких объектов. |
| tenant - / обязательно | Имя существующего арендатора. Псевдонимы: tenant_name | |
| timeout целое число | По умолчанию: 30 | Тайм-аут уровня сокета в секундах. |
| use_proxy булево |
| Если no, прокси не будет использоваться, даже если он определен в переменной среды на целевых хостах. |
| use_ssl булево |
| Если no, вместо стандартного HTTPS-соединения будет использоваться HTTP-соединение. |
| username - | По умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs булево |
| Если no, сертификаты SSL не будут проверены.Это следует устанавливать только в no на сайтах под собственным контролем с использованием самозаверяющих сертификатов. |
Примечания
Примечание
- Этот модуль не управляет EPG, см. aci_epg для этого.
- Перед использованием этого модуля в вашей книге задач
tenantдолжен существовать. Для этого можно использовать модуль aci_tenant. - Дополнительную информацию о внутреннем классе APIC fv:Ap см. в справочнике по модели управления информацией APIC.
См. также
См. также
- Руководство по Cisco ACI
- Подробная информация о том, как управлять инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Add a new AP
aci_ap:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
ap: default
description: default ap
state: present
delegate_to: localhost
- name: Remove an AP
aci_ap:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
ap: default
state: absent
delegate_to: localhost
- name: Query an AP
aci_ap:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
ap: default
state: query
delegate_to: localhost
register: query_result
- name: Query all APs
aci_ap:
host: apic
username: admin
password: SomeSecretPassword
state: query
delegate_to: localhost
register: query_result
Возвращаемые значения
Общие значения возврата описаны в разделе возвращаемых значений, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация с APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращенная с APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация с APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собраная конфигурация из параметров пользователя Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращённый API REST APIC (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ с APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная на APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус с APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-url, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Данный модуль не гарантирует обратную совместимость. [превью]
- Этот модуль поддерживается партнером Ansible. [сертифицировано]
Авторы
- Swetha Chunduri (@schunduri)
Подсказка
Если вы заметили какие-либо проблемы в этом руководстве, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.7/modules/aci_ap_module.html