Spec-Zone.ru › Ansible 2.7

aci_domain_to_vlan_pool – Привязка домена к пулам VLAN (infra:RsVlanNs)

Новая в версии 2.5.

  • Описание
  • Параметры
  • Примечания
  • См. также
  • Примеры
  • Возвращаемые значения
  • Статус

Описание

  • Привязка домена к пулам VLAN на тканях Cisco ACI.

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
certificate_name
-
Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи.
По умолчанию равно private_key basename без расширения.

Псевдонимы: cert_name
domain
-
Имя домена, который связывается с пулом VLAN.

Псевдонимы: domain_name, domain_profile
domain_type
-
    Варианты:
  • fc
  • l2dom
  • l3dom
  • phys
  • vmm
Определяет, является ли домен физическим (phys) или виртуальным (vmm).
host
- / обязательно
IP-адрес или имя хоста APIC, разрешаемый управляющим хостом Ansible.

Псевдонимы: hostname
output_level
-
    Варианты:
  • debug
  • info
  • normal ←
Влияет на вывод этого модуля ACI.
normal означает стандартный вывод, включая current словарь.
info добавляет информационный вывод, включая previous, proposed и sent словари.
debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию.
password
- / обязательно
Пароль для аутентификации.
Этот параметр исключает private_key. Если также указан private_key, он будет использован вместо него.
pool
-
Имя пула.

Псевдонимы: pool_name, vlan_pool
pool_allocation_mode
- / обязательно
    Варианты:
  • dynamic
  • static
Метод, используемый для распределения VLAN для ресурсов.

Псевдонимы: allocation_mode, mode
port
-
Номер порта, используемый для подключения REST.
Значение по умолчанию зависит от параметра `use_ssl`.
private_key
- / обязательно
Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи.
Имя ключа (без расширения) используется в качестве имени сертификата в ACI, если не указан certificate_name.
Этот параметр исключает password. Если также указан password, он будет проигнорирован.

Псевдонимы: cert_key
state
-
    Варианты:
  • absent
  • present ←
  • query
Используйте present или absent для добавления или удаления.
Используйте query для перечисления объекта или нескольких объектов.
timeout
целое число
По умолчанию:
30
Таймаут уровня сокета в секундах.
use_proxy
булево
    Варианты:
  • no
  • yes ←
Если no, прокси не будет использоваться, даже если он определён в переменной окружения на целевых хостах.
use_ssl
булево
    Варианты:
  • no
  • yes ←
Если no, вместо стандартного HTTPS соединения будет использовано HTTP соединение.
username
-
По умолчанию:
"admin"
Имя пользователя для аутентификации.

Псевдонимы: user
validate_certs
булево
    Варианты:
  • no
  • yes ←
Если no, сертификаты SSL не будут проверены.
Этот параметр следует установить в no только при работе с сайтами, контролируемыми лично, использующими самозаверенные сертификаты.
vm_provider
-
    Варианты:
  • cloudfoundry
  • kubernetes
  • microsoft
  • openshift
  • openstack
  • redhat
  • vmware
Платформа виртуальных машин для VMM-доменов.
Поддержка Kubernetes была добавлена в ACI v3.0.
Поддержка CloudFoundry, OpenShift и Red Hat была добавлена в ACI v3.1.

Примечания

Примечание

  • Параметры domain и vlan_pool должны существовать перед использованием этого модуля. Для этого можно использовать модули aci_domain и aci_vlan_pool.
  • Дополнительную информацию об внутренней класс APIC infra:RsVlanNs можно найти в справочнике по модели управления информацией APIC .

См. также

См. также

Руководство по Cisco ACI
Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
Разработка модулей Cisco ACI
Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.

Примеры

- name: Bind a VMM domain to VLAN pool
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: vmw_dom
    domain_type: vmm
    pool: vmw_pool
    pool_allocation_mode: dynamic
    vm_provider: vmware
    state: present
  delegate_to: localhost

- name: Remove a VMM domain to VLAN pool binding
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: vmw_dom
    domain_type: vmm
    pool: vmw_pool
    pool_allocation_mode: dynamic
    vm_provider: vmware
    state: absent
  delegate_to: localhost

- name: Bind a physical domain to VLAN pool
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: phys_pool
    pool_allocation_mode: static
    state: present
  delegate_to: localhost

- name: Bind a physical domain to VLAN pool
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: phys_pool
    pool_allocation_mode: static
    state: absent
  delegate_to: localhost

- name: Query an domain to VLAN pool binding
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: phys_pool
    pool_allocation_mode: static
    state: query
  delegate_to: localhost
  register: query_result

- name: Query all domain to VLAN pool bindings
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain_type: phys
    state: query
  delegate_to: localhost
  register: query_result

Возвращаемые значения

Общие возвращаемые значения описаны здесь, следующие поля уникальны для этого модуля:

Ключ Возвращено Описание
current
список
успех
Текущая конфигурация с APIC после завершения модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
error
словарь
ошибка
Информация об ошибке, возвращенная APIC

Пример:
{'code': '122', 'text': 'неизвестный класс управляемого объекта foo'}
filter_string
строка
ошибка или отладка
Строка фильтра, используемая для запроса

Пример:
?rsp-prop-include=config-only
method
строка
ошибка или отладка
HTTP-метод, используемый для запроса к APIC

Пример:
POST
previous
список
информация
Исходная конфигурация с APIC до запуска модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
proposed
словарь
информация
Собранная конфигурация из параметров пользователя

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}}
raw
строка
ошибка разбора
Необработанный результат, возвращенный APIC REST API (xml или json)

Пример:
<?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata>
response
строка
ошибка или отладка
HTTP-ответ от APIC

Пример:
OK (30 байт)
sent
список
информация
Фактическая/минимальная конфигурация, отправленная в APIC

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда'}}}
status
целое число
ошибка или отладка
HTTP-статус от APIC

Пример:
200
url
строка
ошибка или отладка
HTTP-адрес, используемый для запроса к APIC

Пример:
https://10.11.12.13/api/mo/uni/tn-production.json


Статус

  • Этот модуль не гарантирует обратной совместимости. [превью]
  • Этот модуль поддерживается партнером Ansible. [сертифицировано]

Авторы

  • Dag Wieers (@dagwieers)

Подсказка

Если вы обнаружите проблемы в этом документе, вы можете отредактировать его, чтобы улучшить его.

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.7/modules/aci_domain_to_vlan_pool_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API