aci_encap_pool – Управление пулами encaps (fvns:VlanInstP, fvns:VxlanInstP, fvns:VsanInstP)
Новая версия с 2.5.
Обзор
- Управление пулами vlan, vxlan и vsan на фэбриках Cisco ACI.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| certificate_name - | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. По умолчанию используется private_key без расширения.Псевдонимы: cert_name | |
| description - | Описание для pool.Псевдонимы: descr | |
| host - / обязательно | IP-адрес или имя хоста APIC, разрешаемые хостом управления Ansible. Псевдонимы: hostname | |
| output_level - |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, вкл. current dictinfo добавляет информативный вывод, вкл. previous, proposed и sent dictsdebug добавляет отладочный вывод, вкл. filter_string, method, response, status и url информацию |
| password - / обязательно | Пароль для аутентификации. Этот параметр взаимно исключается с private_key. Если также указан private_key, то он будет использован вместо него. | |
| pool - | Имя пула. Псевдонимы: name, pool_name | |
| pool_allocation_mode - |
| Метод, используемый для распределения encaps ресурсам. Только vlan и vsan поддерживают режимы распределения. Псевдонимы: allocation_mode, mode |
| pool_type - / обязательно |
| Тип encaps pool.Псевдонимы: type |
| port - | Номер порта для подключения REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| private_key - / обязательно | Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи. Имя ключа (без расширения) используется как имя сертификата в ACI, если не указан certificate_name.Этот параметр взаимно исключается с password. Если также указан password, он будет проигнорирован.Псевдонимы: cert_key | |
| state - |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| timeout целое число | Значение по умолчанию: 30 | Таймаут на уровне сокета в секундах. |
| use_proxy булево |
| Если no, прокси не будет использоваться, даже если он определён в переменной среды на целевых хостах. |
| use_ssl булево |
| Если no, будет использовано HTTP-соединение вместо стандартного HTTPS-соединения. |
| username - | Значение по умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs булево |
| Если no, сертификаты SSL не будут проверены.Это следует устанавливать в no только при использовании на контролируемых сайтах с самоподписанными сертификатами. |
Примечания
Примечание
- Дополнительную информацию о внутренних классах APIC fvns:VlanInstP, fvns:VxlanInstP и fvns:VsanInstP можно найти в справочнике по модели управления информацией APIC.
См. также
См. также
- Руководство по Cisco ACI
- Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Add a new vlan pool
aci_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
description: Production VLANs
state: present
delegate_to: localhost
- name: Remove a vlan pool
aci_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
state: absent
delegate_to: localhost
- name: Query a vlan pool
aci_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
state: query
delegate_to: localhost
register: query_result
- name: Query all vlan pools
aci_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
pool_type: vlan
state: query
delegate_to: localhost
register: query_result
Возвращаемые значения
Общие значения возврата задокументированы здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация из APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращенная APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Метод HTTP, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация из APIC до начала модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Сборка конфигурации из параметров, предоставленных пользователем Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный результат, возвращенный API REST APIC (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-адрес, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратной совместимости. [превью]
- Этот модуль поддерживается партнером Ansible. [сертифицировано]
Авторы
- Jacob McGill (@jmcgill298)
Подсказка
Если вы заметили какие-либо проблемы в этом документе, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.7/modules/aci_encap_pool_module.html