aci_encap_pool_range – Управление диапазонами encap, назначенными пулам (fvns:EncapBlk, fvns:VsanEncapBlk)
Новая версия 2.5.
Обзор
- Управление диапазонами vlan, vxlan и vsan, назначенными пулам на Cisco ACI устройствах.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| allocation_mode - |
| Метод, используемый для выделения encaps для ресурсов. Только vlan и vsan поддерживают режимы выделения. псевдонимы: режим |
| certificate_name - | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. По умолчанию равно private_key basename без расширения.псевдонимы: имя_сертификата | |
| description - | Описание диапазона пула. псевдонимы: описание | |
| host - / обязательно | IP-адрес или имя хоста, разрешаемое хостом управления Ansible. псевдонимы: имя_хоста | |
| output_level - |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current dictinfo добавляет информативный вывод, включая previous, proposed и sent dictsdebug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию |
| password - / обязательно | Пароль для аутентификации. Этот параметр взаимоисключает private_key. Если также указан private_key, он будет использован вместо этого. | |
| pool - | Имя пула, которому должен быть назначен диапазон. псевдонимы: имя_пула | |
| pool_allocation_mode - |
| Метод, используемый для выделения encaps для ресурсов. Только vlan и vsan поддерживают режимы выделения. псевдонимы: режим_пула |
| pool_type - / обязательно |
| Тип encaps pool. псевдонимы: тип |
| port - | Порт, используемый для подключения REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| private_key - / обязательно | Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи. Имя ключа (без расширения) используется как имя сертификата в ACI, если не указано certificate_name. Этот параметр взаимоисключает password. Если также указан password, он будет проигнорирован.псевдонимы: ключ_сертификата | |
| range_end целое число | Конец диапазона encaps. псевдонимы: конец | |
| range_name - | Имя, которое нужно присвоить диапазону encaps. псевдонимы: имя, диапазон | |
| range_start целое число | Начало диапазона encaps. псевдонимы: начало | |
| state - |
| Используйте present или absent для добавления или удаления.Используйте query для отображения объекта или нескольких объектов. |
| timeout целое число | По умолчанию: 30 | Таймаут на уровне сокета в секундах. |
| use_proxy булево |
| Если no, прокси не будет использоваться, даже если он определен в переменной среды на целевых хостах. |
| use_ssl булево |
| Если no, вместо стандартного соединения HTTPS будет использовано соединение HTTP. |
| username - | По умолчанию: "admin" | Имя пользователя для аутентификации. псевдонимы: пользователь |
| validate_certs булево |
| Если no, сертификаты SSL не будут проверены.Это следует задать no, только когда используется на контролируемых вами сайтах с самозаверяющими сертификатами. |
Примечания
Примечание
poolдолжен существовать для добавления или удаления диапазона.- Дополнительную информацию о внутренних классах APIC fvns:EncapBlk и fvns:VsanEncapBlk см. в справочнике по модели управления информацией APIC.
См. также
См. также
- Руководство по Cisco ACI
- Подробная информация о том, как управлять вашей инфраструктурой Cisco ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Add a new VLAN pool range
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
pool_allocation_mode: static
range_name: anstest
range_start: 20
range_end: 40
allocation_mode: inherit
state: present
delegate_to: localhost
- name: Remove a VLAN pool range
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
pool_allocation_mode: static
range_name: anstest
range_start: 20
range_end: 40
state: absent
delegate_to: localhost
- name: Query a VLAN range
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
pool_allocation_mode: static
range_name: anstest
range_start: 20
range_end: 50
state: query
delegate_to: localhost
register: query_result
- name: Query a VLAN pool for ranges by range_name
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool_type: vlan
range_name: anstest
state: query
delegate_to: localhost
register: query_result
- name: Query a VLAN pool for ranges by range_start
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool_type: vlan
range_start: 20
state: query
delegate_to: localhost
register: query_result
- name: Query a VLAN pool for ranges by range_start and range_end
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool_type: vlan
range_start: 20
range_end: 40
state: query
delegate_to: localhost
register: query_result
- name: Query all VLAN pool ranges
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool_type: vlan
state: query
delegate_to: localhost
register: query_result
Возвращаемые значения
Общие возвращаемые значения описаны в этой статье, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация из APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращенная из APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Используемый HTTP-метод для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация из APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собранная конфигурация из параметров, предоставленных пользователем Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращенный APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-url, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратную совместимость. [превью]
- Этот модуль поддерживается партнером Ansible. [сертифицировано]
Авторы
- Jacob McGill (@jmcgill298)
Подсказка
Если вы заметили проблемы в этом документе, вы можете отредактировать его для улучшения.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.7/modules/aci_encap_pool_range_module.html